none
Event Log is Flooded

    Question

  • I have log shipping set up with the secondary server restoring in standby mode. I see the following 9 messages in the event viewer for every database I've setup with log shipping.  That's about 360 messages every 15 minutes for me.  It's made the event viewer useless because everything gets lost in this flood of messages.  I can't even maintain 24 hours of events because it fills up before then.

    11:32:41 AM  Setting database option SINGLE_USER to ON for database <db_name>.
    11:32:41 AM  Setting database option SINGLE_USER to ON for database <db_name>.
    11:32:41 AM  Starting up database '<db_name>'.
    11:32:41 AM  The database '<db_name>' is marked RESTORING and is in a state that does not allow recovery to be run.
    11:32:42 AM  Recovery is writing a checkpoint in database '<db_name>' (30). This is an informational message only. No user action is required.
    11:32:42 AM  Starting up database '<db_name>'.
    11:32:42 AM  CHECKDB for database '<db_name>' finished without errors on 2007-10-28 02:18:50.427 (local time). This is an informational message only; no user action is required.
    11:32:42 AM  Setting database option MULTI_USER to ON for database <db_name>.
    11:32:42 AM  Setting database option MULTI_USER to ON for database <db_name>.

    (Yes, the copies are actually in there twice and it is only restoring one (1) TRN file)

    My question is:

    Is there a way to turn off this deluge of informational events but still keep warnings/errors?

    Friday, July 11, 2008 4:51 PM

All replies

  • Well I thought this was a simple enough question.  Guess not...
    Tuesday, July 15, 2008 2:51 PM
  • You can use the trace flag 3226 to suppress logging of successful events. Kevin Farlee of the SQL Server Storage Engine Team has a blog post on this

    Wednesday, July 16, 2008 7:45 AM
    Moderator
  • I've seen this solution around, but unfortunately the flag only supresses events for successful backups.  I've already implemented the flag on my Primary server and need to suppress successful restore events on the Secondary server.
    Friday, July 25, 2008 5:26 PM
  • I have log shipping set up with the secondary server restoring in standby mode. I see the following 9 messages in the event viewer for every database I've setup with log shipping.  That's about 360 messages every 15 minutes for me.  It's made the event viewer useless because everything gets lost in this flood of messages.  I can't even maintain 24 hours of events because it fills up before then.

    11:32:41 AM  Setting database option SINGLE_USER to ON for database <db_name>.
    11:32:41 AM  Setting database option SINGLE_USER to ON for database <db_name>.
    11:32:41 AM  Starting up database '<db_name>'.
    11:32:41 AM  The database '<db_name>' is marked RESTORING and is in a state that does not allow recovery to be run.
    11:32:42 AM  Recovery is writing a checkpoint in database '<db_name>' (30). This is an informational message only. No user action is required.
    11:32:42 AM  Starting up database '<db_name>'.
    11:32:42 AM  CHECKDB for database '<db_name>' finished without errors on 2007-10-28 02:18:50.427 (local time). This is an informational message only; no user action is required.
    11:32:42 AM  Setting database option MULTI_USER to ON for database <db_name>.
    11:32:42 AM  Setting database option MULTI_USER to ON for database <db_name>.

    (Yes, the copies are actually in there twice and it is only restoring one (1) TRN file)

    My question is:

    Is there a way to turn off this deluge of informational events but still keep warnings/errors?


    Hi DreWerD, 

    Did you ever find the solution for this issue? 

    Thanks,

    Monday, January 21, 2013 6:13 PM