none
Failed to acquire connection / The AcquireConnection method Failed

    Question

  • I am running the Sept CTP.  I have created a SSIS package that pulls data from a text file and inserts into a database.  When I run the package on the DB server it runs fine.  I have moved the package the the web server (we are attempting to kick off the package from a web site) and we get connections errors. We are running the package using dtexec from the command line.

    The 1st time we got
    The AcquireConnection method call to the connection manager "Program DW" failed with error code 0x80004005.
    One post I read said that changing the DelayValidation to true may help. 

    I set the DelayValidation to true on all the packages and I now get this error:
    Failed to acquire connection "Program DW". Connection may not be configured correctly or you may not have the right permissions on this connection.

    What do I need to do to make sure that the permission is configured properly?


    Friday, November 11, 2005 5:10 PM

All replies

  • Does the package use stored credentials for the database?  If so, your problem may not be because you moved the package, but because it is being run in a different security context.  By default, SSIS secures stored sensitive data with a user key.  If you access the package as another user, that sensitive data won't be available.  That may be what is happening.  You may need to change the ProtectionLevel to EncryptSensitiveWithPassword and then run dtexec with that password from your web page.

    See "Setting the Protection Level of Packages" in BOL.
     
    • Proposed as answer by piris Wednesday, October 03, 2012 3:49 PM
    Friday, November 11, 2005 7:41 PM
  • I have turn the security setting to DontSaveSensitive.  The master package has a variable called dbConnection and we store the entire connection string.  It is passes to all the packages and we have an expression set the connection string.

    Friday, November 11, 2005 7:50 PM
  •  Wollmatt wrote:

    I have turn the security setting to DontSaveSensitive.  The master package has a variable called dbConnection and we store the entire connection string.  It is passes to all the packages and we have an expression set the connection string.



    Did that work, you didn't actually say whether it did or not? I would be surprised if it did not.

    I do something similar where I store the connection string in a configuration. Security needs to be enforced at some point and in this instance you need to make sure that no-one can get onto the box that shouldn't be allowed to - otherwise they could just open the config file in notepad and get the password.

    -Jamie
    Monday, November 14, 2005 4:21 PM
    Moderator
  • Sorry.  That was the original configuration.  So it does not work.

    We are aware of the security risk of passing the connection string. The package will not store the string, it will be passed in as a package variable.  Thank you for the advice.

    Monday, November 14, 2005 4:30 PM
  • We are facing the very same problem - did you resolve this?  if so, may we ask how?
    Wednesday, March 22, 2006 6:04 PM
  • We were not able to resolve this issue.  The SQL 2005 SP1 CTP (March 2006) release may help.

    http://www.microsoft.com/downloads/details.aspx?familyid=39ebef74-1c29-49fe-8221-c94f2b52f6c6&displaylang=en

    Thursday, March 23, 2006 6:12 PM
  • Hello,

    I was able to resolve this issue by manually editing my dtsx file in a text editor.  The issue was caused when I was setting up a Package Configuration in which I inadvertantly selected the option to save the inital catalog.  I created a new connection from scratch which worked.  Then in the text editor I looked for differences. In the DTSX file the catalog was stored as "Initial Catalog=;" (semi-colon). I removed the entire tag for the initial catalog and then it worked.  If you are going to try this make a copy first in case of bad editing.  Also, I'm sure Microsoft won't recommend this option.

    Best of luck.

    -bob-

    • Proposed as answer by laurensp Wednesday, October 26, 2011 8:56 AM
    Tuesday, April 11, 2006 7:05 PM