none
Text Qualifier in Flat File Source in SSIS

    Question

  • Hi All,

    I am loading a .csv file into a table. But My problem is as below.

    Source file should ideally  contain the values as below,

    Id, Company Name,Company Desc, Employees

    1,abc,abc desc,100

    But the SSIS package has should also load the file if the data is some thing like this

    Id, Company Name,Company Desc, Employees

    1,"abc,xyz","abc,xyz,desc",100

    This means, if the name is enclosed in a quote, the value inside the quote must be taken for loading. I have used text qualifiers.. But Its now working. Please let me know if anyone have idea on this.

    Thanks,

    Rajesh

    Wednesday, February 13, 2013 11:44 AM

Answers

  • Tried with different kinds of data:

    Id, Company Name,Company Desc, Employees
    1,"abc,xyz","abc,xyz,desc",100
    2,"abc,xyz","abc,xyz,desc",100
    3,"abc,xyz","abc,xyz,desc","100"
    "4","abc,xyz","abc,xyz,desc",100

    Regards,Eshwar.


    Please don't forget to Marked as Answer if my post solved your problem and use Vote As Helpful if a post was useful. It will helpful to other users.


    Wednesday, February 13, 2013 12:10 PM

All replies

  • give these settings it will work:

    Defined Text qualifier " it worked:

    Regards,Eshwar.


    Please don't forget to Marked as Answer if my post solved your problem and use Vote As Helpful if a post was useful. It will helpful to other users.



    Wednesday, February 13, 2013 11:54 AM
  • Tried with different kinds of data:

    Id, Company Name,Company Desc, Employees
    1,"abc,xyz","abc,xyz,desc",100
    2,"abc,xyz","abc,xyz,desc",100
    3,"abc,xyz","abc,xyz,desc","100"
    "4","abc,xyz","abc,xyz,desc",100

    Regards,Eshwar.


    Please don't forget to Marked as Answer if my post solved your problem and use Vote As Helpful if a post was useful. It will helpful to other users.


    Wednesday, February 13, 2013 12:10 PM
  • Yes.. Its working.. The problem was, I edited my .csv file excel. So it was inserting two double quotes and thats why it was not working.

    Wednesday, February 13, 2013 1:47 PM