none
Create database permision denied in database ' master' (MS SQL SERVER, ERROR 262

    Question

  • Cn not do anything with my sql server, everything i trt to do i get this message, user does not have permision, etc, ,

    I am running windows Vista Business, SQL SERVER 2005

    so what going on here

     

    Saturday, February 17, 2007 12:26 AM

Answers

All replies

  • SQL Server SP1 is not supported on Vista... U must have SQL Server SP2... but sp2 is in CTP version... SP2 is to be released soon...so wait for a while...

     

    http://www.microsoft.com/sql/howtobuy/windowsvistasupport.mspx

     

    Madhu

     

    Saturday, February 17, 2007 1:44 PM
  • True and try to test it on a other Windows edition and see the user privileges are not an issue.
    Sunday, February 18, 2007 1:51 PM
    Moderator
  • Just tryed with SP2.  Got the same error.  This is fun.  Can any Microsoft MVP enlighten us please?
    Wednesday, February 28, 2007 10:37 PM
  • Have a look at this article:

    http://msdn2.microsoft.com/en-us/library/bb326612.aspx

    Thanks
    Laurentiu

    Friday, March 02, 2007 6:34 PM
    Moderator
  • Thank you very much. I spent some time to try to work with the SQL server management studio express on a VISTA machine and I could not figure out why I could not perform simple things like creating a new database. I became a bit frustrated by messages like  : CREATE DATABASE permission denied in database 'master'; user does not have permission to perform this action; and SQL server error 262. Now I know it have to wait. This is not something I can not solve myself

      

    Monday, April 14, 2008 8:26 PM
  • Hey...

    Just start the management studio with administrator rights...

    ie: go to it from the start menu and right click it....then select run as administrtor..(if you are on vista you should have this option)

    it worked for me...

    All the best

     

     

    Friday, May 16, 2008 10:47 PM
  • havign same problem, been kicking myself in the head for an hour, keep forgeting about run as admin..

    Worked fine

    thanks

    Friday, August 01, 2008 2:16 PM
  • He.. Yeah, it works

     

    I have been trying fro several hours, searching google, various sites for some answers.

     

    Just open it as an administrator.

     

    Why does Vista suck with these programs?

    Just "Keep It Simple Stupid"....

     

    Tuesday, August 12, 2008 9:01 PM
  •   You don't need to elevate to a full administrator token every time (actually I would recommend not to do it). As the article that Laurentiu pointed out, there is an easier solution.

     

      You still need to elevate to "run as administrator" once in order to connect as a member of sysadmin, then you can create a login for yourself and add yourself to sysadmin fixed server role. Once this step is done, next time you start from a UAC token in Vista you will be a member of sysadmin.

     

      Also notice that on SQL Server 2008 the assumption that builtin\Administrators are sysadmins is no longer true (See "SQL Server 2008 Security Changes" for more information). During setup it will be required to specify an explicit administrator account (there is a "quick-button" to add your current credentials as administrator).

     

    -Raul Garcia

      SDE/T

      SQL Server Engine

     

    Tuesday, August 12, 2008 10:20 PM
    Moderator
  • thanx wasif it works for me i was going to format my vista but at last ur post give me a chance to live with vista :-) thanx again 
    take care 
    god bless u Smile
    Thursday, September 25, 2008 7:43 PM
  • Hi, thank you so much for your simple, powerful advise!!! After all day struggle, with your help I can create a database!!!!!!!!!

    so now i am thinking how you found out about this solution? and another thing is how long this painful opening of SMSE will carry on? Thanks again!

    Wednesday, November 12, 2008 10:02 PM
  •  Raul Garcia - MS wrote:

      You don't need to elevate to a full administrator token every time (actually I would recommend not to do it). As the article that Laurentiu pointed out, there is an easier solution.

     

      You still need to elevate to "run as administrator" once in order to connect as a member of sysadmin, then you can create a login for yourself and add yourself to sysadmin fixed server role. Once this step is done, next time you start from a UAC token in Vista you will be a member of sysadmin.

     

      Also notice that on SQL Server 2008 the assumption that builtin\Administrators are sysadmins is no longer true (See "SQL Server 2008 Security Changes" for more information). During setup it will be required to specify an explicit administrator account (there is a "quick-button" to add your current credentials as administrator).

     

    -Raul Garcia

      SDE/T

      SQL Server Engine

     

     

    Hi, I tried but failed, please tell me in very simple instruction what to do to set up myself as sysadmin so I dont have to go to start and right click everytime!?

     

    Thank you for your help

     

    Wednesday, November 12, 2008 10:30 PM
  • thanx for your information.this was very useful to me.

     

    Tuesday, December 02, 2008 2:37 AM
  •  i was having this problem on vista too and got solved by opening management studio with admin rights. Thanks for your post.
    Tuesday, January 27, 2009 7:10 AM
  •  
    Vasif Nagarwala

    Thank You.
    Admin Rights "Run as Admin"  worked right away


    Vista Ultimate

    Joe P
    Monday, February 16, 2009 4:46 PM
  • hai buddy. I tried your infor and got the solution. actually i tried this at long time but your infor help me. THANK YOU.
    Sunday, September 26, 2010 1:31 PM
  • To add a Windows user that has the login "machinename\Administrator" to the sysadmin fixed server role

    1. Log on to the computer using the credentials for the machinename\Administrator account.

    2. Click the Start button, point to All Programs, click Microsoft SQL Server, and then click SQL Server Management Studio.

    3. Connect to an instance of SQL Server.

    4. Click Security, right-click Logins, and then click New Login.

    5. In the Login name box, enter the user name.

    6. In the Select a page pane, click Server Roles, select the sysadmin check box, and then click OK.

    Monday, April 11, 2011 4:25 PM
  • The problem is easy.. Just go to: *Start *All Programs *Microsoft SQL Server *Right click the "Microsoft SQL Server Management Stud. *Properties *Compatibility *[Check] "Run this program in compatibility mode for: "Windows XP (Service Pack 3)" *[Check] "Run this program as an administrator" then click ok to apply the settings you made. test the Program and its now working.. ^_^
    Monday, May 16, 2011 8:06 AM
  • thanx genious... it worked for me..!!!
    Saturday, August 20, 2011 9:48 PM
  • wow i did it you did it but im happy

    internet google.com did it

    Sunday, September 18, 2011 5:59 PM