none
Big Problems with SQL Express

    Question

  • Hi @all...

     

    I have some big troubles with my SQL Express. No matter what I do on it, it sends me a message, that it isn't able to connect the server because t isn't able to open the default database for the user.

     

    pls help me

     

    Thanks FreakMan

    Thursday, November 22, 2007 2:56 PM

Answers

  • Check the default datbase of the Login you are using to connect. The database should exists.

     

    run this statement and then try to login

     

    EXEC sp_defaultdb 'YourUserName', 'Master'

     

    http://support.microsoft.com/kb/307864

     

    Madhu

    Thursday, November 22, 2007 3:00 PM
    Moderator
  • Hello!

     

    When you open up SSMSE you'll meet a window "Connect to Server". In that window there is a button labeled "Options" at the right bottom corner. Click on it and change "Connect to database" option to "master" or something your Login is mapped... And then change your Login' s default database as Madhu mentioned.

     

     

    Thursday, November 22, 2007 10:45 PM

All replies

  • Check the default datbase of the Login you are using to connect. The database should exists.

     

    run this statement and then try to login

     

    EXEC sp_defaultdb 'YourUserName', 'Master'

     

    http://support.microsoft.com/kb/307864

     

    Madhu

    Thursday, November 22, 2007 3:00 PM
    Moderator
  • Hello!

     

    When you open up SSMSE you'll meet a window "Connect to Server". In that window there is a button labeled "Options" at the right bottom corner. Click on it and change "Connect to database" option to "master" or something your Login is mapped... And then change your Login' s default database as Madhu mentioned.

     

     

    Thursday, November 22, 2007 10:45 PM
  • Hi @all...

     

    Thank you a lot for help. Both solutions worked really fine.

     

    It's nice too know that, because else I coudn't work on.

     

    Thx to both...

    FreakMan

    Friday, November 23, 2007 6:40 AM