none
"Prior Visual Studio 2010 Instance Requiring Update" Failed

    Question

  • Hi,

    I'm trying to install BIDS and SSMS for SQL Server 2012 on my machine. However, I can't get passed validation step that indicates SP1 needs to be installed for Visual Studio 2010. However, I have installed an re-installed VS2010 SP1 already.

    Has anyone had the same problem?

    • Moved by Naomi N Monday, August 06, 2012 7:23 PM Better answer can be here (From:Transact-SQL)
    Monday, August 06, 2012 6:34 PM

All replies

  • Thanks Alberto,

    I tried all of this and it didn't work for me. I have VS2010 Express and VS2010 Ultimate installed and they are both on SP1. I have tried to uninstall the express version but that proved to be challenge in itself.

    Thanks for your help.

    Aleks B

    Tuesday, August 07, 2012 2:51 PM
  • Could you try re-applying VS 10 SP1 again.

    Regards,
    Ahmed Ibrahim
    SQL Server Setup Team
    My Blog
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you.
    This can be beneficial to other community members reading the thread.

    Tuesday, August 07, 2012 6:28 PM
  • I have re-applied VS2010 SP1 (for the third time) but it didn't help. I can't get passed the validation point where VS10 SP1 is ismply not recognized by the installation package.

    Very dissappointing.

    Thursday, August 09, 2012 11:58 PM
  • Would you please share/upload SQL Server setup logs

    http://social.msdn.microsoft.com/Forums/en-US/sqlexpress/thread/248589b0-773c-4ef0-acd9-9248c38211d8/


    Regards,
    Ahmed Ibrahim
    SQL Server Setup Team
    My Blog
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you.
    This can be beneficial to other community members reading the thread.

    Friday, August 10, 2012 1:55 AM
  • I don't know if we still have this problem or not, but today I am trying to install the SSDT both from webinstaller and the disk media both failed. Saying the same thing. Any ideas?

    Friday, September 14, 2012 6:32 PM
  • I was having similar issues all day today - kept applying VS2010 SP1 from a variety of sources and still got this issue - after digging into my the SQL server 2012 install logs, I saw this:

    (11) 2012-10-30 20:18:48 Slp: Package ID WPExpress_Cpu32: Installed - Version: 10.0.30319

    I had an old windows phone developer tools beta installed that was causing the installer to get confused about whether VS2010 was up to date or not... it was even still giving me this error after I had uninstalled VS 2010 completely (or so I thought)...

    My advice - check the logs (%program files%\Microsoft SQL Server\110\Setup Bootstrap\Log\<some datetime stamp>\detail.txt

    Find the section related to the 2010 SP1 patch rule and see what it's getting confused about.  It may not be 100% obvious that WPExpress == Windows Phone, but sometimes grey matter > computer.

    Good luck,

    Todd

    Wednesday, October 31, 2012 2:14 AM
  • Hello,

       I'm still having the same issue all the week long, with no luck. Applies the SP1 many times, removed any express software, even remove all the VS2010 and still having the same issue.

      Here is the details from the log file: (basically failing because of (03) 2012-11-27 09:38:30 Slp: The package 'WPExpress_Cpu32' is installed. which I don't have it on my box)

    03) 2012-11-27 09:38:29 Slp: Init rule target object: Microsoft.SqlServer.Configuration.SetupExtension.DetectInstalledProductsFacet
    (03) 2012-11-27 09:38:29 Slp: Package ID VSIntShellRTM_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:29 Slp: Package ID VSIsoShellRTM_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:29 Slp: Package ID VBExpress_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:29 Slp: Package ID VCSExpress_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:29 Slp: Package ID VCExpress_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:29 Slp: Package ID WPExpress_Cpu32: Installed - Version: 10.0.30319
    (03) 2012-11-27 09:38:29 Slp: Package ID VSPremium_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:29 Slp: Package ID VSPro_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:29 Slp: Package ID VSTE_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:30 Slp: Package ID VSUltimate_Cpu32: Installed - Version: 10.0.40219
    (03) 2012-11-27 09:38:30 Slp: Package ID VSLabAgent_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:30 Slp: Package ID VSTestAgent_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:30 Slp: Package ID VSTestController_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:30 Slp: Package ID VWDExpress_Cpu32: NotInstalled
    (03) 2012-11-27 09:38:30 Slp: The package 'WPExpress_Cpu32' is installed.
    (03) 2012-11-27 09:38:30 Slp: The package 'VSUltimate_Cpu32' exceeds the max version limit, it will not be detected as installed.
    (03) 2012-11-27 09:38:30 Slp: Rule 'DEV10RTMDetected' detection result: AreAnyProductsInstalled= True
    (03) 2012-11-27 09:38:30 Slp: Evaluating rule        : DEV10RTMDetected
    (03) 2012-11-27 09:38:30 Slp: Rule running on machine: GASERNADEEMDEV3
    (03) 2012-11-27 09:38:30 Slp: Rule evaluation done   : Failed

    Tuesday, November 27, 2012 5:39 PM
  • So did you check for windows phone installed packages in control panel ?

    FAQ
    ----
    Regards,
    Ahmed Ibrahim
    SQL Server Setup Team
    My Blog
    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" and "Vote as Helpful" on posts that help you.
    This can be beneficial to other community members reading the thread.
    View Ahmed Ibrahim's profile on LinkedIn

    Thursday, November 29, 2012 4:27 AM