none
Cannot connect to Integration Services with SQL Server Management Studio

    Question

  • I am unable to connect to Integration Services with SSMS, and get the message below.

    I have tried the solutions suggested and set the permissions as per the documentation. The service is running and starts / restarts with no errors.

    Any help would be appreciated

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to SERVER-PC.

    ------------------------------
    ADDITIONAL INFORMATION:

    Failed to retrieve data for this request. (Microsoft.SqlServer.Management.Sdk.Sfc)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&LinkId=20476

    ------------------------------

    Connecting to the Integration Services service on the computer "SERVER-PC" failed with the following error: "Access is denied."

    By default, only administrators have access to the Integration Services service. On Windows Vista and later, the process must be running with administrative privileges in order to connect to the Integration Services service. See the help topic for information on how to configure access to the service.


    For help, click: http://go.microsoft.com/fwlink/?LinkId=220763

    ------------------------------

    Connecting to the Integration Services service on the computer "SERVER-PC" failed with the following error: "Access is denied."

    By default, only administrators have access to the Integration Services service. On Windows Vista and later, the process must be running with administrative privileges in order to connect to the Integration Services service. See the help topic for information on how to configure access to the service.


    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Friday, September 28, 2012 5:46 PM

Answers

All replies

  • Start SSMS as Admin after implementing KB2000474

    Arthur My Blog

    • Marked as answer by longinthetooth Friday, September 28, 2012 6:21 PM
    Friday, September 28, 2012 6:09 PM
    Moderator
  • I forgot to mention, its SQL 2012 Developer Edition....
    Friday, September 28, 2012 6:17 PM
  • Restarted SSMS anyway as Administrator as per you reply and it works! Thanks for that.
    Friday, September 28, 2012 6:21 PM
  • I forgot to mention, its SQL 2012 Developer Edition....

    Glad I was able to help. The issue you described is indeed only SSMS 2012 related which works by default under much more unprivileged rights.

    Arthur My Blog

    Friday, September 28, 2012 6:26 PM
    Moderator
  • Hi ArthurZ,

    I am getting same problem. The server is 10.50.4000. I am getting error when I tried to connect to Integration Services remotely. the error is about DCOM settings. 

    Using KB article, i added my login to DCOM security settings and also added it to Distributed COM users group; restarted SSIS services; started SSMS as administrator. The error is still there. 

    what else can I try?

    Thanks,

    Wednesday, May 15, 2013 9:51 PM
  • Do you start SSMS as Admin?


    Arthur My Blog

    Thursday, May 16, 2013 2:41 PM
    Moderator
  • Yeah, I have tried that as well. I think I should try to reboot the server. 

    One thing I found is about different error messages when I use different SSMSs. I do have SSMS2008R2 and SSMS2012 on my system. I wonder if two versions of SSMS may be causing some problem. 

    Here's the error message with SSMS2008R2. 

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to SERVERNAME.

    ------------------------------
    ADDITIONAL INFORMATION:

    Failed to retrieve data for this request. (Microsoft.SqlServer.Management.Sdk.Sfc)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&LinkId=20476

    ------------------------------

    Connecting to the Integration Services service on the computer "SERVERNAME" failed with the following error: "Access is denied.
    ".

    This error occurs when the computer has not been configured to allow remote connections through DCOM, or the user does not have permission to access the SQL Server Integration Services service through DCOM.


    ------------------------------

    Connecting to the Integration Services service on the computer "SERVERNAME" failed with the following error: "Access is denied.
    ".

    This error occurs when the computer has not been configured to allow remote connections through DCOM, or the user does not have permission to access the SQL Server Integration Services service through DCOM.


    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Here's the error message with SSMS2012:

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to SERVERNAME.

    ------------------------------
    ADDITIONAL INFORMATION:

    Failed to retrieve data for this request. (Microsoft.SqlServer.Management.Sdk.Sfc)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&LinkId=20476

    ------------------------------

    Connecting to the Integration Services service on the computer "SERVERNAME" failed with the following error: "Access is denied."

    By default, only administrators have access to the Integration Services service. On Windows Vista and later, the process must be running with administrative privileges in order to connect to the Integration Services service. See the help topic for information on how to configure access to the service.


    For help, click: http://go.microsoft.com/fwlink/?LinkId=220763

    ------------------------------

    Connecting to the Integration Services service on the computer "SERVERNAME" failed with the following error: "Access is denied."

    By default, only administrators have access to the Integration Services service. On Windows Vista and later, the process must be running with administrative privileges in order to connect to the Integration Services service. See the help topic for information on how to configure access to the service.


    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Thursday, May 16, 2013 3:27 PM
  • ANSWER:

    Control Panel > User Accounts > Change User Account Control Settings > Drag Notification slider bar all the way to the bottom (Never Notify).

    You can now connect to Integration Services from the server.

    Friday, May 09, 2014 2:17 PM