none
Weird BIDS error message

    Question

  • For some unknown reason, I'm suddenly experiencing the following error when I open a package in BIDS:

    Error    1          Error loading DimPromotionDemo.dtsx: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not found.              c:\mdwt_projects\aworders_simple\aworders_simple\aworders_simple\DimPromotionDemo.dtsx  1          1           

     

    I don't see any error icons anywhere in my package.  How do I go about figuring out what's wrong?

    Friday, December 15, 2006 6:42 AM

Answers

  •  Duane Douglas wrote:

    For some unknown reason, I'm suddenly experiencing the following error when I open a package in BIDS:

    Error    1          Error loading DimPromotionDemo.dtsx: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not found.              c:\mdwt_projects\aworders_simple\aworders_simple\aworders_simple\DimPromotionDemo.dtsx  1          1           

     

    I don't see any error icons anywhere in my package.  How do I go about figuring out what's wrong?

    I figured out what was causing the error.  While developing the package, I created a SQL Server log provider, but neglected to specify a connection manager.  The error message went away when I deleted the log provider.

    It would've been a lot more graceful for the SSIS designer to trap the error when I clicked the "OK" button in the Configure SSIS Logs dialog box.

    Saturday, December 16, 2006 6:07 AM

All replies

  • It could be that previously you'd have deleted any connection and now, when you're going to open again...
    Friday, December 15, 2006 8:03 AM
  •  enric vives wrote:
    It could be that previously you'd have deleted any connection and now, when you're going to open again...
    Well, I didn't previously delete any connection.  Also, there isn't any error icon showing up in the SSIS Designer (although I think there should be when this kind of thing occurs).
    Saturday, December 16, 2006 3:58 AM
  •  Duane Douglas wrote:

    For some unknown reason, I'm suddenly experiencing the following error when I open a package in BIDS:

    Error    1          Error loading DimPromotionDemo.dtsx: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not found.              c:\mdwt_projects\aworders_simple\aworders_simple\aworders_simple\DimPromotionDemo.dtsx  1          1           

     

    I don't see any error icons anywhere in my package.  How do I go about figuring out what's wrong?

    I figured out what was causing the error.  While developing the package, I created a SQL Server log provider, but neglected to specify a connection manager.  The error message went away when I deleted the log provider.

    It would've been a lot more graceful for the SSIS designer to trap the error when I clicked the "OK" button in the Configure SSIS Logs dialog box.

    Saturday, December 16, 2006 6:07 AM