none
Connection to SQL Server 2008 R2 RTM via IP address fails

    Question

  • I am having trouble to connect to a SQL Server 2008 R2 RTM (64 Bit) Server on Window 7 64Bit. I already attempted to re-configure TCP/IP and named pipped but that did not resolve my problem either.

    I have a 32bit SQL Server 2008 instance on the same machine - could this problem be connected to the 32bit server instance being on the same computer?

    Below is a screenhot of the actual error message and config: "Cannot Connect to xx.xx.xx.xx\SQLExpress".

    Has anyone seen this before? What are the minimal requirements for 2008 R2 RTM to work with ip in the address part of the server?

    Any hints would be greatly appreciated,

    Cheers Dirk

    Thursday, January 19, 2012 3:34 PM

Answers

  • I found a resolution. The SQL Server Browser service was disabled (as it is by default). So setting this to Automatic, restarting it, and configuring TCP/IP and Named Pipes fixed my problem.
    • Edited by Dirkster9999 Monday, January 23, 2012 8:41 AM
    • Marked as answer by Dirkster9999 Monday, January 23, 2012 8:41 AM
    Monday, January 23, 2012 8:40 AM

All replies

  • Hi Dirk,

    Could you please make sure that the IP address is valid, and the SQL Server service is running? For the remote connection, you are also requited to configure the remote connection for this SQL Server instance.

    Please pay attention to this blog to troubleshoot this type of issue: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified.


    Stephanie Lv

    TechNet Community Support

    Monday, January 23, 2012 7:50 AM
  • Try to ping the ipaddress from your remote system.
    Thanks
    Manish

    Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.
    Monday, January 23, 2012 7:52 AM
  • I found a resolution. The SQL Server Browser service was disabled (as it is by default). So setting this to Automatic, restarting it, and configuring TCP/IP and Named Pipes fixed my problem.
    • Edited by Dirkster9999 Monday, January 23, 2012 8:41 AM
    • Marked as answer by Dirkster9999 Monday, January 23, 2012 8:41 AM
    Monday, January 23, 2012 8:40 AM
  • WOW, that worked.  I pulled out a lot of hair today trying everything else.  Thanks for posting your resolution!!
    Wednesday, July 04, 2012 12:46 AM