none
Time out Error

    Question

  • Gurus,

    I have installed SSRS on SQL 2012 and we are getting the below mentioned error randomly while running reports.

    Unable to conect to remote server

    A connection attempt failed because the connected party didnot respond after a period of time ,or established connection failed because connection host has failed to respond.

    I get this error 7 out of 10 times when i run the report from web server. while on the DB server if i run this report from ssrs it runs fine.

    Please guide

    Nitin


    Best Regards Nitin

    Tuesday, April 30, 2013 4:09 PM

All replies

  • Hi Nitin,

    This issue may be related the setting of the rsreportserver.config file. You can try the steps below to avoid this issue.

    1. Change the server account to local account.
    2. Remove the SSL if configured.
    3. Change the  SecureConnectionLevel value to 0 in rsreportserver.config (By default, it located in C:\Program Files\Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportServer)

    Hope this helps.

    Regards,
    Charlie Liao

    If you have any feedback on our support, please click here.


    Charlie Liao
    TechNet Community Support

    Wednesday, May 01, 2013 1:58 AM
  • I will try and will let you know in next 6 hours.

    Best Regards Nitin

    Wednesday, May 01, 2013 8:11 PM
  • i already see the value as 0 on the config file

    • Change the server account to local account.==> do you mean sql server service account? or SSRS

    Nitin


    Best Regards Nitin

    Thursday, May 02, 2013 12:16 AM
  • I think he means the service account you use to run the SSRS instance, through the SSRS config manager
    Thursday, May 02, 2013 5:09 AM
  • This did not worked.

    Few points now

    1)SSRS is on cluster(i am sure this does not make a difference since it is not clusterware)

    2)SSRS is running under local account now

    3) reports are running fine on the server but when someone is trying to connect from webserver, this issue is coming.

    4)SecureConnectionLevel value is  0 in rsreportserver.config

    Any suggestions now?

    Regards


    Best Regards Nitin

    Thursday, May 02, 2013 2:46 PM
  • Kindly suggest.

    Best Regards Nitin

    Monday, May 06, 2013 9:36 PM
  • any inputs here?

    Best Regards Nitin

    Monday, May 13, 2013 3:30 AM
  • Hi,

    Change your config file 

      RSWebApplication.config

    which is located under the path C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportManager


    search for:
    <ReportServerUrl></ReportServerUrl>
    <ReportServerVirtualDirectory>your ReportServer</ReportServerVirtualDirectory>

    change to:

    <ReportServerUrl>http://Server//your reportserver</ReportServerUrl>
    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
    Monday, May 13, 2013 4:38 AM