none
ssis 2008: The binary code for the script is not found

    Question

  • I’m following the examples in the BIDS training kit. I’ve just created my first script and everything seems to go well at the script level; but, when I exit (or close) back to the control flow level I get an error.

    It says I should make sure that my script builds correctly; but, I have no idea how to do that in SSIS 2008

    Thanks

    Ron

     

    Error      1              Validation error. Script Task : The binary code for the script is not found.

    Please open the script in the designer by clicking Edit Script button and make sure it

    builds successfully.          MyPackage.dtsx               0              0             

     

    Saturday, August 01, 2009 11:29 PM

Answers

  • This is often caused to to an error or omission in the code in the script task.  If you are certain that the code is correct you can go to the script properties and set the PrecompileiIntoBindaryCode to False, the default is set to true.  This is under the Properties or in the Script option of the properties window.

    Hopet his helps

    David Dye
    • Marked as answer by Ron5442 Sunday, August 02, 2009 12:17 AM
    Saturday, August 01, 2009 11:51 PM
    Moderator

All replies

  • This is often caused to to an error or omission in the code in the script task.  If you are certain that the code is correct you can go to the script properties and set the PrecompileiIntoBindaryCode to False, the default is set to true.  This is under the Properties or in the Script option of the properties window.

    Hopet his helps

    David Dye
    • Marked as answer by Ron5442 Sunday, August 02, 2009 12:17 AM
    Saturday, August 01, 2009 11:51 PM
    Moderator
  • Thanks David

    Yep, you’re right I found an error in my code and that fixed the problem. I’ve used the “PrecompileiIntoBindaryCode to False” technique in SSIS 2005; but, I couldn’t find that property for the script in SSIS 2008.

    Ron

    Sunday, August 02, 2009 12:16 AM
  • Thanks David

    Yep, you’re right I found an error in my code and that fixed the problem. I’ve used the “PrecompileiIntoBindaryCode to False” technique in SSIS 2005; but, I couldn’t find that property for the script in SSIS 2008.

    Ron


    Its a DelayValidation property, needs to be set to 'TRUE'.

     

    -- Mahesh

    Monday, July 18, 2011 10:35 AM