none
root element is missing

    Question

  • hi

    whenever i am copying my report to different server ans try to execute ,it shows me error like root element is missing

     

    and another problem is ,my all rdl file shows as a notepad symbol.how to get back to rdl symbol

     

    thanks

    Saturday, June 23, 2012 2:18 PM

Answers

  • Can you run the report from BIDS or Report Builder?

    If that doesn't work either, then you can create e blank report and copy the xml from your old report (open with notepad) into the new report (right click and choose View Code).

    Saturday, June 23, 2012 9:56 PM

All replies

  • This means that your xml is not well formed. It seems like it doesn't have a root element.

    The icons in Windows are associated with the program which opens them, you may have set the Notepad as Default application. To change it back, set BIDS (SSDT) or Report Builder as your Default application for .rdl files. To do that:

    1. Right-click the report file, select Open with, select Choose default Program.
    2. In the Open with dialog box, click Brower button, locate to the path of the Report Builder or BIDS.
    3. Double-click the application, click OK.

    Did you open your report with Notepad and modified the schema?

    Saturday, June 23, 2012 5:17 PM
  • thanks now my notepad icon are gone,but how can i solve root element error
    Saturday, June 23, 2012 5:48 PM
  • Can you run the report from BIDS or Report Builder?

    If that doesn't work either, then you can create e blank report and copy the xml from your old report (open with notepad) into the new report (right click and choose View Code).

    Saturday, June 23, 2012 9:56 PM