none
error 18452, Login failed for user Reason: Not associated with a trusted SQL Server connection.

    Question

  • Hi all,
    I have two servers running windows 2003 and both having sql server 2000.
    I want to establish a linked server between all of them.
    i created them . but now when accessing the data from those server the following error is being displayed


    Server: Msg 18452, Level 14, State 1, Line 1
    Login failed for user 'manoj'. Reason: Not associated with a trusted SQL Server connection.



    i have enabled mixed mode authentication.even then its not displaying the intended result.

    please respond is urgent.

    thanks.
    Monday, September 05, 2005 5:21 AM

All replies

  • Hi Manoj,

    Is your problem solved?

    Regards
    ---------------
    Tuesday, September 13, 2005 8:33 PM
  • No Not yet.
    Do you have any solution?
    thanx
    Thursday, September 29, 2005 10:43 AM
  • Change the authantication mode to Mix Mode from Windows Only mode for Sql Server.

    1. Enter SQL Enterprise Manager.

    2. Find your server name in the tree on the left.

    3. Right mouse click on the server name and select properties.

    4. Click the Security folder.  You should now see the screen below with "Windows Only" set as the default authentication.

    5. Check SQL Server and Windows as the Authentication.

    6. Click OK.

    7. Click Yes to restart SQL. 

    I hope your problem will be solved.
    Regards.
    Kam Trivedi
    TORONTO

      • Proposed as answer by Pokis Tuesday, May 31, 2011 9:19 PM
      • Unproposed as answer by Pokis Tuesday, May 31, 2011 9:21 PM
      Monday, October 17, 2005 4:01 PM
    1. I have same Problem.... with error message Displayed below, I tried above steps but no luck....

      icrosoft (R) SQLMaint Utility (Unicode), Version Logged on to SQL Server 'XXXXXX' as 'NT AUTHORITY\SYSTEM' (trusted) [Microsoft SQL-DMO (ODBC SQLState: 28000)] Error 18452: [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection.

      Starting maintenance plan 'DB Maintenance Plan4' on 11/2/2005 9:00:02 PM [1] Database YYYYYY: Transaction Log Backup...

      Destination: [D:\Log\YYYYYY\YYYYY_tlog_200511022100.TRN]

      ** Execution Time: 0 hrs, 0 mins, 1 secs **

      [Microsoft SQL-DMO (ODBC SQLState: 28000)] Error 18452: [Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection.

      [2] Database YYYYYY: Delete Old Backup Files...

      1 file(s) deleted.

      Deleting old text reports... 1 file(s) deleted.

      End of maintenance plan 'DB Maintenance Plan4' on 11/2/2005 9:00:03 PM SQLMAINT.EXE Process Exit Code: 0 (Success)

      Wednesday, November 09, 2005 5:03 PM
    2. Hi

      I am using multimode authentification. but still i have the same error " Login failed for user". this is the only server that i am not able to get connected. i dont know why. i am using SQL server management studio 2005.Can someone help me?
      Monday, May 21, 2007 8:34 AM
    3. GUI solution:
      On the server you run a job:
      1. Select linked server - properties.
      2. Select security page.
      3. Select 'Be made using the security context:'
          enter remote user and password below.
      -----------------------------------------------------------
      SQL solution:
      exec sp_addlinkedsrvlogin 'LinkedServer', false, NULL, <remote user>, <remote password>
      Monday, June 11, 2007 9:50 PM
    4. How did you create this db user 'manoj', is it mapping to a trusted NT login? This is security issue, please post your question to security forum

       

      http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=92&SiteID=1

       

      Good Luck!

      Ming.

      Wednesday, June 13, 2007 4:37 PM
    5. Try this if you are trying to link them with the login's current security context:

       

      To use delegation, all servers that you are connecting to must be running Microsoft® Windows® 2000, with Kerberos support enabled, and you must be using Microsoft Active Directory™, the directory service for Windows 2000. The following options in Active Directory must be specified as follows in order for delegation to work:

      ·         The Account is sensitive and cannot be delegated check box must not be selected for the user requesting delegation.

      ·         The Account is trusted for delegation check box must be selected for the service account of SQL Server.

      ·         The Computer is trusted for delegation check box must be selected for the server running an instance of Microsoft SQL Server™.

       

      Thursday, November 08, 2007 4:03 PM
    6. 1> Goto SQL Server Manger

      2> Select the DB Server (Eg : Local) -> Management->Right click and stop SQlServerAgent

                                            Click the DB Server (Eg local) -> Right click and stop

       

      3> Right click and start both Server and server Agent again.

                                          

       

      • Proposed as answer by Keith Holman Thursday, August 19, 2010 9:58 PM
      Thursday, January 24, 2008 9:07 AM
    7. thank u very much...........................................................veryveryveryveryverymuch,haha
      Sunday, May 30, 2010 4:38 AM
    8. Sunil S, thanks alot !! That solved my problem too ! :)
      Wednesday, August 18, 2010 7:01 PM
    9. It worked for me, I was calling a linked server in a job
      Thursday, January 13, 2011 2:22 PM
    10. Buenisimo Brother, yo tenia problemas pa conectar PHP + Mssql me funciono de maravilla 100Pts. para ti...
      Tuesday, May 31, 2011 9:21 PM
    11. Translation:

      Very good Brother, I had problems connecting PHP + Mssql 100pts I worked wonderfully. for you


      Jeff Wharton
      MSysDev (C.Sturt), MDbDsgnMgt (C.Sturt) MCT, MCPD, MCITP, MCDBA
      Blog: Mr. Wharty's Ramblings
      Please mark solved if I've answered your question, vote for it as helpful to help other user's find a solution quicker
      Wednesday, June 01, 2011 12:23 AM