none
Can't Uninstall SQL Server 2005 Express Tools

    Question

  • I am attempting to install SQL Server 2008 Enterprise Trial and receive the follow error during installation.

     

    "The SQL Server 2005 Express Tools are installed. To continue, remove the SQL Server 2005 Express Tools."

     

    I have used Add or Remove programs to remove all components of SQL Server 2005 Express.  I have even reinstalled the Workstation Tools of SQL Server 2005 just so I could indiviually remove those tools, and then completly removed the SQL 2005 installation.

     

    I have used regedit to search for any instance of SQL Server 2005, there is none.

     

     

    There is still an entry for SQL Server Mangement Express in my all programs listing.  However trying to launch that program fails with errors, so it is partial still installed.

     

    Can anyone tell me how to wipe out these last bits of SQL Server 2005 Express Tools?  I have tried everything I have found searching this forum to no avail.

     

    Bill

    Thursday, August 07, 2008 1:20 PM

Answers

  • Found my own answer search other parts of the formum for folks with similar problems.  Removing the following registry key does the trick.

     

    Remove the registry key at: HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90

     

    I know it's a bit brute force, but I've already lost two days on this, and it works.

     

    Friday, August 08, 2008 4:22 PM

All replies

  • I am getting the same error when tying to install the new RTM version of SQL Server 2008; I have SQL 2000 and 2005 client tools installed but no 2005 Express tools in my XP/SP2 workstation.

     

    Karim

     

    Thursday, August 07, 2008 3:05 PM
  • There is a posting under SQL Katmai Setup and upgrade and the fix was to uninstall Redgate SQL Prompt and it worked for me.

    Karim

    • Proposed as answer by bhav27 Tuesday, September 27, 2011 7:19 PM
    Thursday, August 07, 2008 3:14 PM
  • Hello Bill

    Download Windows Cleanup Utility from the bellow link and install it.

    http://support.microsoft.com/kb/290301/en-us

    See if you can see SQL Server 2005 Express Tools. If you find them you will be having option to Remove it. Let me know if you still cannot able to uninstall.

    Karumajji

    Friday, August 08, 2008 4:43 AM
  • The Windows Cleanup Utility did not work for me.  There is no reference to SQL Server 2005 Client Tools or, Management Studio Express to delete.

     

    Any other sugestions?

     

    Bill

     

    Friday, August 08, 2008 4:12 PM
  • Found my own answer search other parts of the formum for folks with similar problems.  Removing the following registry key does the trick.

     

    Remove the registry key at: HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90

     

    I know it's a bit brute force, but I've already lost two days on this, and it works.

     

    Friday, August 08, 2008 4:22 PM
  •  

    I have the same problem as described above while installing SQLServer 2008. The cleanup-tool doesn't solve it.

    But I dont have the registry-key described above. There are only subitems "100", "RefCount" and "SSMSEE" under "Microsoft SQL Server".

    I have a Visual Studio 2008 on that machin, with SP 1 just installed.

     

    And, Microsoft, why do you show this message so late in the wizard, after typing in lots of configuration-settings?

    Wednesday, August 13, 2008 9:45 AM
  • Ok, thanks to Jan Sotola, I found the reason why that registry-key is missing. You can read it here: http://jasonfollas.com/blog/archive/2008/06/19/sql-server-2008-rc0-install-sql2005ssmsexpressfacet.aspx.

    It's a 64-bit-Windows. There, one must delete the key

     

    HKLM\Software\Wow6432Node\Microsoft\Microsoft SQL Server\90

     

    and one can continue the installation-wizard.

     

     

     

    • Proposed as answer by Steve Dunn Saturday, May 09, 2009 6:09 AM
    Wednesday, August 13, 2008 9:54 AM
  •  metali wrote:

    There is a posting under SQL Katmai Setup and upgrade and the fix was to uninstall Redgate SQL Prompt and it worked for me.

    Karim

     

    In my case SQL Prompt was the issue as well.


    Chris

     

    Friday, August 15, 2008 12:08 AM
  •  Chris Crowe wrote:
     metali wrote:

    There is a posting under SQL Katmai Setup and upgrade and the fix was to uninstall Redgate SQL Prompt and it worked for me.

    Karim

     

    In my case SQL Prompt was the issue as well.


    Chris

     

     

     

    I also removed SQL Prompt and ok!

    Wednesday, August 20, 2008 6:56 PM
  • It worked for me after removing SQL prompt as well.

    Wednesday, August 27, 2008 6:32 AM
  • Removing Redgate did it for me when installing Developer edition over 2005

     

    Wednesday, August 27, 2008 7:34 AM
  • Interestingly enough, removing SQL Prompt didn't work for me, but removing the key at HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90 did work. Thanks!
    • Proposed as answer by Paras Wadehra Sunday, February 22, 2009 5:56 AM
    Monday, September 08, 2008 6:14 PM
  • Exporting the key: HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90, then deleting, re-running the check, it passed. I re-imported the key, continued on installation.  No more bumps.

    Monday, September 15, 2008 10:35 PM
  • I renamed the registry key and it worked for me as well.

     

    Tuesday, October 07, 2008 6:02 PM
  • Renaming or deleting the registry key was the only solution for me. It is not eough to rename a sub-key, I found you must rename or remove the key at the level of "\90"

     

    HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90

     

    I have not tried every permutation but these are the previous steps in order that were NOT helpful.

    Sometimes it is good to know what has been tried and does not work, so you do not spend time in dead ends.

     

    These do NOT work

    1. resolution at this link did not work for me although it worked for that person

    "rename registry key "

    http://jasonfollas.com/blog/archive/2008/06/19/sql-server-2008-rc0-install-sql2005ssmsexpressfacet.aspx

    rename key from: HKLM\Software\Microsoft\Microsoft SQL Server\90\Tools\ShellSEM

    to: ShellSEM.old

    (If I had renamed \90 it might have succeeded)

     

    2. solution at this link did not work for me although it worked for that person

    "changing the Regional Settings of my computer"

    http://www.kodyaz.com/blogs/software_development_blog/archive/2008/02/22/840.aspx

     

    3. reset.cmd

    download and execute reset.cmd to reset many registry settings

    Nope, no luck

     

    4. download entire 2008 express package as an ISO file in the small chance any previous files were corrupted.

    The ISO image was 744 meg, which can only be burned onto a double-layer disk.

    Then I remembered I don't have a double-layer burner.

    Duh.

     

    5. removing 3rd party tools

    - Remove SQL Server 2005 Express Tools

    - Remove Red-Gate SQL Prompt if installed.

    http://blog.crowe.co.nz/archive/2008/08/14/quotThe-SQL-Server-2005-Express-Tools-are-installed.-To-continue.aspx

    mainly because neither were actually listed in add/remove programs, nor was Red Gate in the registry

    (or redgate, red-gate, red_gate)

     

    6. "Solving setup errors by using the SubInACL tool to repair file and registry permissions"

    http://blogs.msdn.com/astebner/archive/2006/09/04/739820.aspx

     

    7. rename the instance of SQL Server 2008 when installing

    Nope.

     

    8. With Add/remove programs, remove

    - sql server 2005

    - anything else that had in the title "sql server 2005"

    - sql server system clr types (which sounded sort of like a 3-rd party tool and I had not used it in a year)

    - remove folder

    c:\program files\microsoft\Microsoft SQL Server90

    Nope, no luck

     

    10. With a Microsoft tool "Windows Install Clean Up" inspect any add/remove programs that were removed and absolutely remove their install logs

    Nope.  So it was not due to any residual information from SQL Server 2005

     

    11. With Add/remove programs, remove

    - anything that has the title sql server 2008

    and try to re-install, which did not work.

     

    Finally found this thread and deleted the key and the installation succeeded.

    It did not take 2 days, but almost.

     

    This is a test, right? We have to navigate all the half-good information and actually succeed installing SQL Server 2008 then we earn the privilege to use it?  Yay!

     

     

     

     

     

     

     

    Sunday, November 09, 2008 3:31 PM
  • The easiest way to resolve this issue is to download the installer for SQL Server Management Studio Express (the 2005 version) and run it - this time, choose uninstall instead of install.

    The download can be found here:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=C243A5AE-4BD1-4E3D-94B8-5A0F62BF7796&displaylang=en
    • Proposed as answer by admapn Friday, April 24, 2009 10:39 PM
    Thursday, December 11, 2008 3:01 PM
  • Uninstalling SQL Server Management Studio worked for me.   It was in the control panel, uninstall programs.
    • Proposed as answer by Kaleem Khan Tuesday, January 20, 2009 8:45 PM
    Wednesday, December 31, 2008 10:52 PM
  • I didn't find anything from RedGate in my registry. However, I removed SQL Server Mangement Studio and it solved my problem.
    Rendezvous
    • Proposed as answer by Kaleem Khan Tuesday, January 20, 2009 8:46 PM
    Tuesday, January 20, 2009 7:45 PM
  • But what I found WEIRD is the fact that I still can launch SQL Server Management Studio console from SqlServer 2005 in start menu. Mind that I have a side by side installation of SqlServer 2005 and SqlServer 2008.
    Rendezvous
    Tuesday, January 20, 2009 8:48 PM
  • pownby said:

    Interestingly enough, removing SQL Prompt didn't work for me, but removing the key at HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90 did work. Thanks!


    +1 for deleting "HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90" - It helped me too.

    Regards,
    Paras Wadehra
    http://blogs.msdn.com/ParasWadehra

    Create your own blog at http://www.paras.2ya.com/
    Sunday, February 22, 2009 5:59 AM
  • Uninstalling Management Studio Express (in control panel, add/remove software) worked for me.
    Tuesday, March 03, 2009 8:20 AM
  • Thanks, everything had failed but that worked.  I'll certainly be aware of this issue in future when I need to delete registry keys on a 64bit system.
    Saturday, May 09, 2009 6:10 AM
  • Positively brilliant.  This worked for me; who cares about Brute Force.

    -- Postal Mike, 23 May 1953 "And that's my 2 cents on the matter"
    Saturday, May 23, 2009 4:54 PM
  • Uninstalling Management Studio Express (in control panel, add/remove software) worked for me.

    that worked here
    Sunday, May 24, 2009 6:19 PM
  • In my case, the system admin did the initial install.  I did not see the Express Tools in my Add/Remove Programs, but I could not install the SQL 2005 Developer Edition tools because of their alleged existence.  I searched the registry for "Express Tools", and after passing a couple hits, I eventually came upon the registry key:

    \HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\<somelonghexstring>

    This contained all the stuff that you would expect to see in an Add/Remove Programs description -- Contact, DisplayName, EstimatedSize, InstallDate, etc.  And there were also strings for ModifyPath and UninstallString.

    I just took the command out of UninstallString (which was MsiExec.exe /I{some-hyphenated-guid}) and ran that in a command prompt, and it uninstalled just fine.

    My guess is he installed it as "Only for Me" instead of "For All Users", which would be why I couldn't see it in Add/Remove Programs.
    Thursday, June 11, 2009 9:18 PM
  • In the list of programs on machine it should be listed as Microsoft SQL server 2005 Managment Express, try uninstalling it and it should work
    Sr. Analyst Programmer, Palm Beach County
    Friday, June 26, 2009 12:44 AM
  • You can try this solution the first one worked for me.
    http://smallworkarounds.blogspot.com/2009/08/can-uninstall-sql-server-2005-express.html
    Aashish Gutpa http://smallworkarounds.blogspot.com
    • Edited by Aashish Gupta Friday, August 07, 2009 10:44 AM
    • Proposed as answer by tomDarth Saturday, October 31, 2009 5:43 AM
    Friday, August 07, 2009 10:40 AM
  • this solved it for me

    thx
    Wednesday, September 09, 2009 3:13 PM
  • Gupta, Henrik, Connor, you guys are a golden treasure. I'm moving along, little by little, thanks to your help.
    Monday, September 21, 2009 8:06 PM
  • Marvelous...
    But how did you find out?
    ...astonishing...
    tb
    Thursday, October 01, 2009 6:06 PM
  • this is a smart guy!

    tb
    Thursday, October 01, 2009 6:07 PM
  • I unistalled Microsoft SQL server 2005 first, but that did not work. Then I unistalled Redgate SQL Prompt, that worked.

    Thanks fot the help everyone.
    Monday, October 19, 2009 7:57 PM
  • All I had to do was delete the registry key HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools

    Once I did that I was able to install SQL Server 2005 Tools without problem.

    Thursday, November 19, 2009 4:53 AM
  • For me, trick was manually uninstalling SQL Server Mangement Express from "Add or Remove Programs"
    Saturday, November 28, 2009 8:21 PM
  • Deleting the reg key (mention number of times above) worked for me.
    Monday, November 30, 2009 9:03 PM
  • Ok, thanks to Jan Sotola, I found the reason why that registry-key is missing. You can read it here: http://jasonfollas.com/blog/archive/2008/06/19/sql-server-2008-rc0-install-sql2005ssmsexpressfacet.aspx.

    It's a 64-bit-Windows. There, one must delete the key

     

    HKLM\Software\Wow6432Node\Microsoft\Microsoft SQL Server\90

     

    and one can continue the installation-wizard.

     

     

     

    Poorly documented x64 case, Markus von und zu Heber gets it PERFECT!

    Well done!  Thanks.
    Sunday, December 06, 2009 7:14 PM
  • I wonder if it would be to much for them to actually list the management studio as the issue rather than calling it sql 2005 tools. thank you for your input, it worked and was the fastest and easiest, thus the reason i tried it first.
    Tuesday, December 08, 2009 10:01 PM
  • Worked for me. Thanks a lot.

    Suman
    Friday, December 25, 2009 1:53 AM
  • Ok, thanks to Jan Sotola, I found the reason why that registry-key is missing. You can read it here: http://jasonfollas.com/blog/archive/2008/06/19/sql-server-2008-rc0-install-sql2005ssmsexpressfacet.aspx.

    It's a 64-bit-Windows. There, one must delete the key

     

    HKLM\Software\Wow6432Node\Microsoft\Microsoft SQL Server\90

     

    and one can continue the installation-wizard.

     

     

     


    Thanks you all. it really helped me.
    I had unistalled my sql server 2005 and downloaded all the new sp1 and what not..
    Thank you guys...
    Friday, February 12, 2010 4:39 PM
  • Thanx...worked for me too......
    Thursday, February 18, 2010 5:32 PM
  • This worked perfectly....!!!! 

    Make sure you do a backup of your registry, though i did not have any issue while deleting this key.

     

    Regards.

    Thursday, March 25, 2010 5:29 PM
  • You keep mentioning this, but there are a ton of directories under this, you not specifing which one to delete.  I don't feel safe deleting all of these items.
    Monday, May 10, 2010 3:11 PM
  • Backup the registry key first, then take the plunge.  That gives you a fallback just in case.
    Monday, May 10, 2010 3:22 PM
  • worked perfectly!!! first search result on google too :-) thanks!!!
    Saturday, May 29, 2010 9:35 PM
  • Thanks nelson,

    It solved my problem.

    Cheers!!!!!!

    Friday, June 04, 2010 7:41 AM
  • after a dozen of articles and hours of hair pulling, removing RedGate's SQL Search worked for me!!! Yeah!!!

    Tuesday, June 15, 2010 2:45 PM
  • Thank you! That saved me many hours.
    Tuesday, June 15, 2010 2:57 PM
  • Renaming the key at HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools worked.

     

    new Key is - HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools_new

    Wednesday, June 16, 2010 9:07 AM
  • hi

    as a shortcut for all the conversation

    First of all my problem sovled but I i think that we didn't notice that it's name would be "Microsoft sql server management studio" in add/remove

    and I think if we remove it it will work will

    and also these ways will work too :

    I delete the key HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools  - worked

     

    I think rename HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools_new - will work

    • Proposed as answer by rann1 Thursday, July 29, 2010 4:00 AM
    Saturday, July 17, 2010 10:59 PM
  • hi all, make sure when deleting the registry keys to remove all instances of 'Microsoft SQL Server\90' otherwise it wont work.

    finally, it worked for me.

    Thursday, July 29, 2010 4:03 AM
  • There is a posting under SQL Katmai Setup and upgrade and the fix was to uninstall Redgate SQL Prompt and it worked for me.

    Karim

    I uninstalled the redgate SQL and i'm now able to install SQL server 2008 without errors

     

    S

    Friday, August 20, 2010 12:19 PM
  • Yes it worked for me: 1)  installed for SQL Server Management Studio Express (the 2005 version) , then

    2) In control panel, uninstalled it.

    Sunday, September 19, 2010 3:06 AM
  • As I did not have either SQL Prompt or SQL Search installed, removing the SSMS Tools Pack add-in did the trick for me.
    Tuesday, October 05, 2010 7:23 PM
  • Thanks for this help, it works.

    I have just tryed and that's ok.

    Well done man

    Friday, November 05, 2010 9:27 AM
  • Thanks for your help/............
    Monday, November 22, 2010 10:35 AM
  • You are brilliant. I tried everything and every link I could find from an exhaustive Google search and nothing worked. I must have installed and re-installed several programs ten times to no avail. I finally deleted the registry key : HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90 and voila!
    Saturday, December 11, 2010 7:45 PM
  • Thanks :) , it WOKRS

    Monday, January 03, 2011 8:45 PM
  • Follow  this step: this work for me

    1. Upgrade .Net Framework 3.5 SP1

    2.  Upgrade VS 2008 to VS 2008 SP1

    3. Go to Control Panel => Programs and Features

    + Remove Microsoft SQL Server 2005 "Workstation Components"

    + Remove Microsoft SQL Server 2005 Management

    4. Install Microsoft SQL Server 2008 R2

    • Proposed as answer by Hebsur Wednesday, March 23, 2011 8:36 AM
    Thursday, January 27, 2011 10:01 AM
  • I had several 3rd party tools installed. I found that uninstalling SSMS Tools Pack, SQLPrompt, and SQLCLR Types fixed the situation for me.
    Charles Evans
    Tuesday, February 01, 2011 10:16 PM
  • Almost 3 years old post, and still useful.

    In my case, removing the registry key did the trick.

    Thanks a lot.

    Cheers!

    • Proposed as answer by peterwliu Thursday, March 31, 2011 8:36 PM
    • Unproposed as answer by peterwliu Thursday, March 31, 2011 8:37 PM
    Wednesday, March 30, 2011 9:46 AM
  • Thanks you very much for the help! worked for XP pro x64
    Tuesday, April 12, 2011 1:55 PM
  • Thanks a lot, I'm sure you just saved me 2 days. I appreciate you following up on your solution here, it makes these web sites work :)
    Tuesday, April 26, 2011 4:12 AM
  • In my case I needed to delete SOFTWARE\Microsoft\Microsoft SQL Server\90\Tools\ShellSEM key that was even empty (I belive it was a leftover from the previous Express edition SSMS 2005 installation).

    I found that the rule was set to check this registry key in a log file Detail.txt in C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\YYYYMMDD_HHMMSS


    Arthur My Blog
    By: TwitterButtons.com
    Thursday, June 23, 2011 6:01 PM
  • Thanks Wm,

     

    Its working now...

     

    Mukesh

    Tuesday, July 05, 2011 4:18 AM
  • Thanks that was part of the problem!
    cs
    Thursday, August 11, 2011 4:15 PM
  • Thank you so much for posting this! I've had this lingering problem for so long! 
    cs
    Thursday, August 11, 2011 4:15 PM
  • I didn't have SQL Prompt installed, but I did have SQL Search installed.  Removing THAT worked for me.

    -Spenser

    Thursday, December 01, 2011 9:07 PM
  • I tried to remove all subnodes to HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90. It didn't work

    Using even more  brute force: I removed the node itself. It didn't work

     

    Using much much more brute force and removing any trace of anything equal to: Microsoft SQL Server\90 worked. Found perhabs 50 keys or more.

     

    I remembered exporting the sys registry before doing this. I recommend you do the same. Sideeffects from above is unknown (at the time writing this).


    Wednesday, December 07, 2011 11:51 AM
  • Thanks for pointing me in the right direction.

    In my case it was the "Poor Man's T-SQL Formatter" SSMS plugin that was causing SQL 2008 R2 to think SQL 2005 SSMS was still installed.

     

    Darren.

    Monday, December 12, 2011 1:45 AM
  • It works for me
    Tuesday, October 09, 2012 4:59 PM
  • Hello, 

    I had the same problem.  Uninstalling any 3rd party plugins that integrate into  SQL Server Management Studio (SSMS Plugin Pack, POOR SQL FORMATER)  did the trick!

    Tuesday, November 06, 2012 8:00 PM
  • Uninstalling SQL Server Management Studio worked.   It was in the control panel, uninstall programs.
    Sunday, December 30, 2012 6:33 PM
  • :) it works
    Sunday, January 20, 2013 10:54 AM
  • Remove the registry key at: HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\90

    If you're running on x64: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Microsoft SQL Server\90
    Saturday, April 06, 2013 3:15 PM
  • Hi All,

    this is same problem facing and can you tell me that sql server 2005 express edition is already installed in my computer then there is any other way to install sql server 2008 express edition without uninstallation of sql server 2005 express tools.

    If there is any way of installation of sql server 2008 express edition then reply to me.

    It is very urgent to me.

    Regards,

    Atul Sharma

    Friday, June 21, 2013 11:55 AM
  • THAT FIXED IT!! Thank you!!


    Ron

    Monday, March 03, 2014 3:18 PM
  • This worked perfectly.
    Thursday, March 13, 2014 4:41 PM
  • This solution wored for me. You have to delete both register keys. Thanks
    • Edited by KaFrAnK Thursday, September 18, 2014 2:32 PM
    Thursday, September 18, 2014 2:31 PM