none
The OLE DB provider "SQLNCLI10" for linked server "servername" reported an error. Authentication failed.

    Question

  • I have configured Linked server and is running fine but suddenly it starts generate error.

    now when i try to connect through link server i got this message

    OLE DB provider "SQLNCLI10" for linked server "SRV-601" returned message "Invalid authorization specification".
    Msg 7399, Level 16, State 1, Line 1
    The OLE DB provider "SQLNCLI10" for linked server "SRV-601" reported an error. Authentication failed.
    Msg 7303, Level 16, State 1, Line 1
    Cannot initialize the data source object of OLE DB provider "SQLNCLI10" for linked server "SRV-601".

    Link server is using an account "apps". But when i try to connect through SSMS i am able to connect.


    Shamas Saeed (if Post helpful please mark as Answer) http://shamas-saeed.blogspot.com

    Tuesday, April 17, 2012 10:01 AM

Answers

  • It is very hard to wait for an answer. at last i have found multiple solutions

    1- Changes on my link server from option from "Be made using login's security context " to "Be made using security context" and providing my username and password.

    2- Was Kerberos delegation configured? 

     this is difficult for me to understand but i have found good article about its configuration. I got a paper published for this configuration on microsoft help.

    another link is 

    http://blogs.msdn.com/b/sql_protocols/archive/2006/08/10/694657.aspx

    but both ways my problem has been resolved. Thanks for every ones sharing.


    Shamas Saeed (if Post helpful please mark as Answer) http://shamas-saeed.blogspot.com

    • Marked as answer by Shamas Saeed Wednesday, April 18, 2012 6:44 AM
    Wednesday, April 18, 2012 6:44 AM

All replies

  • When i try to run query using link server. I got following message

    Msg 18456, Level 14, State 1, Line 1
    Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.


    Shamas Saeed (if Post helpful please mark as Answer) http://shamas-saeed.blogspot.com

    Tuesday, April 17, 2012 10:14 AM
  • It is very hard to wait for an answer. at last i have found multiple solutions

    1- Changes on my link server from option from "Be made using login's security context " to "Be made using security context" and providing my username and password.

    2- Was Kerberos delegation configured? 

     this is difficult for me to understand but i have found good article about its configuration. I got a paper published for this configuration on microsoft help.

    another link is 

    http://blogs.msdn.com/b/sql_protocols/archive/2006/08/10/694657.aspx

    but both ways my problem has been resolved. Thanks for every ones sharing.


    Shamas Saeed (if Post helpful please mark as Answer) http://shamas-saeed.blogspot.com

    • Marked as answer by Shamas Saeed Wednesday, April 18, 2012 6:44 AM
    Wednesday, April 18, 2012 6:44 AM