none
Report Server Manager, How to set up users and passwords

    Question

  • I have successfully set up a web server  using Reporting Services-Sql Server Express 2005. When I go to other machines in the network (same domain) where the server resides, and open the default page, it asks for credentials. The only ones that work are the Windows credentials I use as an administrator for the server machine.

    I want to set it up where people can use SQL Server user-passwords but am not sure where to do this. I have tried setting up logins-users-passwords in SQL Mgt Studio and have been successful doing so with MS Access ADP's . But with the web from Explorer on the same machines, it only accepts my administrator password.

    Can you point me in the right direction as to where to fix this so that  SQL Server user-passwords will work?

    I suspect it's one of these places:

    - Create a new  Windows user on the machine that SQL Server resides on
    - Create a login user-password in report server database
    - Change setting somewhere that will allow passage to the computer SQL Server is installed on without entering Windows credentials.

    I've tried some of these and DARE NOT try them again without good guidance. I just spent a week fixing a password problem I nearly hung myself from the rafters over,  but finally (thanks to you guys) figured it out.

    I prefer using SQL Server passwords without messing with Windows if possible....Thanks in advance for your help...

    David



    DR
    Monday, February 16, 2009 11:56 PM

Answers

All replies

  • You cannot use sql login to access report server (unless you write an authentication extension, I guess). I think what you are asking is a way for non-admin windows users to be able to view/manage reports.

    First you should make sure that non-admin users can access report server. By this I mean when they access http://<server>/reportserver or http://<server>/reports, they should not see HTTP 401 error. If they see HTTP 401, that's something you need to fix first.

    If non-admin users sees report page but with empty contents, that means the user needs to be granted access to report server. SSRS uses a role based security model. You can associate users with roles so they can have access the server.

    Here are some resouces that may help you get stareted:
    HTTP 401 problems: http://support.microsoft.com/default.aspx/kb/958998
    SSRS role based security:http://technet.microsoft.com/en-us/library/ms156014.aspx
    Tuesday, February 17, 2009 12:42 AM
  • OK, I think Im getting closer.

    Here's where I am now:

    I created a new user with the choice of "Limited" selected in Windows at the Computer where SQL Server and Report Services resides. My new user name is PRESSROOM. I set it up with a password and restarted the computer.


    I then went back to Explorer, opened the home page for my site using my original password ( that is, the administrator of the computer where Report Services Resides). Went into Report Manager/ Site Settings/Configure site-wide Security/new role assignment... chose  system user and assigned that role to my new user PRESSROOM that I just created previously in Window.

    Now, when I close Explorer, re-open and enter the new user name and password, ALL I SEE IS THE HOME PAGE. NONE OF MY REPORTS ARE VISIBLE.  WHAT DO I NEED TO CHANGE SO I CAN SEE ALL THE REPORTS I've created? Where do I go to do this?

    Thanks So much, once again for your help.

    David
    DR
    Tuesday, February 17, 2009 10:02 PM
  • You assigned your new user with system user privilege which provides access to functionality like shared schedules. To provide access to the items on the report server, you should select the home folder, go to the security settings and assign an item level role (such as content manager, publisher, browser etc) for your user.
    The link http://technet.microsoft.com/en-us/library/ms156034.aspx will help you do that.
    Wednesday, February 18, 2009 5:43 AM
  • Thank You, Neeraja!
     I'm almost there. I followed the instructions and added an item level user as a "browser.  I can now see my reports listed.

    Now I have one more problem to solve:

    I have a parameter that must be entered before viewing the appropriate data. The new user is allowed to enter the parameter detail, but gets this error. Where do I need to go to give the new user the ability to connect to this datasource?

    error has occurred during report processing:

    • Cannot create a connection to data source 'Report_Datasource'.
      • Cannot open database "TEST_SSMA" requested by the login. The login failed. Login failed for user '00081ASSETTAG\PRESSROOM'

    DR
    Wednesday, February 18, 2009 3:05 PM