none
SQL server services: the remote procedure call failed [0x800706be]

    Question

  • I installed SQL server 2008 R2 (Express) on my Windows Server 2003 Standard edition SP2; I already have the ISA server 2006 installed , which is used as a firewall and to monitor and to limit employees' internet access.

    The installation completes successfully, and the SQL server started successfully. But once I open the server configuration manager, and click on the SQL server services, I receive the error: the remote procedure call failed [0x800706be].

    The TCP/IP protocols are enabled.

    "Allow remote connections to this server" option is enabled.

    Windows firewall is disabled since the ISA acts as the firewall. I tried to go to the ISA and create a new RPC protocol for the SQL server, but it didn't find the SQL server.

    I've been trying to solve this issue for 2 days; uninstalled and re-installed the SQL server, download 3 different versions, None worked.

    Any help is deeply appreciated.

    Friday, November 30, 2012 9:28 AM

Answers

  • Hello,

    Please run the following command if the operating system is 32-bit:

    mofcomp.exe "C:\Program Files\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

    On a 64-bit operating system:

    mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, November 30, 2012 12:37 PM
    Moderator
  • Hi georgio,


    This error seems to happen when .mof files (Managed Object Format (MOF)) don’t get installed and registered correctly during set-up. To resolve this issue, I executed the following mofcomp command in command prompt to re-register the *.mof files:
     
    mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"


    Thanks.


    Maggie Luo
    TechNet Community Support

    Monday, December 03, 2012 12:21 PM
    Moderator

All replies

  • I installed SQL server 2008 R2 (Express) on my Windows Server 2003 Standard edition SP2; I already have the ISA server 2006 installed , which is used as a firewall and to monitor and to limit employees' internet access.

    The installation completes successfully, and the SQL server started successfully. But once I open the server configuration manager, and click on the SQL server services, I receive the error: the remote procedure call failed [0x800706be].

    The TCP/IP protocols are enabled.

    "Allow remote connections to this server" option is enabled.

    Windows firewall is disabled since the ISA acts as the firewall. I tried to go to the ISA and create a new RPC protocol for the SQL server, but it didn't find the SQL server.

    I've been trying to solve this issue for 2 days; uninstalled and re-installed the SQL server, download 3 different versions, None worked.

    Any help is deeply appreciated.

    Friday, November 30, 2012 11:49 AM
  • Hello,

    Please run the following command if the operating system is 32-bit:

    mofcomp.exe "C:\Program Files\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

    On a 64-bit operating system:

    mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, November 30, 2012 12:37 PM
    Moderator
  • Hello Alberto,

    I ran the command of the 32-bit OS , and tried to run the SQL server configuration manager, and went to the services, but the same error came again.

    I opened the file with notepad, found nothing clear on the subject.

    Regards.

    Georgio Maalouf.


    Friday, November 30, 2012 1:02 PM
  • Dear Alberto,

    I successfully connected to the SQL server on ISA, knowing that the error is still showing, 

    SQL server services: the remote procedure call failed [0x800706be].

    Thank you.

    Best regards,

    Georgio Maalouf.

    Friday, November 30, 2012 2:07 PM
  • Hello,

    Please try to apply service pack 2 for SQL Server 2008 R2.

    http://www.microsoft.com/en-us/download/details.aspx?id=30437

    I will unmark this question as answered.

    Hope this helps.

    Regards,
    Alberto Morillo
    SQLCoffee.com

    Friday, November 30, 2012 2:20 PM
    Moderator
  • Hi georgio,


    This error seems to happen when .mof files (Managed Object Format (MOF)) don’t get installed and registered correctly during set-up. To resolve this issue, I executed the following mofcomp command in command prompt to re-register the *.mof files:
     
    mofcomp.exe "C:\Program Files (x86)\Microsoft SQL Server\100\Shared\sqlmgmproviderxpsp2up.mof"


    Thanks.


    Maggie Luo
    TechNet Community Support

    Monday, December 03, 2012 12:21 PM
    Moderator
  • Is this a new Installation?

     1. Open SSMS in Integrated security Mode
     2. Right click on server name in Object explorer tree at the left
     3. Select properties -> Then choose the "Security" page at left
     4. Under Server Authentication, select "SQL Server and Windows Authentication mode"
     5. Click OK
     6. Exit SSMS completely
     7. Open "SQL Server Configuration Manager" (in Configuration menu under the "Microsoft SQL Server 2008 R2" menu item from start menu
     8. Select you instance on SQLExpress and restart the instance of the server (but this is ok for non express too)
     9. Exit SSCM - and to verify open SSMS again, but with "SQL Server Authentication" selected in the Authentication type dropdown - put in your SQL user ID and password.

     


    .Net thingy maker type guy.

    Sunday, June 09, 2013 3:14 PM