none
SQL Server Management Studio Slow Grid Draw and Refresh

    Question

  • I've istalled SQL2005/SSMS on my development machine and connecting to a local SQL Server 2005. Executing queries is fast but the results grid populating is slow and so is the refresh of the same data. This is not a slow query, its the gridview draw/redraw. I've other PC's with slower processors and less ram with the same software run circles around the SMSS Performance on this Laptop

     

    I've read posts about nvidia graphics drivers and mouse drivers causing issues similar to this. I do have an nvidia quadro x1600M (this is a laptop Compaq 8710w) and switching off the accelerator using Displays/Advanced/Troubleshooting by moving the slider to the middle/center position causes the gird refresh to dramatically increase. It's funny how turning oof the accelerator increases performance.

     

    I have the latest HP nvidia drivers and SSMS is useable without hardware acceleration  but I also develop software that uses directx and its getting really troublesome to work this way.

     

    I am running:

     

    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_qfe.070227-2300)
    Language: English (Regional Setting: English)
    System Manufacturer: Hewlett-Packard
    System Model: HP Compaq 8710w
    BIOS: EPP runtime BIOS - Version 1.1 
    Processor: Intel(R) Core(TM)2 Duo CPU     T7300  @ 2.00GHz (2 CPUs)
    Memory: 3072MB RAM
    Page File: 515MB used, 4439MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.2180 32bit Unicode

    All drivers up-to-date and latest microsoft updates (as of this posting)

     

    Major Software Instaled

    VS2005 Professional

    SQL Server 2005

    Office 2003 Professional

     

     

    Is there a way to adjust my system setup to have my acceleration at Full and get decent display results from SQL Server? Is there an nvidia tweak?
    Friday, March 07, 2008 1:05 AM

Answers

  • I experienced the same problem on HP Pavilioin dv7-4080us running Windows 7, SQL Server 2008 R2 Express, and Office 2010.

    After right clicking on view and Selecting Top 100 rows, response time was extremely slow.  SSMS started using a tremendous amount of memory.  After running a few of these, it would fail to respond.

    I suspected the video driver but that was not the problem.

    Had the same exact problem with MS Access.  Must be a conflict with DataGrid.

    Windows 7 Clean Boot procedure revealed the service Biometric Authentication Service (DigitalPersona DPHostw.exe) was the problem.

    Disabling the service fixed the problem.

     

     

     

     

    • Proposed as answer by Shane Pilo Thursday, July 29, 2010 9:38 PM
    • Marked as answer by Kalman TothEditor Wednesday, September 01, 2010 8:57 PM
    Friday, July 16, 2010 12:32 AM
  • I have the same problem on my desktop, XP sp3, SQL server 2005 sp2, GeForce 8800GT. I installed the latest nDidia driver from official website then the problem is gone.
    • Proposed as answer by telstar220 Saturday, June 27, 2009 5:35 AM
    • Marked as answer by Kalman TothEditor Sunday, June 28, 2009 11:50 AM
    Saturday, June 27, 2009 5:35 AM

All replies

  • I repeat your question, wbochar, cause I have the same issue using a Quadro NVS 290 video card and MS SQL Server 2005 Management Studio. Also, I've downloaded a Performance Type video driver from www.nvidia.com. To draw the grid in a table takes multiple seconds to do, and the same amount of time if I switch between windows, back and forth.

    I had to disable all directdraw and direct3d in order to improve sql server grid draw, but ain't happy with the workaround in the long term.

    Please, anyone that can aid us? HAS to be a more common problem, either with sql server or most likely Quadro-cards.
    Monday, March 17, 2008 12:28 PM
  • Gotta add my voice to the mix ...

     

    Exact same issue here. I am running an Nvidia Quadro FX 1600M on a Dell Precision M6300. SSMS draws the results grid painstakingly slow. I tried the above suggestion and it worked. If i change Display -> Settings - > Advanced -> Troubleshooting -> Hardware Acceleration to the 3rd tick or lower then the problem completely goes away. But that seems like an unreasonable solution. For now at least I got something to help me get through the workday. Thank you wbochar!

     

    Any other suggestions out there would be wonderfully appreciated!

     

    Spike

    Tuesday, March 18, 2008 4:10 AM
  •  

    Same issue here.  I'm on a Dell Precision T3400 with a Core 2 Quad and an Nvidia Quadro FX 1700.  The redraw time on the results grid in SSMS is painfully slow and even spurred a BSOD on me earlier today.  Like the others here, turning down my hardware acceleration corrects the issue and the performance becomes snappy.  Not exactly a great solution.  Anyone figure anything out about this?  It's rather annoying.

     

    Thanks!

    Wednesday, March 19, 2008 4:06 PM
  • Same problem here on a Dell Precision M6300, looks like it fixed by lowering hardware acceleration, which I agree is certainly not a solution. This problem presented it self secondary to upgrading the BIOS to version A08 and the video drivers to v.167.55, A00 for the Quadro FX3600M. I’m assuming that this problem is a result of the newer driver version judging by the dates on these posts. Going to try to find the original driver and reinstall to see if that resolves the issue.

     

    Has anyone had any success with this or any other fix?

     

    Wednesday, March 19, 2008 9:16 PM
  •  

    All I can think of is Direct X and Acceleration. Maybe a refresh of the directx drivers might work..
    Wednesday, March 19, 2008 10:54 PM
  • I tried the directX refresh and it didn't help. Did anyone else have any success?

     

     

    Sunday, March 23, 2008 3:56 PM
  • I haven't found a complete solution, however I reverted to my computer's original graphics drivers (Forceware 162.55) and the performance drastically improved.  It still isn't the best I've seen the results grid perform, and I'd expect better on this machine but at least it's usable now.

     

    Monday, March 24, 2008 11:33 AM
  •  

    I wish I could revert, my laptop's drivers for its nvidia chipset will only install using the HP driverset. When I try to use the nvidia installer, it doesnt allow me to install -- it forwards me to HP.

     

    Since this laptop and design are relatively new, there is only 2 driver sets available and both exhibit this issue.

     

    Monday, March 24, 2008 3:14 PM
  • I am having the same problem and the workaround kind of "solve" this issue. I have a nvidia geforce 5700 AGP (it's a desktop PC, not a laptop)
    Does anybody find any solution?
    Those who rollbacked to older drivers could solve the problem?
    Saturday, March 29, 2008 8:07 PM
  • I haven't tried to rollback any driver, and honestly, I'd find rolling back the drivers less attractive than

    lowering the hardware acceleration. At least, it's easy to switch back on, when 3d acceleration is req. I find it strange that noone knows the reason/solution.

    Monday, March 31, 2008 8:39 AM
  • Yes -- attempting to rollback drivers is messy business. The best thing to do is for everyone concerned is to post their graphics accelerators and general hardware config. As well as What OS and Graphics driver version they have. Maybe we will be able to see a pattern emerge.

     

    When you move the slider down to that level you are disabling Directx for the OS. So it looks like either the controls that rely on the directx are having a problem. The Grid control is pretty standard, does anyone have a windows app that uses the same grid control? If we can find something that uses it and its having the same problem -- then its to do with the grid. Maybe replacing the grid with a newer version or finding out if SQL server's client tools upgrade the grid control might have somehting to do with it.

     

    Anyone else have any ideas?

     

     

    Monday, March 31, 2008 5:57 PM
  • Everyone so far in the threads is using an Nvidia chipset. Also, looks like a Quadro based chipset too.

    Is there anyone with another manufacturer's chipset getting the same issue?

     

    If its so far only nvidia; maybe we should contact their driver team and ask them some questions. Anyone got a contact at Nvidia?

    Monday, March 31, 2008 6:01 PM
  • Hello,
    I have the exact same issue with a quadro fx 1700 from HP not only with SSMS but also with Quarkxpress and even worse with Adobe Lightroom in Pinstripe background mode (u can get it free here : http://labs.adobe.com/technologies/lightroom/).
    The redraw time is near to normal with the 162.63 driver and prior (slight T-shift though). Nothing but
    dragging the hardware acceleration slider down 3 notches really helps. I tried almost everything else :  fresh windows 32 and 64 install, SP2, SP3, march08 directx (4.09.0000.0904), quadro and mainboard bios (Intel D975xbx2), last nvidia drivers and so on. Note that disabling directdraw doesn't help either. The odd thing is that I have not a damn problem with my old quadro fx 560. I guess this could be related to the new nvidia unified architecture and old code parts unable to deal with it. There should be more people complaining unless very few applications are concerned so far. We should indeed contact nvidia.

    Thursday, April 17, 2008 3:26 AM
  • Hi.

     

    Yup, I downloaded and switched to pinstriped background mode in Lightroom 2 beta:

    HW Acceleration on full made it unusable, while on level 2 you don't notice a refresh at all.

     

    Thursday, April 17, 2008 11:11 AM
  • I have this problem off and on when connecting to sql server on network and sql server on remote site. I use Dell OptiPlex GX280 with Intel 82915G/GV/910GL Express Chipset.

     

    What is the deal with this problem? At first I thought it was the connection but connecting on local network has same problem so now I'm not sure.

     

    Thursday, April 17, 2008 8:43 PM
  • I've noticed that the Directx of several applications and games tends to bomb on the first run with this chipset (the one quoted earlier by me). I noticed that alot of laptop implementations install multiple dead monitors to handle a variety display situations. Normally if there is another monitor device thats been active at one time or another, it becomes dormant after its unplugged. There are 4 active "Default Monitor" and one "Plug and Play Monitor", total of 5 active displays on the system. Now 2 might be ok, if there was a vga/dvi attached and the laptops' mian lcd display -- not 5. Most applications that use a directdraw seem to go to the first default monitor which might be set to some wierd resolution and refresh to handle a NTSC Analogue TV output or HD TV. I found that if an application like a game or rendering system allows for a default resolution to be set, you set sit it to the LCD displays res and then when the app makes a request for a display surface if finds the one thats appropriately set. Other wise it tries to activate the first available monitor and refresh rate on dead/non active display.

     

    Monday, April 21, 2008 1:49 PM
  • I have the same Problem. First I had no problems. But for a short time my Grid is very slow and the redraw is incomplete (I didn't change the graphic drivers - It could be since I installed VS2008, but no guarantee). This is only when I open the table directly. When I open a new query with the same sql-command it works perfectly. Disabling directx-acceleration would solve the problem, but it isn't a solution for me.
    • Proposed as answer by telstar220 Saturday, June 27, 2009 5:32 AM
    Tuesday, April 22, 2008 8:30 AM
  •  

    We have a .NET app that uses the datagrid and users report very slow screen refresh when switching between this app and others. Turning hardware acceleration down to basic resolved that issue but has caused issues with apps requiring hardware acceleration for directX. I think this particular problem is related to this specific datagrid control though, not necessarily directX and NVidia hardware acceleration. We have other applications that require directX acceleration and they don't exhibit this kind of behavior with hardware acceleration set to full. The control we're using is the standard .NET 2.0 datagrid control.

    Thursday, May 01, 2008 3:16 PM
  • Anyone have any updates on this? Turning hardware acceleration fixed it but not an ideal solution.....

     

    Saturday, June 28, 2008 1:01 AM
  •  

    With a brand new NVIDIA Quadro NVS 140M card and SSMS Open Table the screens flickers and draws appr. 3 records pr. sec.

     

    Driver Date: 22-02-2008

    Driver Version: 6.14.11.7431

    Digital Signer: Microsoft Windows Hardware Compatibility Publisher

     

    Microsoft Team on SQL Server Management Studio - please address this screen hardware related issue asap.

     

    Drawing the Result grid have no performance problems!

     

    Terkild
    Wednesday, July 02, 2008 8:13 AM
  • FWIW, I have the same issue with my hardware, which is using an NVIDIA Quadro FX 3700.  ForceWare version 169.39.  Video BIOS version 62.92.19.00.07.  I am not only seeing this issue with SQL Server Management Studio 2005, but also with the Query Results window from Team Explorer 2005 within Visual Studio 2005.  Setting the hardware acceleration to the third tick solves the problem for both pieces of software.  One tip for those with multiple monitors is that you can set the hardware acceleration up for each monitor - so you could have one monitor set to Full and run your DirectX intensive apps on that monitor.

    Tuesday, August 05, 2008 7:06 PM
  • I had an app with grid control that did same thing. A colleague converted it to devex xgrid and it went away. I still have problem with MSSMSE though. Running nvidia GEForce  with latest drivers.

     

    Friday, August 08, 2008 4:06 PM
  • same problem, drawing is slow inside SQL Server Management Studio Express.

    i have
    windows xp sp3
    Asus Nvidia Geforce GTX 260 with latest drivers.
     

    Friday, August 22, 2008 7:07 PM
  • same problem, drawing is slow inside SQL Server Management Studio Express.

    i have
    windows xp sp3
    Asus Nvidia Geforce GTX 260 with latest drivers.
    Intel Core 2 Quad 9450

    Friday, August 22, 2008 7:08 PM
  • I guess we by now know that something isn't as it should be. But I don't have a clue on where and how to start testing in order to find a solution (better than lowering the hardware acceleration).

     

    Are there any that have contacted M$ and gotten a decent reply/hotfix/tip? I find it rather weak by M$ not to take this seriously, but maybe they haven't been given it enough focus? Do they even READ these forum threads?

     

    Anyone contacted NVIDIA about it? I noticed that my NVIDIA GTX 8800 also gave me a slow MSSQL experience.

    Monday, August 25, 2008 6:53 AM
  • Has anyone found a solution to this problem?  I'm running into the same issue on an 8500gt.

     

     

     

    Friday, September 19, 2008 2:31 PM
  • Turning down acceleration to ensure directx acceleration is turned off is the tweak you need. With the nview desktop manager you can create application-specific settings. I've had to do this to accommodate autodesk Inventor running alongside apps that use the grid control with good results.

    Saturday, September 20, 2008 4:50 PM
  • The question is:

     

    Does Microsoft fix the Gridview component - so it works along with all hardware accelerators?

     

    Does anyone know if this problem still exists in SQL 2008 Management Studio (on hardware accelerators pc's) or any other newer VS2008 software?

     

    Terkild

    Monday, September 22, 2008 5:47 AM
  • Just turn hardware acceleration down to the point where DirectX acceleration is turned off. Another option is to use the nview desktop manager to create application-specific settings for those apps where the gridview is used and turn off DirectX acceleration just for those apps. Hope this helps.

    Tuesday, September 23, 2008 3:33 AM
  •  scottdennis wrote:

    Just turn hardware acceleration down to the point where DirectX acceleration is turned off. Another option is to use the nview desktop manager to create application-specific settings for those apps where the gridview is used and turn off DirectX acceleration just for those apps. Hope this helps.

     

    Thanks for the reply.  I had already disabled DirectX but that doesn't seem to be an ideal solution.  The nview desktop sounds like it would be great except it looks like nvidia has excluded it from their latest drivers and although it says in the release notes that it exists as an add-in I can't seem to find it.  This is a problem that Nvidia and/or MS should address.  I guess we're in the minority so it's not important.

    Tuesday, September 23, 2008 12:05 PM
  • But tell me, ARE we a minority? This problem has been addressed many places, by many. I considered this a major flaw, and not a single NVIDIA or Microsoft representative in sight. This thread ain't new, either, but it gives no solution to the problem, just increases as more and more experience the same as us. Who has been in contact with either of them more directly, I wonder?
    Tuesday, September 23, 2008 12:16 PM
  •  scottdennis wrote:

    With the nview desktop manager you can create application-specific settings. I've had to do this to accommodate autodesk Inventor running alongside apps that use the grid control with good results.

     

    I'm running an 8600M GT.  I have the same issue with management studio grids but mine is a bit more serious.  If I open a grid it is slow and causes screen artifacts.  If I try to scroll it I get a BSOD.  Not good.  You mention using nview.  I've added sqlwb to the applications in the nview properties, but the options I see for available tweaks in "Individual Settings" and "Enhancements" don't seem to have anything to do with turning DirectX on or off.  Could you please indicate what settings you modified at the nview application level?  It is really difficult to work with Management Studio, Visual Studio 2008, and Flash at the same time.  I need the directx for flash and I'm constantly having to shut down management studio and turn the acceleration back on through the advanced display properties.

     

    Thanks in advance!

    Saturday, October 04, 2008 3:35 PM
  • The only settings I've added are for Autodesk Inventor. I turned hardware acceleration down to the point that DirectX acceleration was off at the desktop level. I then created an application-specific setting for Inventor and disabled it. This effectively forced NView to disregard settings for the desktop and allowed Inventor to manage it's own DirectX settings. I'm assuming that some of the calls the application makes into the DirectX libraries are somehow optimized when the manager is active. You might try the same trick with Flash. We have a laptop that is having the same problem with screen artifacts and this didn't seem to resolve that problem. I'm starting to wonder if the NVidia drivers are really fully DirectX compliant.

    Saturday, October 04, 2008 6:52 PM
  • I have the same issue.  It seems to me that for every row it draws, that it redraws every windows in the system, including other programs.  I tend to have a lot of windows open, and they all flicker and flash when I am using Management Studio.  It is the one program that I make sure I close when I am not actively using it.

     

    Thursday, October 09, 2008 3:12 PM
  • Same issuse to me on my working-pc in my company!

    But i'am using no nvidia-card but an Intel-Chip with a "82915G/GV/910GL Express Chipset" driver.

    The Grid in the SSMS draws itself very slow when opening a table in it.

    Reducing HW-acceleration with the windows slider as often mentioned resolves the problem.

    But isn't a good solution.


    Greetz skymax
    Monday, November 03, 2008 1:13 PM
  • I'm having the same problem. I also see a drastic performance improvement in SMSS when I disable hardware acceleration.

    Microsoft SQL Server Management Studio                        9.00.3042.00
    Microsoft Analysis Services Client Tools                        2005.090.3042.00
    Microsoft Data Access Components (MDAC)                        2000.085.1132.00 (xpsp.080413-0852)
    Microsoft MSXML                        2.6 3.0 5.0 6.0
    Microsoft Internet Explorer                        7.0.5730.13
    Microsoft .NET Framework                        2.0.50727.1433
    Operating System                        5.1.2600

    Using a NVIDIA Quadro 570M (Lenovo T61p).
    Friday, November 14, 2008 11:24 PM
  • I ran into this problem for a long time with nVidia cards. I just recently installed the latest nVidia drivers and it has drastically improved the performance of the grids in SSMS and other programs.

     

    You can download the latest drivers here: http://www.nvidia.com/Download/index.aspx?lang=en-us

    I installed: 178.24, released 15 Oct, 2008 for my GeForce 8500 GT PCIx card.

    Thursday, November 20, 2008 8:51 PM
  • Yes. Confirmed! This completely fixed the issue for me. Yahoo!

     

    Thank you!

     

    - Spike

    Thursday, November 20, 2008 8:57 PM
  • Because HP-equipment owners can't download from the nvidia website directly, they have to wait for HP to bring up the fix.

    HP has released an update for the NVIDIA driver, but posted the wrong link on their download site. 
    The new driver solves the problem in my case (hp compaq 8710w, xp professional, NVIDIA Quadro FX 3600M).  The new driver can be downloaded from this location: ftp://ftp.hp.com/pub/softpaq/sp41001-41500/sp41310.exe.
    Monday, January 12, 2009 9:35 PM
  • scottdennis said:

     

    We have a .NET app that uses the datagrid and users report very slow screen refresh when switching between this app and others. Turning hardware acceleration down to basic resolved that issue but has caused issues with apps requiring hardware acceleration for directX. I think this particular problem is related to this specific datagrid control though, not necessarily directX and NVidia hardware acceleration. We have other applications that require directX acceleration and they don't exhibit this kind of behavior with hardware acceleration set to full. The control we're using is the standard .NET 2.0 datagrid control.




    This fixed the flicker of the DataGridView control, I hope it will help you too.

    1    /// <summary> 
    2    /// Custom flicker-free DataGridView 
    3    /// </summary> 
    4    public class CustomDataGridView : DataGridView 
    5    { 
    6        /// <summary> 
    7        /// Creates a new flicker-free instance. 
    8        /// </summary> 
    9        public CustomDataGridView() : base() 
    10        { 
    11            base.DoubleBuffered = true
    12        } 
    13    } 

    Wednesday, January 14, 2009 9:59 AM
  • Well I wish I had seen this thread earlier as I have been struggling with this for over a year now.
     
    Yes, turning off DirectX seems to fix the problem... but what are the side-effects of doing this?  I noticed I get an ugly black bar under my address bar on Internet Explorer 8 - hopefully this is the full extent of the new problems I will encounter.

    Monday, January 19, 2009 3:57 PM
  • Happening on new Dell XPS M1530 here, SQL Management Studio 2005 SP3.
    Have latest nVidia drivers.

    Will try turning hardware acceleration down, but seems more of a work-around than a fix - thanks to those who worked it out though.

    Everything worked perfectly on an old Acer with ATI card and half the RAM.
    Monday, June 01, 2009 8:18 PM
  • I have the same problem on my desktop, XP sp3, SQL server 2005 sp2, GeForce 8800GT. I installed the latest nDidia driver from official website then the problem is gone.
    • Proposed as answer by telstar220 Saturday, June 27, 2009 5:35 AM
    • Marked as answer by Kalman TothEditor Sunday, June 28, 2009 11:50 AM
    Saturday, June 27, 2009 5:35 AM
  • I experienced the same problem on HP Pavilioin dv7-4080us running Windows 7, SQL Server 2008 R2 Express, and Office 2010.

    After right clicking on view and Selecting Top 100 rows, response time was extremely slow.  SSMS started using a tremendous amount of memory.  After running a few of these, it would fail to respond.

    I suspected the video driver but that was not the problem.

    Had the same exact problem with MS Access.  Must be a conflict with DataGrid.

    Windows 7 Clean Boot procedure revealed the service Biometric Authentication Service (DigitalPersona DPHostw.exe) was the problem.

    Disabling the service fixed the problem.

     

     

     

     

    • Proposed as answer by Shane Pilo Thursday, July 29, 2010 9:38 PM
    • Marked as answer by Kalman TothEditor Wednesday, September 01, 2010 8:57 PM
    Friday, July 16, 2010 12:32 AM
  • I 2nd the Biometric Authentication Service.

     

    I have no idea why it makes a difference, but disabling login protection in HP Protect Tools and disabling the service did the trick for me and a coworker.

    Thursday, July 29, 2010 9:40 PM
  • I can also 2nd the Biometric Authentication Service.

    Everyone at my office have the same type of laptop and the same problem. Uninstalling HP Protect Tools resolved this issue for everyone.

    Friday, August 27, 2010 11:29 AM
  • This solution also works for me. Thanks.

    However, did anyone know whether HP relaese any patch on this issue?

     

    Tuesday, November 09, 2010 6:46 PM
  • Thank you, thank you!

    I have been battling with this problem with both my previous laptop (HP ProBook 4520) and my current one (HP Pavilion dv7) for a while now.

    Disabling the Biometric Authentication Service (DigitalPersona), then rebooting my machine fixed the problem.

     

    Tuesday, February 01, 2011 5:55 AM
  • I yesterday came across this discussion. I was facing the same problem on very much the same hardware (an HP 8540w). I tried looking into the solutions mentioned here. Disabling the DPHostw service or nVidia functionalities certainly did not help, it only crippeled the laptop. After searching some more I found this solution: http://social.msdn.microsoft.com/Forums/en/sqltools/thread/27197d4e-3f08-41ea-a8a9-36af33ee431d

    It is excellent. Just right click the SSMS icon, select properties and change into XP sp3 compatibility mode. Check that your UAC settings are not the lowest.

     

    Cheers!

    Tuesday, February 15, 2011 8:29 AM
  • I've found a solution on my Windows 7 system. Assuming that the issue is with DirectX, I have SSMS on the Start menu, and if I change the Properties, and on the Compatibility tab set it to XP SP3 it works like charm. I read that XP compatibility doesn't use the Aero/DirectX that native Windows 7 does.

    • Proposed as answer by chieflyBrit Tuesday, April 12, 2011 7:07 PM
    Tuesday, April 12, 2011 6:50 PM
  • funciona!!!... gracias.

     

    works for me. Thanks.

     

     

    Tuesday, April 12, 2011 10:25 PM
  • Thanks a milllion.  Worked for me.
    Thursday, June 02, 2011 9:59 AM
  • Alternate:

    I had the same issues and came across the following thread.  I made the '<process name="ssms.exe" type="skip"/>' change to the "C:\Program Files (x86)\DigitalPersona\Bin\Coruscant\customization_per.xml", rebooted and all is well.  I have a Pavilion dv7 running Windows 7 Home Premium (x64)

    http://h30434.www3.hp.com/t5/Notebook-Operating-systems-and/Microsoft-SQL-Server-Management-Studio-slow-on-EliteBook-8440p/td-p/314236


    • Edited by resavage Monday, September 26, 2011 9:19 PM
    Monday, September 26, 2011 9:09 PM
  • My probs existed with ssms 2005, with sp4 installed, on win7 pro 64bit. I have a ASUS A53S laptop running an NVIDIA GeForce GT840M with CUDA & an integrated graphics driver as well from Intel : HD 3000. I also have logitech's setpoint which has been a source of some probs for some folks.

    I tried: updating drivers, tweaking gfx settings, loading in xp sp3 compatibility, etc. Nothing worked.. at least consistently. 

    Ultimately I gave up the fight and installed Oracle's free VirtualBox, and setup some winxp VMs. I  now have two separate VMs, one with SSMS 2005, and have another one with SSMS 2008. 

    Everything runs as fast as it should be! My 64bit parent OS handles all this greatly. No more issues. VirtualBox has come a long way if you haven't used it in awhile. I highly recommend for those on win7 64, who have the HD space and system resources avail to setup VMs, (mine are just 15gig apiece). 

    Now I have dedicated virtual machines for SSMS and NO issues, no hassles.

    https://www.virtualbox.org/

    -Steve

    Thursday, September 29, 2011 3:11 PM
  • I have an HP Probook 4520 running windows 7 64bit and i have been plagued with this problem for months, after upgrading to SQL server 2008 R the whole laptop came crashing to a halt.

    as suggested i disabled the Biometric Authentication Service, restarted Sql management Studio and everything has been runnnig fine since.

    thanks.

    Thursday, March 15, 2012 8:40 AM
  • Thanks to the solution from Pajamas. My problem was also related the Digital Persona. I have also battled with this sluggish performance for almost 6 months now. I am using a dv6 machine. I also did not need to restart the machine, just restarting the ssms was required.
    Tuesday, July 10, 2012 3:08 PM