none
SSRS Pop up in new window report ask for credentials

    Question

  • Hi,

    I have created a ASP website which uses reportviewer control for rendering reports from report server.

    On the main report , I have used Go to URL to show subreport in new window(pop up).  I have hosted this website  on IIS server.

    When I try to access main report (i.e. Home.aspx), I am geeting content of main report from reporting server and it's not asking me for credentials.

    But when I click on link for subreport. it is asking for credentials for pop up window. I am not getting point that why it's asking credentials for only pop-up and not for main report. If my SSRS is not properly configured, then it should ask credentials for main report as well but it prompt for only pop-up.

    I am using SSRS 2008. SSRS and IIS both are on same machine.  I have used javascript function for Go to URL  expression.

    Followign are screenshots for both scenario.

    Main Report - Links to subreport which is open in new pop up window (No credentials asked here)

    Subreport Pop up windows (Prompt for  credentials)



    Wednesday, May 09, 2012 3:25 PM

Answers

  • Hi,

    In order to avoid the pop-up dialog, please refer to the following steps:
    1. Open IE
    2. Click the menu "Tools" -- > "Internet Options..."
    3. Go to "Security" tab.
    4. Select "Local Intranet" zone, then click "Custom Level"
    5. Check the item "Auto logon with current user and password"1. Ensure the current window users can access the detail report.

    If the above way does not work, try to remove RSWindowsNegotiate and ensure RSWindowsNTLM is specified in the file rsreportserver.config

    Thanks,
    Challen Fu


    Challen Fu

    TechNet Community Support

    Monday, May 14, 2012 8:35 AM
    Moderator

All replies

  • Is the URL of the main report http:\\192.168.1.200 or an actual servername?

    Chuck


    Wednesday, May 09, 2012 3:34 PM
  • thanks chuck for the quick reply.

    http:\\192.168.1.200:86 is our server where we are hosting our website

    and our reports are deployed at http:\\192.168.1.200:84\reports

    Wednesday, May 09, 2012 3:40 PM
  • Hi,

    In order to avoid the pop-up dialog, please refer to the following steps:
    1. Open IE
    2. Click the menu "Tools" -- > "Internet Options..."
    3. Go to "Security" tab.
    4. Select "Local Intranet" zone, then click "Custom Level"
    5. Check the item "Auto logon with current user and password"1. Ensure the current window users can access the detail report.

    If the above way does not work, try to remove RSWindowsNegotiate and ensure RSWindowsNTLM is specified in the file rsreportserver.config

    Thanks,
    Challen Fu


    Challen Fu

    TechNet Community Support

    Monday, May 14, 2012 8:35 AM
    Moderator