none
AlwayOn - Problems creating AlwaysOn Availability Group

    Question

  • Hi,

    I have installed SQL Server 2012 on 2 machines using the same domain account for both, but when I am trying to create AlwaysOn Availability Group it fails to join the database to the availability group and I see the following error in the server logs:

    2012-11-24 15:05:02.48 Logon       Database Mirroring login attempt by user 'DC1\SQL2$.' failed with error: 'Connection handshake failed. The login 'DC1\SQL2$' does not have CONNECT permission on the endpoint. State 84.'.  [CLIENT: 192.168.2.193] <-- This is the secondary node

    And when I try to grand the CONNECT permission on the endpoint to the domain user I get the following msg:

    GRANT CONNECT ON ENDPOINT::[Hadr_endpoint] TO [DC1\Administrator]
    GO

    Cannot grant, deny, or revoke permissions to sa, dbo, entity owner, information_schema, sys, or yourself.

    I tried granting this permission to this user using with a number of accounts but none worked.

    I read quite a few articles on configuring AlwaysOn and I was under the impression that if you do the installation with the same domain account on all nodes with just one domain user setup for sql server, it should work.

    I am now stuck please help me get around it

    Thanks a lot

    T

    Saturday, November 24, 2012 4:23 PM

Answers

  • Hello Terry,

    I haven't yet had the chance to play with AlwaysOn technologies, but the error you are receiving is fairly common. The error is stating that the login 'DC1\SQL2$' does not have connect permission which you've already noticed. The interesting thing is that this is the COMPUTER account of the machine named 'SQL2' in domain 'DC1'. This tells me that SQL Server isn't running under a domain account as it's attempting ot use the computer account for network access. Please verify that the account used for SQL Server is a domain account and not network service or local system (or a local user account).

    -Sean


    Sean Gallardy | Blog | Twitter

    • Marked as answer by TerryHam531 Monday, November 26, 2012 9:01 PM
    Sunday, November 25, 2012 2:22 AM

All replies

  • Hello Terry,

    I haven't yet had the chance to play with AlwaysOn technologies, but the error you are receiving is fairly common. The error is stating that the login 'DC1\SQL2$' does not have connect permission which you've already noticed. The interesting thing is that this is the COMPUTER account of the machine named 'SQL2' in domain 'DC1'. This tells me that SQL Server isn't running under a domain account as it's attempting ot use the computer account for network access. Please verify that the account used for SQL Server is a domain account and not network service or local system (or a local user account).

    -Sean


    Sean Gallardy | Blog | Twitter

    • Marked as answer by TerryHam531 Monday, November 26, 2012 9:01 PM
    Sunday, November 25, 2012 2:22 AM
  • Hi Sean

    Thank you very much for your response and you are right the instance was running under local machine account though I have installed the software under a domain account and was under the impression that it would use the same account for all SQL Server services.

    Again appreciate your help and your observation is great.

    Regards

    T

    Sunday, November 25, 2012 12:22 PM
  • HI terry,

    is your issue resolved?

    after resolving your permissions when you deal with always on here are few tips.

    make sure your clusteraccount have local admin rights on the nodes.

    if you can enable the always on you can easily create the high availability groups between standard alone instancess. it is stright forward.

    thanks

    kumar

    Monday, November 26, 2012 1:42 AM
  • Hi Kumar

    Thanks for your tips, yes after I changed the instance login property the problem went away ( thanks to Sean ).

    Rgds

    T

    Monday, November 26, 2012 2:11 PM
  • Hello Terry,

    If my solution fixed your issue, please mark it as the answer so that others can quickly find it if they are having a similar issue!

    -Sean


    Sean Gallardy | Blog | Twitter

    Monday, November 26, 2012 2:12 PM
  • Hi Sean

    Sorry as I should have done that in the first place, I am very new to this forum and Windows.

    I have posted another question at the following link if you would like to look at it.

    http://social.technet.microsoft.com/Forums/en-US/transactsql/thread/5fe44e69-aacc-423b-8088-529c87e76394

    Thanks again

    Rgds

    T

    Monday, November 26, 2012 9:19 PM