none
sql 2008 express not listening on port 1433

    Question

  • I installed sql 2008 express on 2008R2 but it is not listening on port 1433.

    I check configuration for tcp and enabled that already. also started sql browser service.

    any idea?

    Saturday, April 07, 2012 1:37 AM

Answers

  • I installed sql 2008 express on 2008R2 but it is not listening on port 1433.

    I check configuration for tcp and enabled that already. also started sql browser service.

    any idea?

    by default SQL Server Express does not enable Remote Connections.

    Could you check the following:

    1) check that the SQL Express is running (SQL Server Configuration Tool)

    2) log onto the box containing the SQL Server and try to connect with SSMS to the SQL Express instance. Try tcp/ip and/or shared memory to connect.
       if you can successfully login check that the SQL Server does allow Remote Connections

    3) Firewall does not block incoming connections

    4) does the DNS server name resolve to the correct ip address of the SQL Server ?

    Saturday, April 07, 2012 8:33 AM

All replies

  • Hello,

    Please check the SQL Server log file, at the beginning there is noted if the SQL Server is listening on TCP/IP protocoll and on which port.


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing

    Saturday, April 07, 2012 2:23 AM
  • where is the log file?

    I followed this exactly step by step but still doesnt want to listen on 1433. I cannot even login via sql studio express

    http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/

    Saturday, April 07, 2012 5:10 AM
  • I installed sql 2008 express on 2008R2 but it is not listening on port 1433.

    I check configuration for tcp and enabled that already. also started sql browser service.

    any idea?

    by default SQL Server Express does not enable Remote Connections.

    Could you check the following:

    1) check that the SQL Express is running (SQL Server Configuration Tool)

    2) log onto the box containing the SQL Server and try to connect with SSMS to the SQL Express instance. Try tcp/ip and/or shared memory to connect.
       if you can successfully login check that the SQL Server does allow Remote Connections

    3) Firewall does not block incoming connections

    4) does the DNS server name resolve to the correct ip address of the SQL Server ?

    Saturday, April 07, 2012 8:33 AM
  • You can open the log from SSMS => Management => SQL Server Logs.

    Or you can open it from Windows Explorer, it' as simple text file. You will find it in C:\Program Files\Microsoft SQL Server\MSSQL10_50.SQLEXPRESS\MSSQL\Log


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing

    Saturday, April 07, 2012 3:46 PM
  • hi, the below link ma help you out.

    http://support.microsoft.com/kb/823938

    • Proposed as answer by Kridly Sunday, January 06, 2013 7:01 PM
    Monday, April 16, 2012 4:21 PM
  • Solved it.  I went to Protocols for SQLExpress, IP Address and then at the very bottom, set IPALL to 1433.  Restart SQL service.  Whala.  What a pain but works now.
    Sunday, January 06, 2013 7:04 PM