none
FIX TO: The attempt to connect to the report server failed. Check your connection information...

    General discussion

  • If you get the error message: The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version.

    If you then scan the recent logfiles in C:\Program Files\Microsoft SQL Server\MSSQL.1\Reporting Services\LogFiles and find the following exception: Microsoft.SqlServer.ReportingServices2005.RSConnection+MissingEndpointException: The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version. ---> System.Net.WebException: The request failed with HTTP status 404: .

    it means that you have configured the /reportserver/ app to not be reachable via http://localhost/... - there are two options from here:

    1) add the localhost hostheader to the web-site which hosts the /reportserver/ and make sure the app is then reachable via that path

    2) edit the file C:\Program Files\Microsoft SQL Server\MSSQL.1\Reporting Services\ReportManager\RSWebApplication.config and add the full url to the ReportServer into the ReportServerUrl tag (no ending / nessesary) AND remove the value from ReportServerVirtualDirectory (otherwise you get nasty, unprecise exceptions). THEN you must recycle the app-pool used by the Report-Manager so that config file is being reloaded.

    Wednesday, January 11, 2006 7:46 AM

All replies

  • THANK YOU VERY MUCH FOR YOUR HELP.

    Thursday, October 05, 2006 8:35 AM
  •  

    Thank You for the FIX TO: message - just what I needed to implement Reporting services on a secondary web site (with different host header)

    Added  the complete url and removed the entry from the ReportServerVirtualDirectory and everything worked - glad I found this - wish I would have found it before I reinstalled RS 2005 a couple times..

    thanks tilfried for your contribution

    John F

     

    Thursday, December 21, 2006 1:39 AM
  • Glad I could help :)

    When one messes around a couple of hours trying to fix a problem, I think it's worth the extra 5 mins to post the solution!

    Thursday, December 21, 2006 7:46 AM
  • Many thanks for your post, Tilfried Weissenberger. thanks
    Thursday, April 12, 2007 9:54 AM
  • Hello all,

    Could some one please explain the security piece of reporting services? What type of IDs do I need, do I need to use SPN accounts if yes how and where would I put/specify this SPN account. Basically I am trying to understand how to setup security when I install reporting services.

     

    Thanks

    MA

    Monday, July 02, 2007 6:43 PM
  • You would have to edit the rsreportserver.config file with the full fqdn of the report server as well.
    Monday, July 09, 2007 6:07 PM
  • Tilfried:

     

    Thank you!  Thank you!  If you are ever in southwest Florida, look me up, and I'll buy you a beer!  I mean it.  And there aren't many Vangors in the phone book down here, so I'll be easy to find.  Or google me.

     

    This was the final piece of the puzzle that I needed to get SSRS 2005 working on my Win2K Server with SQL Server 2000. 

     

    In my case, I made the following changes to the RSWebApplication.config file:

    From:       <ReportServerUrl></ReportServerUrl>
    To:           <ReportServerUrl>http://www.mydomain.com/ReportServer</ReportServerUrl>

     

    From:      <ReportServerVirtualDirectory>ReportServer</ReportServerVirtualDirectory>
    To:          <ReportServerVirtualDirectory></ReportServerVirtualDirectory>

    Thanks, again!

    Van

    Wednesday, August 29, 2007 7:20 PM
  •  

    It was very helpful. Thanks//
    Tuesday, January 01, 2008 8:36 AM
  • Thanks Tilli.

     

    Thanks a Ton, it worked for us.

     

    Wednesday, February 27, 2008 12:53 PM
  • i followed your instruction but its still not connecting!

    any idea?

    Tuesday, April 22, 2008 1:56 PM
  • if you want help, you should post the exact error-message from the logfile. Superman's on vacation Wink

    Monday, April 28, 2008 12:13 PM
  • Same error: "The attempt to connect..."

     

    Config file:

     

    My Reporting Services Config is up and running with no error, just cant seem to actually log into Report Manager to config the rest. 

     

    Suggestions??


    Thanks!

     

    Robert

    <Configuration>

    <UI>

    <ReportServerUrl>http://rlewis-lt:82/ReportDev</ReportServerUrl>

    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>

    <ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel>

    </UI>

    <Extensions>

    <DeliveryUI>

    <Extension Name="Report Server Email" Type="Microsoft.ReportingServices.EmailDeliveryProvider.EmailDeliveryProviderControl,ReportingServicesEmailDeliveryProvider">

    <DefaultDeliveryExtension>True</DefaultDeliveryExtension>

    <Configuration>

    <RSEmailDPConfiguration>

    <DefaultRenderingExtension>MHTML</DefaultRenderingExtension>

    </RSEmailDPConfiguration>

    </Configuration>

    </Extension>

    <Extension Name="Report Server FileShare" Type="Microsoft.ReportingServices.FileShareDeliveryProvider.FileShareUIControl,ReportingServicesFileShareDeliveryProvider"/>

    </DeliveryUI>

    </Extensions>

    <Add Key="MaxActiveReqForOneUser" Value="20"/>

    <Add Key="DisplayErrorLink" Value="true"/>

    </Configuration>

     

    Wednesday, May 14, 2008 5:29 PM
  • Okay, so here's where I stand.  I've got Vista Business laptop.  I've got Visual Studio 2008, SQL Server Dev Edit 2005 SP2, IIS 7.0 on this box.  I've got Reporting Services running, everything looks great in Configuration Manager.  However, I cannot hit Report Manager to save my butt.  The log for reporting services is in blue.  The Config file is in red. 

     

    Please shed some light on where I've got this botched.  I'd really appreciate it.

     

    Regards,


    Robert

     

     

    <Header>
      <Product>Microsoft SQL Server Reporting Services Version 9.00.3042.00</Product>
      <Locale>en-US</Locale>
      <TimeZone>Eastern Daylight Time</TimeZone>
      <Path>c:\Program Files\Microsoft SQL Server\MSSQL.2\Reporting Services\LogFiles\ReportServerWebApp__05_21_2008_07_38_19.log</Path>
      <SystemName>RLEWIS-VCL</SystemName>
      <OSName>Microsoft Windows NT 6.0.6000.0</OSName>
      <OSVersion>6.0.6000.0</OSVersion>
    </Header>
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing ReportBuilderTrustLevel to '0'  as specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing MaxActiveReqForOneUser to '20' requests(s) as specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing MaxScheduleWait to default value of '1' second(s) because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing DatabaseQueryTimeout to default value of '30' second(s) because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing ProcessRecycleOptions to default value of '0'  because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing RunningRequestsScavengerCycle to default value of '30' second(s) because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing RunningRequestsDbCycle to default value of '30' second(s) because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing RunningRequestsAge to default value of '30' second(s) because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing CleanupCycleMinutes to default value of '10' minute(s) because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing DailyCleanupMinuteOfDay to default value of '120' minutes since midnight because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing WatsonFlags to default value of '1064'  because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing WatsonDumpOnExceptions to default value of 'Microsoft.ReportingServices.Diagnostics.Utilities.InternalCatalogException,Microsoft.ReportingServices.Modeling.InternalModelingException'  because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing WatsonDumpExcludeIfContainsExceptions to default value of 'System.Data.SqlClient.SqlException,System.Threading.ThreadAbortException'  because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing SecureConnectionLevel to default value of '1'  because it was not specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing DisplayErrorLink to 'True'  as specified in Configuration file.
    w3wp!library!5!5/21/2008-07:38:19:: i INFO: Initializing WebServiceUseFileShareStorage to default value of 'False'  because it was not specified in Configuration file.
    w3wp!ui!5!5/21/2008-07:38:25:: e ERROR: The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version.
    w3wp!ui!5!5/21/2008-07:38:25:: e ERROR: HTTP status code --> 500
    -------Details--------
    Microsoft.SqlServer.ReportingServices2005.RSConnection+MissingEndpointException: The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version. ---> System.Net.WebException: The request failed with HTTP status 404: Not Found.

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.GetSecureMethods()

       at Microsoft.ReportingServices.UI.Global.RSWebServiceWrapper.GetSecureMethods()

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.IsSecureMethod(String methodname)

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.ValidateConnection()

       --- End of inner exception stack trace ---

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.MissingEndpointException.ThrowIfEndpointMissing(WebException e)

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.ValidateConnection()

       at Microsoft.ReportingServices.UI.ReportingPage.EnsureHttpsLevel(HttpsLevel level)

       at Microsoft.ReportingServices.UI.ReportingPage.ReportingPage_Init(Object sender, EventArgs args)

       at System.EventHandler.Invoke(Object sender, EventArgs e)

       at System.Web.UI.Control.OnInit(EventArgs e)

       at System.Web.UI.Page.OnInit(EventArgs e)

       at System.Web.UI.Control.InitRecursive(Control namingContainer)

       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    w3wp!ui!5!5/21/2008-07:38:29:: e ERROR: Exception in ShowErrorPage: System.Threading.ThreadAbortException: Thread was being aborted.
       at System.Threading.Thread.AbortInternal()
       at System.Threading.Thread.Abort(Object stateInfo)
       at System.Web.HttpResponse.End()
       at System.Web.HttpServerUtility.Transfer(String path, Boolean preserveForm)
       at Microsoft.ReportingServices.UI.ReportingPage.ShowErrorPage(String errMsg) at    at System.Threading.Thread.AbortInternal()
       at System.Threading.Thread.Abort(Object stateInfo)
       at System.Web.HttpResponse.End()
       at System.Web.HttpServerUtility.Transfer(String path, Boolean preserveForm)
       at Microsoft.ReportingServices.UI.ReportingPage.ShowErrorPage(String errMsg)

     

    <Configuration>

    <UI>

    <ReportServerUrl>http://rlewis-vcl:82/reportserver</ReportServerUrl>

    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>

    <ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel>

    </UI>

    <Extensions>

    <DeliveryUI>

    <Extension Name="Report Server Email" Type="Microsoft.ReportingServices.EmailDeliveryProvider.EmailDeliveryProviderControl,ReportingServicesEmailDeliveryProvider">

    <DefaultDeliveryExtension>True</DefaultDeliveryExtension>

    <Configuration>

    <RSEmailDPConfiguration>

    <DefaultRenderingExtension>MHTML</DefaultRenderingExtension>

    </RSEmailDPConfiguration>

    </Configuration>

    </Extension>

    <Extension Name="Report Server FileShare" Type="Microsoft.ReportingServices.FileShareDeliveryProvider.FileShareUIControl,ReportingServicesFileShareDeliveryProvider"/>

    </DeliveryUI>

    </Extensions>

    <Add Key="MaxActiveReqForOneUser" Value="20"/>

    <Add Key="DisplayErrorLink" Value="true"/>

    </Configuration>

    Wednesday, May 21, 2008 11:47 AM
  • In your confg file try to remove the "http://" and the port number ":82" and just leave the Alias name and see if that resolves the issue

     

    e.g:

    "<Configuration>

    <UI>

    <ReportServerUrl>rlewis-vcl</ReportServerUrl>"

     

    Once you save this try accessing your RS via the following URLs:

    http://rlewis-vcl:82/reportserver

    http://rlewis-vcl:82/reports

     

     

    Hope this helps

     

     

    Thursday, May 22, 2008 2:36 AM
  • Just to say thanks - after waiting for the it team to resolve security problems -  I did a bit of digging and found this easy fix.

     

     

    Wednesday, May 28, 2008 3:56 PM
  • Thanks Van!
    Thursday, May 29, 2008 2:25 PM
  •  

    how you do this

     

    1) add the localhost hostheader to the web-site which hosts the /reportserver/ and make sure the app is then reachable via that path

    Thursday, May 29, 2008 5:46 PM
  • I tried option one and got nowhere.  I tried adding "localhost" as the hostheader in the webserver....but maybe I did it wrong.  I think I just put "localhost" in the window (advanced) with the IP address.

     

    Amazingly, option two worked for me.  Important to REMOVE the virtual directory and append it to the URL in the URL tag.  here's what I did:

     

    <ReportServerUrl>http://sql01.joho.com/ReportServer</ReportServerUrl>
      <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
      <ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel>

     

    fingers crossed that my install of CRM is finally going to work...!

    Tuesday, July 15, 2008 7:49 AM
  • I tried #2 to no avail.
    When I browse to http://localhost/reportserver I get the following error:


    Error Summary

    HTTP Error 404.2 - Not Found


    The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server.




    Tuesday, October 21, 2008 7:51 PM
  • David this should be easy to fix, please follow the following steps and provide the requested information so I can further assist you: (Assuming you are running SSRS on Windows Server 2003 with IIS 6.0)

    1. Start -> Administrative Tools -> Internet Information Services (IIS) Manager
    2. Under IIS -> Click on the "+" next to the (local Computer) name
    3. You should now see three folders (Application Pools, Web Sites, and Web Service Extensions)
    4. Click on the "Web Service Extensions" folder -> and on the right pane verify what web service extensions are allowed?

    Please replay with your findings so I can further help you with this issue.

    MA

    Wednesday, October 22, 2008 1:28 AM
  • Thanks for the reply MA,

    I ended up getting it working doing the following:

    Migrated the app using -
    %systemroot%\system32\inetsrv\APPCMD.EXE migrate config "Default Web Site/ReportServer"

    Also turned out the isapi handler mapping was pointing to the 64bit version and needed to point to the 32bit version ...

    FYI I'm using Vista 64bit.

    cheers
    David

    Wednesday, October 22, 2008 2:38 PM
  • Hi,

    I am trying to follow the example 

    http://www.dotnetheaven.com/UploadFile/ursbgiri/106012007065515AM/1.aspx

    and when I am trying to deploy

    I got this Error Message:

    A connection could not be made to the report server http://samsamaster:8080/Reports.

    Additional Information:

    The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version. (Microsoft.ReportingServices.Designer)


    SOLUTION:

    I did and follow the steps you told me but unfortunately It did work.

    I made changes the RSWebApplication.config

    <ReportServerUrl>http://samsamaster:8080/Reports</ReportServerUrl>
    and
    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>

    and recycle the Application Pool named "ReportServer"

    the above said url is the url of Report Manager.

    and my web server worked with port 8080 as on port I got SharePoint.

    I am stuck.


    Please any help is highly appreciated.

    Regards

    S R





    Monday, December 15, 2008 9:26 AM
  • Hi,

    I am getting this same Error

    • The attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version.
      • The request failed with HTTP status 404: Not Found.

        I have tried to change RSWebApplication.config
      • <ReportServerUrl>http://localhost/ReportServer$SQLExpress</ReportServerUrl>
      • ReportServerVirtualDirectory></ReportServerVirtualDirectory>
      • But Still it is not working. Please help me  to solve this one.   


      Regards,
      chitra.

    Thursday, August 20, 2009 9:47 AM
  • Hi,


    I have Sql server Express 2005. As per your Note What should be value in ReportServerUrl tag

    Which I need to use :

    <ReportServerUrl>http://localhost/Reports$Sqlexpress</ReportServerUrl>
    <ReportServerUrl>http://localhost/ReportServer$Sqlexpress</ReportServerUrl>
    <ReportServerUrl>http://localhost/Reports</ReportServerUrl>


    Right now, I tired all but nothing works. I get same error.

    Also I don't know what is REPORT PATH VALUE in report viewer control ? Like I created Reports Using SSRS 2005 and Published On Website,
    I can go on SSRS wevservice home page and run report like REPORT PROJECT1 / REPORT1

    But where are these stored and What is Report Path Value ?


    Also What should be value of Report Server URL In Report Viewer Control.
    Is it full path : http://localhost/Reports$Sqlexpress ?

    Please Help.


    Ami
    ami_sur@yahoo.com


    Wednesday, September 16, 2009 5:42 PM

  •  Error

     The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version.
     
    Home 
     


    Although saving the databse connection successded, the rport server cannot access the internal information abolut the deployment to determine whether the current configuration is valid for this edition. if you are ... bla bla bla...

    ReportServicesConfigUI.WMIProvider.WMIProviderException: The encrypted value for the "LogonCred" configuration setting cannot be decrypted. (rsFailedToDecryptConfigInformation)
       at ReportServicesConfigUI.WMIProvider.RSReportServerAdmin.ThrowOnError(ManagementBaseObject mo)
       at ReportServicesConfigUI.WMIProvider.RSReportServerAdmin.ListReportServersInDatabase(RSReportServerInfo[]& serverInfos)


    Shift the Ctrl in our hands and we will Alt the world.
    Thursday, September 24, 2009 9:03 PM
  • Hi there,

    http://localhost/ReportServer  try this

    let me know.
    khan
    Wednesday, October 21, 2009 8:25 PM
  • Hi, i got the same problem.

    I can easy access my reports from the IE (by ReportManager). My ReportViewer Controls are configured properly (serwer and virtual directory settings).
    - hostheaders added
    - rsreportserver.config checked
    - non of solutions above helped me.

    everything seems to be ok but it' still not working...

    frustrating,
    lost over 3 days to find solution :(

    plz somebody help
    Friday, November 20, 2009 10:53 AM
  • finally, i got it,
    it was so easy... to easy in my case.

    In the ReportViewer Control i typed wrong adress in the "ReportServerUrl" property
    it was:
    http://localhost/Reports_Sqlexpress
    and i changed it to:
    http://localhost/ReportServer_SqlExpress
    -it works now!

    also remember to type "/" before reports catalog in "ReportPath" property of ReportViewer Control

    if You are not shure what is your ReportServerUrl go to "Reporting Services Configuration Manager" (menu start>sql server>configuration tools), select "Web Service URL" from the left menu and at the bottom You will find "Report Server Web Service Url's" - this is your ReportServerUrl value.

    Friday, November 20, 2009 2:06 PM
  • Hi miloone,,, well in my case i am trying to configure x86 MS SQL 2005 server reporintg server on X64 Win server 2003 OS... and its giving me hard time.. many I remember one incendent where i tool MS support and the tech could not find anything that i was doing wrong .. he then requested to uninstall reporting service and reinstall ( saying that sometime its a courrput installation ) and that fixed my issue...

    so give it a shot .. you never know it that works out in your case.. i am still battling i really need some one give me step by step of configuring reporting service in such odd scenario.. where os is x64 and ms sql is x86...

    thanks..
    Shift the Ctrl in our hands and we will Alt the world.
    Friday, November 20, 2009 2:13 PM
  • I have successfully installed SSRS several times, but on my DEV server, I had to make a change to allow a network path coming in on another port. Since then everything has gone haywire. Right now, my ReportServer works (URL works and site displays folders, images, datasources, and report files.) The problem is with the Report Manager. The URL worked yesterday after some tweaking, but started failing again at the end of the day. Today it still doesn't work.

    I have everything working in RS Configuration (Green Check Marks).

    Custom tweak is a second IIS Site to handle the custom port configuration for network traffic. The default Virtual Directory is still there, unaltered. It was working, starting displaying errors, worked again yesterday, then quit again. Error is:
    ERROR
    The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version.
    HOME

    My RSWebApplication.config file has the following, which is the URL path to the IIS site for my Report Mangager. 
    <ReportServerUrl>http://192.168.2.2:8080</ReportServerUrl>
    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
    <ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel>
    

    I Changed to this and it was fixed:
    <ReportServerUrl>http://192.168.2.2/ReportServer</ReportServerUrl>
    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
    <ReportBuilderTrustLevel>FullTrust</ReportBuilderTrustLevel>
    

    Thanks.

    have another Dr. Pepper
    • Edited by Drew Coppock Tuesday, December 08, 2009 3:37 PM Found my problem
    Tuesday, December 08, 2009 3:29 PM
  • Hi - this worked like a charm, thanks very much.

     

    Wednesday, March 31, 2010 8:56 AM
  • You also have to be sure that you are using the right parameters:

     

     

    This works fine for me, different web server than the report server.

     

    ReportViewer1.ProcessingMode = Microsoft.Reporting.WebForms.ProcessingMode.Remote;

    ReportViewer1.ServerReport.ReportServerUrl = new Uri("http://yourServer/yourReportServer");  //Remember not use slash at the end 

    ReportViewer1.ServerReport.ReportPath = "/FaxReport";  //use the slash before the name of your report

     

     

    Regards,


    oskarcharles
    Tuesday, August 24, 2010 8:21 PM
  • After configuring this getting the fallowing message. Can anyone tell me why this is happening.

    Under Construction


    The site you are trying to view does not currently have a default page. It may be in the process of being upgraded and configured.

    Please try this site again later. If you still experience the problem, try contacting the Web site administrator.

     

    Saturday, January 29, 2011 7:57 AM
  • This is a serious problem and bug to go through this.  I have just tried 3 hours worth of modifications to this install: Windows 2008 64 bit, SQL 2005 with SP3 and I am still get this error.  Thanks for the first post though.  It was good start to troubleshooting, but it doesnt fix my problem.

    If anybody has any suggestions to fix this issue: "The attempt to connect to report server failed..."; please let me know.

     

    Thanks,

    RM

    Monday, February 07, 2011 7:15 PM
  • As most of us techie do, I finally had to reinstall everything and do some work under the hood (registry changes).  I believe that IIS 7 had become corrupt so I ended up cleaning the SSRS installs, the registry, and uninstalling the IIS 7 role in Windows 2008 64 bit.  Even when I reinstalled the role, I still had to delete old virtual websites and directories.  BE SURE TO CLEAN EVERYTHING ABOUT THE SSRS.

    Here's the link I used that helped.

    http://support.microsoft.com/kb/938245

    Share the knowledge... so the bleeding can stop!

    Wednesday, February 09, 2011 6:03 PM
  • I had exactly the same problem. It was the wrong ReportServerUrl.
    Wednesday, June 01, 2011 3:50 PM
  • I am getting this same error connecting to a SQL 2008 Report Server instance.  The ReportServerUrl works fine from a browser on the local machine, however the ReportViewer control issues this error.  The Report Server is file-based, so no IIS to check/configure.
    Thursday, September 15, 2011 8:39 PM
  • Hey

    Thanks a ton. struck there for the past 2 days.

    Saturday, April 21, 2012 1:59 PM
  • If you have VPN, please use that VPN IP to access the report sever remotely. It should work...

    Monday, June 18, 2012 4:49 PM
  • We found that when copying in a string from Word to notepad in the web.config file, the quotes held as smart quotes (thicker quote font type) and caused this error.  When typing in the quotes in notepad in the web.config it was fine.
    Tuesday, July 03, 2012 2:15 PM