none
SQL Server Agent not listed as cluster resource

    Question

  • Hello everyone, thanks for any help on this issue.  I have recently installed SQL 2008 R2 on a Server 2008 R2 machine cluster.  We ran the advanced cluster prep and completion.  I have SQL Server up and running properly and failing over between nodes.  In the failover cluster manager, when I select SQL Server, I do not have the SQL Server Agent listed under other resources.  When I try to start the Agent from the SQL Configuration Manager it fails with an event 103 and I've found several notes on this error but I am figuring the root issue is that there isn't a cluster resource for the Agent.

    Is it possible to create the resource for the Agent? I have run a repair and I have tried to use add a resource, generic service, sql agent but it fails when I attempt to bring it online.

    Thanks again for any help on this.

    Mike

    Monday, August 16, 2010 11:17 PM

Answers

  • The SQL agent is missing because the setup never finished successfully.

    At this point you should 

    1 - Add the SQL agent 'resource type'.

    cluster restype "SQL Server Agent" /create /DLL:sqagtres.dll

    2- Add the SQL agent resource ..

    .       In the Failover Cluster Management use Add Resource to add the SQL Server Agent resource.
    Name the resource as “SQL Server Agent”, as this is case sensitive unless you are on CU3 or above for SQL Server 2008 RTM.

    a.
           Right-click on the SQL Agent resource and go to Properties and fill in values for the two parameters.
    b.
          Specify the Virtual Server name of the SQL instance.
    c.       Specify the Instance name.
    d.      Add the SQL Server Resource as a dependency for the newly created SQL Server Agent resource

    3.       Open Registry Editor and browse to the following location.

    Default Instance
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10.MSSQLSERVER\ConfigurationState

    Named Instance
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft Microsoft SQL Server\MSSQL10.INSTNAME\ConfigurationState

    Make sure that the values for all the keys present are 1. In case it is not, change it to 1.
    This will set the configuration state for all SQL features to 1, meaning the feature is installed and configured. A value greater than 1 indicates either an install failure or configuration failure.

    4- perform a repair of the instance.

    How to: Repair a Failed SQL Server 2008 Installation
    http://msdn.microsoft.com/en-us/library/cc646006.aspx

    just fyi there is a KB coming for this.

    thx-vijay

    Thursday, August 19, 2010 6:56 AM

All replies

  • Try to add custom service to cluster resource and choose SQL Agent.
    Tuesday, August 17, 2010 7:19 AM
  • Please post the exact error message you are receiving on the SQL Server Errorlog / Agent Log / Event viewer.

    SQL Server Agent will be part of the SQL Server installation and it will be by default would appear on the Cluster Manager.

     


    Sivaprasad S http://sivasql.blogspot.com Please click the Mark as Answer button if a post solves your problem!
    Tuesday, August 17, 2010 10:14 AM
  • The SQL agent is missing because the setup never finished successfully.

    At this point you should 

    1 - Add the SQL agent 'resource type'.

    cluster restype "SQL Server Agent" /create /DLL:sqagtres.dll

    2- Add the SQL agent resource ..

    .       In the Failover Cluster Management use Add Resource to add the SQL Server Agent resource.
    Name the resource as “SQL Server Agent”, as this is case sensitive unless you are on CU3 or above for SQL Server 2008 RTM.

    a.
           Right-click on the SQL Agent resource and go to Properties and fill in values for the two parameters.
    b.
          Specify the Virtual Server name of the SQL instance.
    c.       Specify the Instance name.
    d.      Add the SQL Server Resource as a dependency for the newly created SQL Server Agent resource

    3.       Open Registry Editor and browse to the following location.

    Default Instance
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10.MSSQLSERVER\ConfigurationState

    Named Instance
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft Microsoft SQL Server\MSSQL10.INSTNAME\ConfigurationState

    Make sure that the values for all the keys present are 1. In case it is not, change it to 1.
    This will set the configuration state for all SQL features to 1, meaning the feature is installed and configured. A value greater than 1 indicates either an install failure or configuration failure.

    4- perform a repair of the instance.

    How to: Repair a Failed SQL Server 2008 Installation
    http://msdn.microsoft.com/en-us/library/cc646006.aspx

    just fyi there is a KB coming for this.

    thx-vijay

    Thursday, August 19, 2010 6:56 AM
  • and Yes one last thing .. change the dependencies if any and delete the generic resource that you created for sql agent.
    Thursday, August 19, 2010 6:58 AM
  • Perfect, thanks much for the help everyone.
    Thursday, August 19, 2010 8:31 PM
  • I am having the same issue and have followed the same instructions but was never as lucky as you

    I am running SQL Server Agent as a generic service not as a SQL Server Agent cluster resource service

     

    Any advise

    Tuesday, August 31, 2010 9:51 PM
  • The above solution will work.

    First delete the generic resource that you have created and then follow the solution provided above.

    thx-vijay

     

    Sunday, September 05, 2010 9:09 AM
  • When trying to run:

    cluster restype "SQL Server Agent" /create /DLL:sqagtres.dll

    I'm getting the following error message: Cannot create a file when that file already exists. I've ensured this resource does not exist in my default instance cluster group.

    Any help would be appreciated!

    Saturday, October 23, 2010 5:30 PM
  • There are two things

    1. ResourceType

    2. Resource

    The command above creates a resourcetype for SQL agent. Confirm it by running below command

    Cluster Restype

     


    Thanks - Vijay Sirohi
    Saturday, October 23, 2010 8:14 PM
  • This seems to have worked for me as well. When can we expect the KB for this? 
    Tuesday, December 28, 2010 6:31 AM
  • thank you so much!  this worked wonderfully. 
    Tuesday, January 11, 2011 12:02 AM
  • The KB was published some time back -- http://support.microsoft.com/kb/2102055

     


    Thanks - Vijay Sirohi
    Tuesday, January 18, 2011 6:08 PM
  • The KB was published some time back -- http://support.microsoft.com/kb/2102055

     


    Thanks - Vijay Sirohi

    Hi Vijay,

     

    Thank you so much! this information helped me to finish my cluster configuration!

    Monday, February 07, 2011 3:16 AM
  • The solution of adding the resource type, then adding the resource makes sense, but I get "Access Denid" when I try to run the "cluster restype" command, even with no parameters.

    I'm a local system admin...weird.

    Friday, February 11, 2011 6:59 PM
  • When launching CMD - choose 'Run as Admin'

    that will get you working.

     


    Thanks - Vijay Sirohi
    Friday, February 11, 2011 8:27 PM
  • In my case this happened because I forgot to put the "FAILOVERCLUSTERIPADDRESSES" in my configuration.ini file. After I added this parameter AND removed the DNS record from the dns server, I was able to install all resources.
    Warjte31
    Friday, June 24, 2011 8:36 AM
  • Thanks for posting this, it resoved an issue I was having with sql agent on my 2008 cluster.
    Saturday, June 02, 2012 9:29 PM