none
trial period expired error message

    Question

  • Dear all,

    I hope you can help.

    A colleague installed a trial version of SQL Server 2008 on a production server.

    He then bought a standard license of SQL Server and re-installed on top of the trial (the company which sold the license to him said that the installer was pre-pidded and they could not provide a serial number for upgrading).

    180 days passed and the server still work, however integration services and management studio give us a trial evaluation period expired error message.

    The server is a production server and we would rather not reboot it or doing anything drastic to get the trimmings back up and running properly...

    Any help is appreciated. 

    Thanks in advance.

    Leo

    • Moved by Eric WisdahlModerator Tuesday, February 16, 2010 3:43 PM This appears to be an upgrade question (From:SQL Server Integration Services)
    Tuesday, February 16, 2010 2:26 PM

Answers

  • You should have selected the "Edition Upgrade" option in the Maintenance page of the Installation Center app. Anyhow, I think you would be able to do that now, wnd this sould only ask you for the PID and make what is already installed the edition according to the typed in PID. You probably want to ractice this on a test machine first, of course.
    Tibor Karaszi, SQL Server MVP | http://www.karaszi.com/sqlserver/default.asp | http://sqlblog.com/blogs/tibor_karaszi
    • Proposed as answer by VidhyaSagarModerator Wednesday, February 17, 2010 12:23 AM
    • Unproposed as answer by Lenny S Wednesday, February 17, 2010 8:32 AM
    • Marked as answer by Lenny S Wednesday, February 17, 2010 2:49 PM
    Tuesday, February 16, 2010 6:44 PM
  • Do you have the installation media? If so, run setup on some other machine, and you will see the pre-pid while running setup and methink that you should be able to write it down and use on your production instance.
    Tibor Karaszi, SQL Server MVP | http://www.karaszi.com/sqlserver/default.asp | http://sqlblog.com/blogs/tibor_karaszi
    • Marked as answer by Lenny S Wednesday, February 17, 2010 2:49 PM
    Wednesday, February 17, 2010 9:21 AM

All replies

  • More than likely when you re-installed on top of the trial you only installed the database engine.  You will probably now need to re-install the other services which you are using to get a valid key in place for these services.

    Hope this helps.

    Please mark answered posts. Thanks for your time.
    Tuesday, February 16, 2010 2:56 PM
    Moderator
  • I think you are on the right track but... Unfortunately that is not a possibility. See image below:

    Tuesday, February 16, 2010 3:22 PM
  • I'm going to go ahead and move this thread to the upgrade forum.  I think you will probably get more help there.
    Please mark answered posts. Thanks for your time.
    Tuesday, February 16, 2010 3:42 PM
    Moderator
  • Thanks Eric.
    Tuesday, February 16, 2010 3:54 PM
  • You should have selected the "Edition Upgrade" option in the Maintenance page of the Installation Center app. Anyhow, I think you would be able to do that now, wnd this sould only ask you for the PID and make what is already installed the edition according to the typed in PID. You probably want to ractice this on a test machine first, of course.
    Tibor Karaszi, SQL Server MVP | http://www.karaszi.com/sqlserver/default.asp | http://sqlblog.com/blogs/tibor_karaszi
    • Proposed as answer by VidhyaSagarModerator Wednesday, February 17, 2010 12:23 AM
    • Unproposed as answer by Lenny S Wednesday, February 17, 2010 8:32 AM
    • Marked as answer by Lenny S Wednesday, February 17, 2010 2:49 PM
    Tuesday, February 16, 2010 6:44 PM
  • Hi TiborK,

    That would definitely work but we haven't got the PID!

    (the company which sold the license to him said that the installer was pre-pidded and they could not provide a serial number for upgrading).

    Is there a way to retrieve the PID from an installed instance?

    Leo
    Wednesday, February 17, 2010 8:32 AM
  • Do you have the installation media? If so, run setup on some other machine, and you will see the pre-pid while running setup and methink that you should be able to write it down and use on your production instance.
    Tibor Karaszi, SQL Server MVP | http://www.karaszi.com/sqlserver/default.asp | http://sqlblog.com/blogs/tibor_karaszi
    • Marked as answer by Lenny S Wednesday, February 17, 2010 2:49 PM
    Wednesday, February 17, 2010 9:21 AM
  • That's a great idea! I will give it a go and let you know how it goes. Thanks man!
    Wednesday, February 17, 2010 9:31 AM
  • Hei TiborK,

    Unfortunately this did not work... Clever thinking though.

    I opened a case with Microsoft, now. Hopefully they will be able to help.

    Please do get in touch if you can think of anything else.

    Kind Regards,

    Leo
    Wednesday, February 17, 2010 10:41 AM
  • <<Unfortunately this did not work>>

    Sorry to hear that... Yes, a case with MS would be my next step too...
    Tibor Karaszi, SQL Server MVP | http://www.karaszi.com/sqlserver/default.asp | http://sqlblog.com/blogs/tibor_karaszi
    Wednesday, February 17, 2010 12:09 PM
  • Hi TiborK,

    Thanks for your help. 

    Using the process that you described did work in the end... 

    The installer that we found on the server was not the pre-pidded one... :-(

    We ended up re-downloading the installer and upgrading as you explained.

    However this (upgrading an instance from a trial to a full version does not upgrade the shared features) is most definitely a malfunction with the installer (part of which is already described in a KB) and I am confident that Microsoft will eventually provide a workaround/fix the issue.

    Thanks again.

    BTW: I did open a case with Microsoft and I was very lucky because I was assisted by a brilliant man called Nickson. Thanks for all your help Nickson.  

    Leo
    Wednesday, February 17, 2010 3:15 PM
  • Thanks for the update, Leo!
    Tibor Karaszi, SQL Server MVP | http://www.karaszi.com/sqlserver/default.asp | http://sqlblog.com/blogs/tibor_karaszi
    Thursday, February 18, 2010 9:43 AM