none
Missing System Administrator Account. To Cont.......

    Question

  • I am in the process of insalling Sql Server Dev Edition on a Vista x64 machine. It is a Dell R5400 W/S with 8 cores. I am stumbled by this error in the GUI.  The error message which I cannot read in its entirety blocks my further progress. I cannot click NEXT button because of it. I set up a Mixed Mode. It opened two textBoxes for PWs. I entered a strong PW which is my adm sign in PW on the machine. It does not accept it. i am still blocked. I tried Windows Authentication--the same thing. The error message window, a narrow white stip does not go away. I checked the Local Users and Groups. My sign in name is in Administrators group. What else can I do to break the stalemate?

    Thanks.

    AlexB
    Thursday, February 05, 2009 6:19 PM

Answers

  • The next time that you have this you can have the install do it for you.  If you try installing with the install screen maximized, you should see under account provisioning (add the current user) or add a different user.  I did notice that with some screen resolutions that it may not appear.   I had mine set to 1400 x 1050 (lenovo X61 tablet.)    Try either maximizing or going with 1024 x 768 resolution during the install.
    Friday, April 10, 2009 9:24 PM
  •  OK, I completely and I should say elegantly resolved it with full understanding as to why that happened. First of all adding a Group to the Groups in Vista Local Users and Groups GUI did not help, or perhaps did not seem to help, I don't know. My next step was to Add a User to the Users pane in Local Users and Groups. The user Full Name was SQL Server System Administrator and the Name: Sql Server Adm since there was not enough space to put anything longer than that. Then I think I added this name to the Group with the same Full Name I defined yesterday. That group also had my name as Adm in it as a user. That made it a full circle almost. Still it did not work. Then this morning after a reboot or two I noticed that a sign in thumbnail appears after the Vista Globe next to the old thumbnail with my sign-in name. The new sign in name is SQL Server System Administrator. Still one more action was required. I had to click Add on that page where I got stuck installing Sql Server and upon getting an entry form to enter SQL Server System Administrator as a user. There are options to enter more names but I do not need that. After that the error message simply disappeared. A happy ending.
    AlexB
    Friday, February 06, 2009 3:57 PM

All replies

  •  Guys, it's been almost 3 hours since I posted this. I will have to get back to the install in about 2-3 hours. I want it to be resolved ASAP. Could anybody help?
    AlexB
    Thursday, February 05, 2009 9:05 PM
  •  It seems I've almost figured it out. I should have been more attentive and expanded the small GUI form. Then all error messages become easily viewed. In order to break that stalemate I have to set up an Administrator account for Sql Server in Local Users and Groups. It is Vista. I do it by invoking lusrmgr.msc API. So far I added a group SQL Server system administrator to the Groups. So far no success but I am sure I will break in soon. I've done it before a number of times.
    AlexB
    Friday, February 06, 2009 1:52 AM
  •  OK, I completely and I should say elegantly resolved it with full understanding as to why that happened. First of all adding a Group to the Groups in Vista Local Users and Groups GUI did not help, or perhaps did not seem to help, I don't know. My next step was to Add a User to the Users pane in Local Users and Groups. The user Full Name was SQL Server System Administrator and the Name: Sql Server Adm since there was not enough space to put anything longer than that. Then I think I added this name to the Group with the same Full Name I defined yesterday. That group also had my name as Adm in it as a user. That made it a full circle almost. Still it did not work. Then this morning after a reboot or two I noticed that a sign in thumbnail appears after the Vista Globe next to the old thumbnail with my sign-in name. The new sign in name is SQL Server System Administrator. Still one more action was required. I had to click Add on that page where I got stuck installing Sql Server and upon getting an entry form to enter SQL Server System Administrator as a user. There are options to enter more names but I do not need that. After that the error message simply disappeared. A happy ending.
    AlexB
    Friday, February 06, 2009 3:57 PM
  • The next time that you have this you can have the install do it for you.  If you try installing with the install screen maximized, you should see under account provisioning (add the current user) or add a different user.  I did notice that with some screen resolutions that it may not appear.   I had mine set to 1400 x 1050 (lenovo X61 tablet.)    Try either maximizing or going with 1024 x 768 resolution during the install.
    Friday, April 10, 2009 9:24 PM
  • Thank you, Jim, It may come in handy. I just lost my OS on one of my other machines and will most likely have to reinstall it from scratch with all resulting consequences. My screen resolution is 1600x1200.
    AlexB
    Saturday, April 11, 2009 9:43 PM
  • Thank you.  Your suggestion solved my problem.
    Tuesday, September 29, 2009 11:01 PM