none
SQL 2008 Report Not Showing in Google Chrome or Safari

    Question

  • Hello All,

     

    We have several SQL 2008 Reports that are loading fine in our Development and Test Environment, but are not showing up in Production using Google Chrome 13 Browser or Apple Safari 5.1 (they show up using IE 9, FireFox 6.0). Does anyone have any idea what the problem may be or if there is a patch available for this?

     

    Thanks,

    Pedram

    Sunday, August 21, 2011 2:39 PM

All replies

  • Are you using Report Manager (Native mode)? If so, Report Manager supports IE only: http://msdn.microsoft.com/en-us/library/ms156511(v=SQL.105).aspx. What you describe sounds like a known issue when using WebKit browsers (Safari and Chrome) with Report Manager.


    Program Manager, SQL Server Reporting Services
    Monday, August 22, 2011 2:50 AM
  • But it is working on two of my servers just fine. All I am doing is to redirect users to view the reports, and it works fine in Dev and Test, just not the Production. If it was a matter of it not being supported it shouldn't have worked in the other two environments either. Makes no sense!

    Has anyone come across this?


    Monday, August 22, 2011 3:02 AM
  • Do all three servers have the same build of SSRS?

    Also, note that our lack of official support for Report Manager on non-IE browsers doesn't necessarily mean that none of it ever works at all.


    Program Manager, SQL Server Reporting Services
    Tuesday, August 23, 2011 3:34 AM
  • Yes, all  3 of the servers have identical build of SSRS and all other software on them, which makes this even more confusing.
    Tuesday, August 23, 2011 4:53 AM
  • But it is working on two of my servers just fine. All I am doing is to redirect users to view the reports, and it works fine in Dev and Test, just not the Production.

    Hi psoheil,

    I was confused by the paragraph above. As Riccardo Muti mentioned, not all report functionality is supported by all browsers. So I want to know what is the browser in your Dev and Test environments? Did you try to open the report in both Safari and Chrome browsers in Dev and Test environments? If it shows up correctly, I might need more information for further assistance.

    Could you please elaborate the issue with some error messages?

    Thanks,
    Lola

    • Proposed as answer by Lola WangModerator Tuesday, August 23, 2011 8:33 AM
    • Unproposed as answer by psoheil Tuesday, August 23, 2011 2:35 PM
    Tuesday, August 23, 2011 6:05 AM
    Moderator
  • But it is working on two of my servers just fine. All I am doing is to redirect users to view the reports, and it works fine in Dev and Test, just not the Production.

    Hi psoheil,

    I was confused by the paragraph above. As Riccardo Muti mentioned, not all report functionality is supported by all browsers. So I want to know what is the browser in your Dev and Test environments? Did you try to open the report in both Safari and Chrome browsers in Dev and Test environments? If it shows up correctly, I might need more information for further assistance.

    Could you please elaborate the issue with some error messages?

    Thanks,
    Lola

    Hello Lola,

    I tried it with the following browsers in dev and test, and it worked fine:

    • IE 8 and 9
    • FireFox 4, 5 and 6
    • Chrome 13
    • Safari 5.1

    In production Safari 5.1 and Chrome 13 didn't work. There is no error message. The screen just comes up blank, and I don't see any errors in the Windows Application Log. 

    Thanks,

    Pedram

     

    Tuesday, August 23, 2011 2:35 PM
  • +1, exactly same problem here.

    Another known problem: using IE (required ...), when you have more than 1000 lines, the display is horribly slow (about .... 5 minutes !)

     

    If i hide the grid, and use only the "export" button (excel format), the export is done in 3 seconds.

     

    Profiling IE using the integrated profiler (IE9) gives this result:

    width and clientWidth took about 25 seconds each ! ...

     

    Function / Inclusive Time / Exclusive Time / URL

    width 3 343 25 623,47 25 623,47

    clientWidth 679 22 535,29 22 535,29

    offsetHeight 676 8 398,48 8 398,48

    length 18 090 399,02 399,02

    appendChild 4 041 143,01 143,01

    removeChild 2 658 132,01 132,01

    innerHTML 15 117,01 117,01

    ShowFixedTablixHeaders 2 8 552,49 63,00 https://bi.../Reports/Reserved.ReportViewerWebControl.axd?OpType=Resource&Version=10.50.1600.1&Name=ViewerScript 7 844

    height 3 982 48,00 48,00

    Microsoft_ReportingServices_HTMLRenderer_ScaleImageConsolidation 2 48 935,80 48,00 https://bi.../Reports/Reserved.ReportViewerWebControl.axd?OpType=Resource&Version=10.50.1600.1&Name=ViewerScript 8 161

    top 1 997 46,00 46,00

    cssText 2 654 45,00 45,00

    Microsoft_ReportingServices_HTMLRenderer_PxPerInch 2 648 236,01 30,00 https://bi..../Reports/Reserved.ReportViewerWebControl.axd?OpType=Resource&Version=10.50.1600.1&Name=ViewerScript 7 144

    removeAttribute 2 701 26,00 26,00

    getAttribute 20 934 24,00 24,00

    offsetLeft 42 23,00 23,00

    style 13 201 19,00 19,00

    cloneNode 1 377 18,00 18,00

    getElementsByTagName 685 17,00 17,00

    Thursday, October 20, 2011 10:47 AM