none
The owner () of job <Job Name> does not have server access.

    Question

  • Up till now the jobs have been running without fail for months after the upgrade to SQL 2005.
    For some reason the jobs started to fail with the error:
    The owner () of job <Job Name> does not have server access.

    The user is a domain admin with the ability to control every sing aspect of SQL.
    I then changed the owner and now the jobs are running again.

    I am however afraid it will happen again since I am still clueless as to what could have caused the problem.

    Any help would be greatly appreciated.
    RoviWil

     

    Thursday, March 30, 2006 8:22 AM

Answers

  • I had the same problem, also caused by a power outage. I found that you do not have to reboot the server - for me, just restarting SQL Server Agent worked.

     

    Thanks for putting me on the right track!

    Tuesday, August 07, 2007 8:42 AM
  • restsarting sql server agent did for it for me. Also set you username for the job to be non windows domain ie..sa or someother internal username to sql server that doesnt require a connection to active directory
    Saturday, May 03, 2008 8:56 PM
  • Found the problem: we had a power outage a number of days ago.

    Found buried in my voicemail....

    reboot the server and all is well. 

    DNS server didn't like how we ignored her. Next time I will be nice.

    Thursday, April 26, 2007 2:43 AM

All replies

  • I too am having difficulty finding out why

    Code Snippet
    The owner () of job ____ does not have server access

     

    The owner is a member of [the chosen] few who have sysadmin rights.

    The individual logon is not declared on the server, but group permissions = membership to sysadmin.

    SQL Server 2005, 2003 server.

     

    Monday, April 23, 2007 4:44 PM
  • Hi,

     

    In principle this error says that SqlAgent was unable to verify that the login has sysadmin privileges. Since the rights came through group membership it's possible that some sort of network failure could have led to this. Is the failure reproducing consistently for you? If you try to use a different login that exists on the server do you still have problems?

     

    Regards,

    Ciprian Gerea

    Monday, April 23, 2007 10:45 PM
  • Wednesday, April 25, 2007 8:30 AM
    Moderator
  • Found the problem: we had a power outage a number of days ago.

    Found buried in my voicemail....

    reboot the server and all is well. 

    DNS server didn't like how we ignored her. Next time I will be nice.

    Thursday, April 26, 2007 2:43 AM
  • I had the same problem, also caused by a power outage. I found that you do not have to reboot the server - for me, just restarting SQL Server Agent worked.

     

    Thanks for putting me on the right track!

    Tuesday, August 07, 2007 8:42 AM
  • http://support.microsoft.com/kb/825042

     

    This KBA is great, for SQL 2000.

     

    But, I am having the same EXACT issue with SQL 2005 SP2.  This happens every time that I reboot the server.  A specific job, owned by a Domain\User, who access to the server by way of a Domain\GlobalGroup.  I can exec xp_logininfo for his Domain\User and it returns the correct information, including the permission path that shows the Domain\GlobalGroup.  Yet the job still fails!  The only workaround we have is to assign the job a different owner, and then assign back to him.

     

    Why can't jobs be owned by Domain\GlobalGroups?  I can an error that says it will not accept the global group, but why not?  If I have a TEAM of DBA's that are in the same global group, they should ALL have access to the jobs, and I (as SA)should not have to reassign them to specific DBA's.

     

     

    Wednesday, October 24, 2007 9:04 PM
  • We are having the same exact problem in the environment that I support (e.g. SQL Server 2005 x64 SP2 build 3054). Where a Windows login name is a member of a Windows group and there is only a corresponding SQL Server Windows Group login that has sysadmin access. Jobs created by the setup of Replication or the Database Maintenance Wizard will fail until you change the job owner to sa. I'm surprised that this has not been reported to Microsoft yet?

     

    Error Description:

    Message
    The job failed.  The owner (MyDomain\WinLoginName) of job MP-Full Adhoc Database Backup.Subplan_1 does not have server access.

    Thursday, February 14, 2008 3:23 PM
  • restsarting sql server agent did for it for me. Also set you username for the job to be non windows domain ie..sa or someother internal username to sql server that doesnt require a connection to active directory
    Saturday, May 03, 2008 8:56 PM
  • Recycling the SQLAgent worked for me as well.  Also switched the user who was running the job to another, ran the job successfully, then switched back.  Did that on one job, cycled the agent service to get the others working.  All jobs owned by the one owner failed, while others owned by a different domain user succeeded.  Strange.
    Wednesday, June 24, 2009 7:17 PM
  • Restarting SQL Server Agent- statrt jobs again...
    :)
    Works like a charm.
    Thursday, August 20, 2009 12:29 PM
  • :)))
    Sunday, August 30, 2009 6:38 PM
  • You will have remove the Job Owner Alias from Administrators group to overcome this issue
    Thursday, October 22, 2009 1:42 PM
  • restarting the SQL Server Agent seemed to work for us.
    I think it can be resolved completely if you set a dependancy on the netlogon service so that the SQL Agent Service waits for netlogon before starting up.
    Thursday, January 28, 2010 1:41 PM
  • The same problem to me, was solved just restarting the SQL Server Agent.
    Monday, March 08, 2010 7:48 AM
  • Restarting SQL Server Agent is also fine for me :))
    Friday, June 04, 2010 12:02 PM
  • Working for me tooo :)))))
    Monday, July 19, 2010 11:15 AM
  • Thumb rule is...after creating any sql agent job always change job owner to [sa], u'll be happy forever.
    Best Regards, Abhishek DBA(MCTS)
    Wednesday, December 08, 2010 3:00 PM
  • Note: by just restarting the SQL Server Agent you won't prevent the issue from happening again. See answer from G-Unit for permanent solution.
    Tuesday, January 18, 2011 3:09 PM
  • I had same issue in sql server 2008 EE sp1. I changed job owner from domain user (user part of dba group) to SA. it worked for me. I didn't restart sql agent.when looked at sql error log it shows server rebooted and i am not able to see "SQL Trace was stopped due to server shutdown. Trace ID = '1'. This is an informational message only; no user action is required." in previous error log than the current error log. from this what i understand is server rebooted with some power outage or some unexpected happened.

     

    i will update on why server rebooted.

     

     

    Thanks,

    Brahma

     


    ------------------------ Brahma http://brahmarao.tech.officelive.com http://nani1211.info/sql
    Sunday, August 07, 2011 12:56 PM
  • The job failed. The owner of job does not have server access, means - the owner of the Job does not have the windows authentication account enabled.

    Do the below test you will find out the problem.

    Login as Domain user account into a machine where you can access the SQL Server - > Open SSMS -> Select Windows authentication username will default to \Domain\Username

    Click on Connect button, it should connect if not connecting then the user is not added properly to the Logins. First add the user to the login

    Some times using windows 7 and Server 2008 you need to run the SSMS using Run as Administrator also to solve this problem

    Thursday, February 21, 2013 9:45 AM
  • That's interesting. I just saw this happen in SQL 2012 R2. I'm part of a group that is in the sysadmin server role. Yet, a job that I own couldn't run until I added myself personally to sysadmin. Though now it seems to run either way. Maybe a one-off thing on a new server.

    Ken

    Wednesday, November 13, 2013 11:18 PM