none
The datasource , 'db name', contains an ImpersonationMode that that is not supported for processing operations.

    Question

  • I get the below error when i try to process my cubes:

    The datasource , 'local  - SRDB', contains an ImpersonationMode that that is not supported for processing operations.

     

    I have tried all 4 impersonation modes, but the same error comes from all. i created a new connection , and when i click "test" it says test successful, but the new connection throws the same error. anyone have any ideas?

    Friday, November 17, 2006 4:39 PM

All replies

  • What type of data source are you using?  As you probably know, creating and testing a data source within BIDS is not quite the same as setting the impersonation mode for the data source.  The credentials specified by the impersonation mode are only used when the SSAS engine needs to connect to the data source (to process things, for example).  Within BIDS, the designers use whatever connection credentials are specified when the data source is created (which is what the Test Connection button tests).

    Dave Fackler

    Saturday, November 18, 2006 5:45 AM
  • Is your data source on another server?

    If so, your problem can be related to the account that you use for the SSAS2005 service. Use the same domain account for access rights to the data source and that you are using for the SSAS2005 service.

    HTH

    Thomas Ivarsson

    Saturday, November 18, 2006 11:17 AM
  • im testing it on my own machine. the database its connecting to is on the localhost. the account that SSAS is running under has been granted full access to the database in question. I have tested my  connection and the test succeeds, yet still get the same error when processing.
    Monday, November 20, 2006 8:56 AM
  • I have tried the following :

    My MSAS 2005 service runs on machineA under a local admin account '.\sql05svc'. I have recreated the same account on machine b (which hosts the database that I want to create the cube for ) and added it to the Admisnitrators group. The cube gets processed just fine now.

     

    Hope that helps

    ~R

     

     

    Thursday, April 12, 2007 9:47 PM
  • the problem being desicribed included both the analysis server and sql server funning on the same local box . If i can view tables through the datas ource view, i would think i can process dimensions based on those tables.
    Monday, May 21, 2007 9:59 AM
  • Perhaps you have already solved your problem. If don't, try these steps:
    1. Create a role in the database you want the cubes to get processed
    2. Assign this role permission to process database
    3. Add  a valid domain\username and password to this role
    4. Set the previous domain\username and password for the ImpernationMode
    • Proposed as answer by LUDANFENG Saturday, October 12, 2013 7:41 AM
    Friday, June 08, 2007 2:40 PM
  • Hi Winstonsmith,

     

    I know this you encountered this issue about 2 years ago however, were you ever able to come to a resolve with it?

     

    The datasource , 'dbname', contains an ImpersonationMode that that is not supported for processing operations."

     

    regards,

    Joe

     

    Thursday, May 22, 2008 1:17 AM
  • Winstonsmith may have resolved it, but I am having this same exact error.  Any advice would definitely be appreciated.

    Jason

     

     

    Wednesday, July 09, 2008 2:09 PM
  • Hi,

     

    I used just "Default" and it started working for me......

     

    Kashif Zia

     

     

    • Proposed as answer by longhorndkr Thursday, January 17, 2013 9:43 PM
    Tuesday, November 25, 2008 12:50 AM
  • Hi Joe, I was having the same problem on SSAS 2008 in BIDS. So I thought I'd better sort it out on SQL Management Studio (SSMS) 1st.
    In SSMS, expand your Database. In the Properties of the "Data Sources" in the OLAP Cube that pointed to my SQL Server Relational Table (also SQL 2008 - all this is on a local machine) you first setup the Connection String. I used the SQL Server Native Client 10.0, pointed to the correct database on SQL Server and hit Test Connection. As has been pointed out in this discussion, it returns OK. But that doesnt mean you can process a Dimension or the Cube. The connection string uses Integrated Security (Windows Authentication radio button is on) so it will use domain\myaccount for me. Clicking OK works because I know I have access to the database using this connection string. But processing cubes gives me the error as outlined in this discussion.

    I found that I had to click Impersonation Info, under the Security Settings of the Data Source Properties. You'll get the elipses (...) that take you to the Impersonation Information dialog.
    None of the following worked for me:
    * Use the Service Account
    * Use the Credentials of the Current User
    * Inherit

    So I used a specific username and password. I log in to my local machine under a domain accont domain\myaccount and it was a bit odd entering this again into the  User Name field with my password. After clicking OK, you return to the Data Source Properties dialog and the Impersonation Info field now says ImpersonateAccount.

    Make sure also you have defined a Role for your Cube. When you edit the Role and look under Membership, I made sure domain\myaccount appeared, and under the General tab, that I had full control (Administrator) permission.

    I tried processing one small dimension first - it worked, so I then did the entire Cube with all of its dimensions, this also now worked. The error went away.

    If using SQL 2005 it will work the same way. I hope you have already fixed this but thought I'd pass on my experience with this error.
    Regards
    Ertan Sertcan

    Saturday, January 17, 2009 12:20 PM
  • thx ..it worked and allowing me to process (if i am doing it at database level..let say i am going directly to cube database and changing the setting).but still processing is not happening at the BI studio level .
    how will we change the ImpersonateAccount at BIStudio level.

    regards,
    Gaur

    Saturday, July 18, 2009 10:21 AM
  • I went under "Impersonation Information", hit inherit and it worked for me.
    • Proposed as answer by peterxw Tuesday, January 17, 2012 1:42 PM
    Sunday, July 26, 2009 4:02 AM
  • Thanks MikeChicago - in the window that opens when you double-click your datasource, chosing Inherit checkbox in the "Impersonation Information" tab and Deploy works now without this error:
      The datasource , 'db name', contains an ImpersonationMode that that is not supported for processing operations.

    Friday, November 13, 2009 6:29 PM
  • hi where do i actually define the role for my cube? where to edit it? please help
    Friday, June 25, 2010 9:25 AM
  • i left the sql server instance name as blank... it works now...

    tools-->options-->database tools-->data connections-->sql server instance name...

    then check the default option under impersonation tab

    Monday, June 28, 2010 6:13 AM
  • Thomas, thank you, this issue is 100% related to account being used

     

    Thanks for saving me a ton of time!

     

    Gary

    Friday, September 24, 2010 10:11 AM
  • Thanks Mike Chicago using 2008 and that worked for me.
    Thursday, October 06, 2011 6:47 PM
  • This worked for me in BIDS 2008 with AdventureWorks DW 2008 R2. I was working through the tutorial, as I am new to SSAS. I used my own account, which is an administrator and was provisioned as an admin on SSAS when I installed the instance.

    Lisa Morgan

    Tuesday, February 28, 2012 2:08 AM
  • Hi,

    double-click on data source, Select Inherit check box in the "Impersonation Information" tab and Deploy. Please refer the attached image.


    Junior System Support Engineer i-Context Content Convergence (Pvt) Ltd

    Thursday, August 23, 2012 8:29 AM
  • Hi Joe, I was having the same problem on SSAS 2008 in BIDS. So I thought I'd better sort it out on SQL Management Studio (SSMS) 1st.
    In SSMS, expand your Database. In the Properties of the "Data Sources" in the OLAP Cube that pointed to my SQL Server Relational Table (also SQL 2008 - all this is on a local machine) you first setup the Connection String. I used the SQL Server Native Client 10.0, pointed to the correct database on SQL Server and hit Test Connection. As has been pointed out in this discussion, it returns OK. But that doesnt mean you can process a Dimension or the Cube. The connection string uses Integrated Security (Windows Authentication radio button is on) so it will use domain\myaccount for me. Clicking OK works because I know I have access to the database using this connection string. But processing cubes gives me the error as outlined in this discussion.

    I found that I had to click Impersonation Info, under the Security Settings of the Data Source Properties. You'll get the elipses (...) that take you to the Impersonation Information dialog.
    None of the following worked for me:
    * Use the Service Account
    * Use the Credentials of the Current User
    * Inherit

    So I used a specific username and password. I log in to my local machine under a domain accont domain\myaccount and it was a bit odd entering this again into the  User Name field with my password. After clicking OK, you return to the Data Source Properties dialog and the Impersonation Info field now says ImpersonateAccount.

    Make sure also you have defined a Role for your Cube. When you edit the Role and look under Membership, I made sure domain\myaccount appeared, and under the General tab, that I had full control (Administrator) permission.

    I tried processing one small dimension first - it worked, so I then did the entire Cube with all of its dimensions, this also now worked. The error went away.

    If using SQL 2005 it will work the same way. I hope you have already fixed this but thought I'd pass on my experience with this error.
    Regards
    Ertan Sertcan

    HI Ertan,

    thanks for the post it really helped.

    One needs to be careful that you enter  credentials of the  current user expllicityly.

    I was on a domain. I  entered domain/username and password and it worked like a charm.

    Regards

    Vinod

    Saturday, December 29, 2012 5:19 PM
  • I second what Kashif said above and what William posted here--which worked for me:

    http://www.sqlservercentral.com/Forums/Topic324311-17-2.aspx#bm1126619

    If everything is set to Default, set IMpersonation props to Default as well. 

    -Dave

    Thursday, January 17, 2013 9:45 PM