none
Unable to allocate DBPROCESS connection structure - Windows 7 machine only

    Question

  • I have a program connects to SQL database remotely, and having problem with Windows 7 machine.

    Windows 7 machine can't connect to the SQL server remotely through the program.(It can connect locally from the program)

    XP CAN connect remotely just fine.

    I'm not sure if this is SQL Server Error message but here is what I'm getting.

    Database accessing error [Unable to connect to a database [Unable to allocate DBPROCESS connection structure].].

    From Windows 7 machine, I can ping the SQL Server and can connect using SSMS.

    I turned off Firewalls on both side but no change.

    Are there any setting on the SQL server so that windows 7 machine can connect remotely?

    Is there difference between XP and Win 7 connection?

    I've tried with SQL Server 2012 Express and 2008 R2 Express.

    Thank you


    • Edited by Aibip Tuesday, July 17, 2012 6:44 PM
    Tuesday, July 17, 2012 6:42 PM

Answers

  • Hi Aibip,

    Base on your description, you can ping the SQL Server and can connect using SSMS from Windows 7 machine, so the SQL Server remote connection is enable.

    Generally, we don’t recommend that turn off Windows Firewall. There are three ways to configure the Windows Firewall settings to allow SQL Server Access:
    • Windows Firewall item in Control Panel
    • Microsoft Management Console (MMC)
    • Netsh
    For more details, please refer to this thread.

    The above is just a suggestion for you. So what type of program are you using? .NET application or something else? Please provide the specific connection string. By default SQL Server Express Edition is installed as named instance “SQLEXPRESS”, so you have to add the instance name to the server name, like “YourMachineName\SQLEXPRESS” in the connection string, also please ensure that the SQL Server Browse Service is running. You can take a look at this website regarding SQL Server Connection String: http://www.connectionstrings.com/sql-server-2008.

    If the above suggestion can’t work for you, please share the SQL error Log for further troubleshooting.


    Best Regards,
    Ray Chen

    Thursday, July 19, 2012 3:40 AM
    Moderator