none
Event ID: 19019 Evevt Category: (3)

    Question

  • I have a 2 node SQL Server  (SQLCLUSTERTEST 1 and SQLCLUSTERTEST2)Test Cluster. I tried to move Test1 to Test2, I  could not start the SQL Services  on SQLCLUSTERTEST 1, I  received the following error message:  Event Type: Error

    Event Source:    MSSQL$sqlclustertest1

    Event Category:                (3)

    Event ID:              19019

    Date:                     5/4/2010

    Time:                     3:50:28 PM

    User:                     N/A

    Computer:          SQLCLUSTERTEST2

    Description:

    [sqsrvres] OnlineThread: ResUtilSetResourceServiceEnvironment failed (status 6)

    .

    Data:

    0000: 4b 4a 00 40 01 00 00 00   KJ.@....

    0008: 10 00 00 00 73 00 71 00   ....s.q.

    0010: 6c 00 76 00 73 00 65 00   l.v.s.e.

    0018: 72 00 76 00 65 00 72 00   r.v.e.r.

    0020: 74 00 65 00 73 00 74 00   t.e.s.t.

    0028: 31 00 00 00 00 00 00 00   1.......
    Tuesday, May 04, 2010 9:27 PM

All replies

  • Check if the account on which SQL Server Instance SQLCLUSTERTEST 1 run have "Local Administrator" privileges on SQLCLUSTERTEST2.

    Please provide the SQL Server & Windows Version build details.


    Sivaprasad S http://sivasql.blogspot.com Please click the Mark as Answer button if a post solves your problem!
    Wednesday, May 05, 2010 12:29 AM
  • Am I correct to assume that you built the Windows cluster with a single node, installed SQL Server failover cluster, and then added the second node?

    bass_player http://bassplayerdoc.blogspot.com/
    Wednesday, May 05, 2010 12:38 AM
  • Yes, both have local admin priveleges

    Both nodes have SQL Server 2005 Enterprise x64.

    Wednesday, May 05, 2010 1:06 PM
  • I started off with 2 Windows Clusters; SQLCLUSTERTEST1 (test1) and SQLCLUSTERTEST2 (test2).  Test1 has a R and a S drive.  Test2 has the T and U drive. I installed SQLSERVER 2005 Enterprise x64 on Test1 (SQLvSrvr1)first. I then installed the SQL on test2 (SQLvSrv2). I then installed SP3 on Test1 and after installation I rebooted Test1. After Test1 came up I installed SP3 on Test2 and rebooted.  I did the same when I installed the Hot Fix. Could this be a Dependencies issue? For example on the R drive I have:SQL IP Address 1 and SQL Network Name.  Is this correct, should I add the S drive as a dependency? Should I have set up the dependencies prior to installing SP3 and HotFix?

    When I went to move SQLSvr1 to SQLSvr2, it SEEMED to work.  When I went to move SQLSvr1 back I got the error:  Event ID: 19019 Event Category: (3).

    Thank you so much for your help

    Wednesday, May 05, 2010 1:38 PM
  • Hi,

     

    I have same problem on one of my production clustered server.

    Windows Server 2003 R2 sp2
    SQL Server 2005 sp3

    sql server service is fine in cluster1. When failed over to cluster2 the sql server service, sql server agent will act to start but the generic service for FTS has an X mark then afterwards the 2 first services will not start.

    Event Type:    Error
    Event Source:    MSSQL$VS3
    Event Category:    (3)
    Event ID:    19019
    Date:        4/4/2011
    Time:        5:49:07 PM
    User:        N/A
    Computer:    ZSQLCL3
    Description:
    [sqsrvres] OnlineThread: Error 6 bringing resource online.


    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 4b 4a 00 40 01 00 00 00   KJ.@....
    0008: 08 00 00 00 5a 00 53 00   ....Z.S.
    0010: 51 00 4c 00 56 00 53 00   Q.L.V.S.
    0018: 33 00 00 00 00 00 00 00   3.......

    Event Type:    Error
    Event Source:    MSSQL$VS3
    Event Category:    (3)
    Event ID:    19019
    Date:        4/4/2011
    Time:        5:49:07 PM
    User:        N/A
    Computer:    ZSQLCL3
    Description:
    [sqsrvres] OnlineThread: ResUtilSetResourceServiceEnvironment failed (status 6)


    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 4b 4a 00 40 01 00 00 00   KJ.@....
    0008: 08 00 00 00 5a 00 53 00   ....Z.S.
    0010: 51 00 4c 00 56 00 53 00   Q.L.V.S.
    0018: 33 00 00 00 00 00 00 00   3.......

     

    Thanks,

    Saburo

     

     


    Luanne
    Monday, April 04, 2011 9:34 AM