none
formating report to get desired csv export format

    Question

  • Hello, I'm trying to format a report so when exported to a comma delimited text it looks like:

    "column1", "column2"
    "column1", "column2"

    Biggest problem is with the quotes, when I add my own, either in query or expression, the csv file will put quotes around the quote.
    Any Ideas?  Thanks
    Wednesday, April 29, 2009 5:28 PM

Answers

  • Hi,

    One way to allow only one instance of double quotes to appear in your csv output is to export your report to excel, and then save the format as csv.


    Ke Xu - MSFT Reporting Services
    Monday, May 04, 2009 7:28 PM

All replies

  • Hi,

    Please take a look at the following post regarding the CSV export qualifier device info:

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/a34a5cda-b685-45ac-babd-d712e3d3e6fc

    HTH,
    Ke
    Ke Xu - MSFT Reporting Services
    Wednesday, April 29, 2009 8:56 PM
  • Thanks
    however on my report server, my config file only has:
    <Extension Name="CSV" Type="Microsoft.ReportingServices.Rendering.CsvRenderer.CsvReport,Microsoft.ReportingServices.CsvRendering"/>
    there are no delimiter and classifier settings.

    Wednesday, April 29, 2009 9:42 PM
  • ok I think I understand now but I'm still confused as to why <Qualifier>"</Qualifier> or <FieldDelimiter>,</FieldDelimiter> is not shown expliciltey since thats the default behavior
    Wednesday, April 29, 2009 10:35 PM
  • I have changed the config on the report server to the following:
    <Extension Name="CSV" Type="Microsoft.ReportingServices.Rendering.CsvRenderer.CsvReport,Microsoft.ReportingServices.CsvRendering">
    
    	<Configuration>
    
    		<DeviceInfo>
    <Qualifier>false</Qualifier> <NoHeader>false</NoHeader> </DeviceInfo> </Configuration> </Extension>
    However it didnt work.  I did this to the rsreportserver.config file in: C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportServer

    there is also a MSSQL.1 and MSSQL.4 folder but they didnt do appear to have the config file

    Any ideas?
    thanks

    EDIT: I have verified that MSSQL.3 is the active instance. 
    Thursday, April 30, 2009 4:00 PM
  • odd, I guess the server decided it would start behaving over night because now it started responding to config changes
    I got it working now thanks
    Friday, May 01, 2009 3:54 PM
  • hmm aparently false does not disable the qualifier
    so is there any way to export csv to look like:
    "field1","field2"
    where the fields can contain whatever text and not blow up?

    Friday, May 01, 2009 6:27 PM
  • Hi,

    One way to allow only one instance of double quotes to appear in your csv output is to export your report to excel, and then save the format as csv.


    Ke Xu - MSFT Reporting Services
    Monday, May 04, 2009 7:28 PM