none
SQL Server 2008 R2 SP1 install fails with error code -2068578304 (sa password not strong enough)

    Question

  • Hello everyone!
    I am having a problem where some machines (both virtual and real), running Win7 (both 32 and 64 bit) fail to install SQL Server 2008 R2 SP1.
    The exit code is -2068578304 and in the log file for the SQL installation I find the following: 
    ----------------------------------------------
    Overall summary:
      Final result:                  SQL Server installation failed. To continue, investigate the reason for the failure, correct the problem, uninstall SQL Server, and then rerun SQL Server Setup.
      Exit code (Decimal):           -2068578304
      Exit facility code:            1204
      Exit error code:               0
      Exit message:                  The specified sa password does not meet strong password requirements. For more information about strong password requirements, see "Database Engine Configuration - Account Provisioning" in Setup Help or in SQL Server 2008 R2 Books Online.
    ----------------------------------------------
    and then also
    ----------------------------------------
    Exception summary:
    The following is an exception stack listing the exceptions in outermost to innermost order
    Inner exceptions are being indented
    Exception type: Microsoft.SqlServer.Chainer.Infrastructure.InputSettingValidationException
        Message: 
            The specified sa password does not meet strong password requirements. For more information about strong password requirements, see "Database Engine Configuration - Account Provisioning" in Setup Help or in SQL Server 2008 R2 Books Online.
        Data: 
          SQL.Setup.FailureCategory = InputSettingValidationFailure
          DisableWatson = true
        Stack: 
            at Microsoft.SqlServer.Chainer.Infrastructure.InputSettingService.LogAllValidationErrorsAndThrowFirstOne(ValidationState vs)
            at Microsoft.SqlServer.Configuration.SetupExtension.ValidateFeatureSettingsAction.ExecuteAction(String actionId)
            at Microsoft.SqlServer.Chainer.Infrastructure.Action.Execute(String actionId, TextWriter errorStream)
            at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionInvocation.ExecuteActionHelper(TextWriter statusStream, ISequencedAction actionToRun)
        Inner exception type: Microsoft.SqlServer.Configuration.SqlEngine.ValidationException
            Message: 
                    The specified sa password does not meet strong password requirements. For more information about strong password requirements, see "Database Engine Configuration - Account Provisioning" in Setup Help or in SQL Server 2008 R2 Books Online.
    ----------------------------------------
    However, if the sa password is not strong enough, why does the installation succeed on many machines but not on a few?
    I am not getting consistent behaviour across machines, but the behaviour seems so far to be consistent on specific machines.
    Any ideas (except for changing the pwd)?
    Monday, November 28, 2011 11:49 AM

Answers

  • Technically you can install using windows auth only, then turn around and make it mixed mode auth. Once mixed mode is enabled you can choose to have the SA password be anything you wish by choosing to not enforce the GPO or LSP.

    If however this is to be packaged as part of a program, then what Janos has said applies and you will either have to change the GPO/LSP or create a more complex password according to the GPO/LSP.

    -Sean

    Monday, November 28, 2011 6:45 PM

All replies

  • hi,

    Local Security Policy or GPO can cause different password strenght settings on a machine. If changing sa password is not an option, nor using Windows Authentication only, yur only option is to change LSP or GPO.

    I hope it helps.

    J.


    There are 10 type of people. Those who understand binary and those who do not.
    My Blog
    Monday, November 28, 2011 1:18 PM
  • Technically you can install using windows auth only, then turn around and make it mixed mode auth. Once mixed mode is enabled you can choose to have the SA password be anything you wish by choosing to not enforce the GPO or LSP.

    If however this is to be packaged as part of a program, then what Janos has said applies and you will either have to change the GPO/LSP or create a more complex password according to the GPO/LSP.

    -Sean

    Monday, November 28, 2011 6:45 PM
  • Thank you for your replies!

    Ok I will check the LSP settings and see if that helps.

    Tuesday, November 29, 2011 7:50 AM