none
SSMS 2012 error adding solution to source control

    Question

  • I'm using TFS 2010, and have the MSSCCI provider installed. I recently installed SSMS 2012. If I create a new project and solution in Management studio 2012, then click File >> Source Control >> Add solution to source control I get an error:

    Error: No such interface supported

    File: vsee\internal\inc\vscomptr.inl

    Line number: 259

    Other source control selections in the file menu seemingly work OK, like 'Launch Team Foundation server MSSCCI Provider'

    Similar operations work OK in SSMS 2008, which is still installed on this workstation.

    What would be causing this error?

    Thanks.

    Monday, April 16, 2012 3:49 PM

Answers

  • I also have the same issue. I run both SSMS 2008 and SSMS 2012.  SSMS 2008 does not have this issue.

    I have narrowed the problem down to the presence of the .vspscc files.

    A poor workaround is to create the Projects and Solutions with no source control. Use VS or web browser and manually add the files/folders to TFS.

    Delete ALL .vspscc files in TFS and locally. Open the solution in SSMS and you should be able to work after optionally unbinding and re-binding a few times.  NOTE: you will experience problems as TFS is expecting those .vspscc files. Checkout of projects will have to be done outside SSMS.  You will also need to manually uncheck the 'missing' .vspscc files from checkin whenever prompted.


    • Edited by .Hexanon Monday, April 23, 2012 12:33 PM spelling 'doh
    • Marked as answer by Stephanie Lv Monday, April 30, 2012 7:05 AM
    Monday, April 23, 2012 12:32 PM

All replies

  • have you select a source control provider in Tools menu of SSMS 2012?

    and do you use the same plattform for SSMS 2012 and MSSCI provider ? (32-bit vs 64-bit)

    Monday, April 16, 2012 8:13 PM
  • Hi Rob gravereaux,

    Could you have a try to use the following command to remove vssprovider.dll in case the problem is the vssprovider.dll is failed to load?
    devenv.exe/ResetSkipPkgs

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Stephanie Lv

    TechNet Community Support

    Tuesday, April 17, 2012 5:48 AM
  • Yes, the correct source control provider is selected - Team Foundation Server MSSCCI Provider. It's the only selection in the list. I had Visual SourceSafe 2005 installed until yesterday.

    I have this installed on two systems and they act the same way. One is Win7 x64, and the other is a Win7 x86 VM.

    Yes, the proper platforms are installed. The Sql server install is for both x86 and x64. The MSSCCI install has separate installers for x86 and x64, and won't install to the wrong platform.

    Tuesday, April 17, 2012 1:13 PM
  • Thanks for the reply.

    I believe you're looking as issues related to the visual studio executable - devenv.exe.

    The SSMS 2012 executable is ssms.exe. There is no devenv.exe installed with the sql server tools, and Ssms.exe does not support the same command line arguments.

    Are there registry settings that control this?

    I have this installed in two environments and both act the same way. One is Win7 x64, and one is a Win7 x86 VM. I did have Visual SourceSafe 2005 installed in my x64 environment until yesterday.

    Tuesday, April 17, 2012 1:33 PM
  • I'm facing excatly the same problem.

    Any idea ?

    Thanks.

    Thursday, April 19, 2012 7:25 AM
  • I just created an incident on Connect:

    https://connect.microsoft.com/SQLServer/feedback/details/737893/ssms-2012-error-adding-solution-to-source-control-with-tfs-msscci-provider

    We'll see what happens there.

    I'm curious to know, can anyone successfully add a SQL Server 2012 solution to source control with the MSSCCI provider?

    Friday, April 20, 2012 1:35 PM
  • I also have the same issue. I run both SSMS 2008 and SSMS 2012.  SSMS 2008 does not have this issue.

    I have narrowed the problem down to the presence of the .vspscc files.

    A poor workaround is to create the Projects and Solutions with no source control. Use VS or web browser and manually add the files/folders to TFS.

    Delete ALL .vspscc files in TFS and locally. Open the solution in SSMS and you should be able to work after optionally unbinding and re-binding a few times.  NOTE: you will experience problems as TFS is expecting those .vspscc files. Checkout of projects will have to be done outside SSMS.  You will also need to manually uncheck the 'missing' .vspscc files from checkin whenever prompted.


    • Edited by .Hexanon Monday, April 23, 2012 12:33 PM spelling 'doh
    • Marked as answer by Stephanie Lv Monday, April 30, 2012 7:05 AM
    Monday, April 23, 2012 12:32 PM
  • Delete ALL .vspscc files in TFS and locally. Open the solution in SSMS and you should be able to work after optionally unbinding and re-binding a few times.  NOTE: you will experience problems as TFS is expecting those .vspscc files. Checkout of projects will have to be done outside SSMS.  You will also need to manually uncheck the 'missing' .vspscc files from checkin whenever prompted.

    Not working. Using SSMS 2012 + CU1. Source Control = Vault 4.14

    SSMS seems to works for about 2 minutes and the error message "File: vsee\internal\inc\vscomptr.inl" poped up.

    Thursday, May 03, 2012 7:45 PM
  • What a disaster MS has created here...

    I applied the latest service request found on the connect site - still get the same results trying to manage source controlled projects in SSMS 2012.

    Friday, August 03, 2012 12:18 PM
  • Same here... Applied the "recommended" hotfixes but the error still persists. 

    Anybody had any luck making this work seamlessly? 

    My config is:

    TFS 2012 running on a Windows Server 2008 R2.

    SQL Server Management Studio version 11.0.2100.60

    Microsoft Analysis Services Client Tools 11.0.2218.0

    Microsoft Data Access Components (MDAC) 6.1.7601.17514

    Operating System 6.1.7601

    Friday, October 12, 2012 1:24 PM
  • This is not answered so please remove the check from this thread.  The check indicates that it has been answered and anyone that has tried to add a SQL Server 2012 solution to source control with the MSSCCI provider knows that this has not been resolved.

    The workaround is to use both SSMS 2012 and VS 2010 in tandem.   VS 2010 to checkout/checkin and SSMS 2012 to edit after checkout.  But this is a pain.


    SOTATS, Inc.

    Monday, October 15, 2012 5:01 PM