none
Could not create a managed connection manager ; SSIS package from SSMS - Windows 7 64 bit

    Question

  • I created connection as Oracle provider for .Net.

    In data flow, using the ado net source. select data access mode as SQL command.

    When click preview. data is coming.

    But when right click the dataflow task --> execute task.

    data flow is failed with following error

    [ADO NET Source [1]] Error: Microsoft.SqlServer.Dts.Runtime.DtsCouldNotCreateManagedConnectionException: Could not create a managed connection manager. at Microsoft.SqlServer.Dts.Runtime.ManagedHelper.GetManagedConnection(String assemblyQualifiedName, String connStr, Object transaction) at Microsoft.SqlServer.Dts.Runtime.Wrapper.IDTSConnectionManager100.AcquireConnection(Object pTransaction) at Microsoft.SqlServer.Dts.Pipeline.DataReaderSourceAdapter.AcquireConnections(Object transaction) at Microsoft.SqlServer.Dts.Pipeline.ManagedComponentHost.HostAcquireConnections(IDTSManagedComponentWrapper100 wrapper, Object transaction)

    Friday, May 20, 2011 3:53 AM

Answers

  • Do you run it under 64bit?

    if yes, go to Project menu, select project properties.

    in the project properties window, go to Debugging tab, and set Run64BitRuntime as false. and try again.

     

     


    http://www.rad.pasfu.com
    • Proposed as answer by SSS.Ezhil Friday, May 20, 2011 7:08 AM
    • Marked as answer by david.ng Friday, May 20, 2011 7:25 AM
    Friday, May 20, 2011 5:10 AM

All replies

  • Do you run it under 64bit?

    if yes, go to Project menu, select project properties.

    in the project properties window, go to Debugging tab, and set Run64BitRuntime as false. and try again.

     

     


    http://www.rad.pasfu.com
    • Proposed as answer by SSS.Ezhil Friday, May 20, 2011 7:08 AM
    • Marked as answer by david.ng Friday, May 20, 2011 7:25 AM
    Friday, May 20, 2011 5:10 AM
  • Just got a new Windows 7 64-bit workstation after replacing an old 32-bit Windows XP workstation and I got this error while running my SSIS package.

    Flipping that flag in the debugging tab did the trick for me.

    Thanks for the tip!


    Thursday, April 24, 2014 2:06 PM