none
Virtual Labs - No Connection message

    Question

  • A couple of us are trying to use the SQL Server 2005 Virtual labs at http://msdn.microsoft.com/sql/ .  We complete all the prelim steps successfully but when we click on "Start the Lab" we get a blank page with "No Connection" in the middle.  The clock ticks and the system thinks we are doing the lab.  How can we get a connection?  or is the server down?  or are there no available resources left?
    Wednesday, November 23, 2005 4:02 PM

Answers

  • Great news!!  The next ActiveX control is coming out tonight.  Please try Virtual Lab again and see if it fixes your problem.

    NOTE: When you login, it will seem as if you don't have the activeX control installed and will prompt you for a new installation.  This is an expected procedure.

    Thanks,
    Anthony Tsim
    Microsoft Virtual Labs (aka the guy who invented the program )

    Tuesday, May 02, 2006 10:50 PM
  • With the new ActiveX control, if it does not automatically recognize your browser proxy settings, you can enter them in on a new screen.  Have you tried this yet?

    To get to the screen, notice the new menu bar right above the ActiveX display.  Click on the "Help" button, and then on the "No connection?" link.  Here you can enter your proxy settings, and the control will then attempt to reconnect using that information.

    Robert

    Tuesday, May 09, 2006 5:40 PM

All replies

  • Can you please send an email to me at majewett@online.microsoft.com so I can connect you with the right people to address this?  Thanks< MJ
    Thursday, November 24, 2005 5:51 AM
  • Hi,

    I tried to send an email to majewett@online.microsoft.com but I got the following message:

    5.1.2 - Bad destination host 'DNS Hard Error looking up online.microsoft.com (MX): NXDomain'

    Has the email address changed?

    Thanks,

    Reza

    Monday, November 28, 2005 4:15 PM
  • Sorry, please try Mark.Jewett@microsoft.com instead.  Thanks< MJ
    Monday, November 28, 2005 6:50 PM
  • Here's a status update:
    This does appear to be issues based on firewalls.  At this point in time there is an investigation into how to best resolve. In cases it is either due to vmrc (which controls the virtual machine) protocol being blocked or proxy settings not being handled properly.

    In instances where ISA Firewall is being used, we have found that installing the ISA Firewall client will resolve the issue.  If another firewall is being used we suggest in the short term, contact your administrator to see if a local firewall client option is available.

    At this point there is little the end-user can do without escalating the issue to the IT administrator responsible for managing their corporate firewall.

    We will continue to update with more information.

    Thanks, MJ

    Tuesday, November 29, 2005 11:53 PM
  • Is any more information available?  What settings should I tell my network administrators to change, etc.  Thanks.
    Thursday, December 15, 2005 4:10 PM
  • I'm sorry right now there's not much to report.  I know the issue is being worked on but I suspect it will be post holidays when we're able to publish an update here.  Thanks for continuing to try.  MJ
    Saturday, December 17, 2005 12:29 AM
  • OK, Mark it is post holidays now, well for me it is anyway.  Do you have any way to resolve this issue as yet?

    This is lessening the chances of my company purchasing software from Microsoft, in particular BizTalk Server which I am trying to do an evaluation on.

    I look forward to seeing your solution to this problem and the "Microsoft Contact US" msconus@microsoft.com are being rather silent after first mentioning they are escalating my question to this known issue.

    Thanks in advance.

    Wednesday, January 18, 2006 11:07 PM
  • Mark we have run into the same issue with our IT group trying to use some of the labs for studio 2005.  No connection - we are also waiting for a solution or at least what chcnges in the firewall we can test.

     

    Thanks

    Wednesday, January 25, 2006 7:55 PM
  • Hi, do you have any update regarding this issue? we also have this problem. We are using ISA 2004.

     

    thanks,

    Arnold

    Friday, March 24, 2006 8:18 PM
  • Hi,

    A fix is on its way and we are getting close to the final bits.  Basically the issue is related to the VRMC ActiveX control not able to pick the proxy server information.  We anticipate the fix to be avaiable no later than end of May.  Sorry for the inconvenience.

    With the new platform launched back in November, we have routed all the communications to port 80 and 443 instead of 3389.

    Anthony Tsim
    Owner of Microsoft Virtua Labs (the man who invented the thing!!)

    Monday, April 03, 2006 10:34 PM
  • Any word on this thing?   We are a complete MS Shop with regard to firewall and that this doesn't seem to be working with ISA Server seems a bit odd.
    Friday, April 21, 2006 7:06 PM
  • The fix is currently going through final code review within Microsoft.  We should have it available very soon.  In the mean time, please ensure you have port 80 and 443 enabled  and VMRC allowed.

    Thanks,
    Anthony Tsim
    Owner of Microsoft Virtual Labs

    Monday, April 24, 2006 5:08 PM
  • I have the firewall client loaded and I am still not able to view the virtual lab.  Just letting you know.
    Monday, May 01, 2006 1:56 PM
  • Great news!!  The next ActiveX control is coming out tonight.  Please try Virtual Lab again and see if it fixes your problem.

    NOTE: When you login, it will seem as if you don't have the activeX control installed and will prompt you for a new installation.  This is an expected procedure.

    Thanks,
    Anthony Tsim
    Microsoft Virtual Labs (aka the guy who invented the program )

    Tuesday, May 02, 2006 10:50 PM
  • Great work..it works!

    Thanks

    Sudhaker

    Tuesday, May 02, 2006 11:45 PM
  • Anthony,

    I got the same message NO CONNECTION. How can it be fixed?

    Thanks.

    Wednesday, May 03, 2006 2:54 PM
  • I am still having trouble - recieving the no connection message.  I installed the latest activex today.  Tracing with Ethereal shows that the active x component is ignoring my proxy settings and trying to connect directly using port 443.  Will the activex be fixed to use the brower proxy settings?

    If not the only other option is to try and get a network admin to open up port 443 to the required servers.  Is there a range of ips that can be used for this

    Tuesday, May 09, 2006 1:20 AM
  • With the new ActiveX control, if it does not automatically recognize your browser proxy settings, you can enter them in on a new screen.  Have you tried this yet?

    To get to the screen, notice the new menu bar right above the ActiveX display.  Click on the "Help" button, and then on the "No connection?" link.  Here you can enter your proxy settings, and the control will then attempt to reconnect using that information.

    Robert

    Tuesday, May 09, 2006 5:40 PM
  • Wow.. it works.. but..

    SERIOUS SECURITY ISSUE!!!

    Please mask the password when it is typed in.. it is entered in free text.. all someone has to do is look over your shoulder.. or run up and click Help | No Connection? when you aren't there and it will show them your password.

    PLEASE update to mask the password

     

    Thanks!

    Wednesday, May 10, 2006 6:21 AM
  • How long would this VLab for SQL Server be available online ?

    Is there any dates for it not to be available any further?

     

    Wednesday, May 10, 2006 8:40 PM
  • Very good point about the security issue with the proxy password field.  It's been updated to mask the entries now.
    Wednesday, May 10, 2006 10:15 PM
  •  Baikinman wrote:

    I am still having trouble - recieving the no connection message.  I installed the latest activex today.  Tracing with Ethereal shows that the active x component is ignoring my proxy settings and trying to connect directly using port 443.  Will the activex be fixed to use the brower proxy settings?

    If not the only other option is to try and get a network admin to open up port 443 to the required servers.  Is there a range of ips that can be used for this

    I'm having the exact same problem at work. The network guys said that all the traffic goes through the proxy up until trying to connect to the VM, then the traffic goes straight through the firewall.

    Is this an issue with the ActiveX control?

    Thursday, July 13, 2006 8:47 PM
  • I was able to get the VM connection working using this little utility as the proxy: http://ntlmaps.sourceforge.net/
    Thursday, July 13, 2006 9:43 PM
  • Having similar difficulties here when not allowing all users group through. If I create a rule allowing all users to the url, the clients can get through.
    Tuesday, July 18, 2006 12:32 AM
  • I am still having the "No Connection" issue at a client location but I can connect with a commercial ISP.  Looking at an ethereal capture, it looks like there is a TLS session that is attempted with a random client port to the server port 443.  On the session that works, everything goes fine and the client gets a number of handshakes from server port 443 to the random port at the client.  On the session that does not work, I see the request go out from client (TCP port 2560 in this case) to server port 443.  Then I see where I am prompted to enter my credentials by hand which I do.  I see the request go out from the client again (TCP port 2560) to server port 443.  I am prompted again.

    Any ideas what I can do next or is this a lost cause?

    Thursday, August 17, 2006 2:19 PM
  • On the session that does not work, what is the network configuration?  I am assuming there is no proxy server in the middle since it seems to be directly making contact with server port 443.  What is the IP/Name of the server for the port 443?  Is this the server prompting for credentials?  Just trying to verify if it is communicating with one of the virtual lab servers (vhxx.virtuallab.microsoft.com) or if it is not even making it that far.
    Friday, August 18, 2006 6:33 PM
  • Yes there is a proxy server in between and I see the proxy server in the traffic.  The final destination was vh27.virtuallab.microsoft.com:443 which (if I am reading my .cap file correctly) is going through my proxy server port 80.  I see the call out (TLS) to vh27.virtuallab.microsoft.com:443 but I see no response.  I assume the response is getting blocked or lost somewhere.  The multiple TLS attempts II mention in my first message I believe are the the first connection fails so it asks me for my proxy server (which I enter on the "No Connection" page and it tries again.  It then prompts me for my proxy again...
    Tuesday, August 22, 2006 1:45 AM
  • Terry,

    Could you please elaborate on this - how can connection be established using this utility http://ntlmaps.sourceforge.net/? I have a corporate proxy server in between my PC and microsoft's site and get "No Connection" message when I try to login. Thanks for the info.

    Tuesday, August 22, 2006 8:02 PM
  • Hi Anthony,

    In my company we are expereincing this same exact "no connection" problem  using our corporate ISA Proxy Server (version 2000) even after the fix was released.

    I note the last post was August 2006. Are there any other suggestions, fixes etc?

     

    Joe

    Tuesday, September 26, 2006 4:13 PM
  • If you read the documentation that comes with the utility, you can figure out what information needs to go where. Once running, set your IE proxy to 127.0.0.1:5865 and your requests are wrapped with NTLM authentication and passed to the configured proxy.

    In my case, this helped as direct proxy communication was not working properly. No guarantees this will work for all, though.

    Wednesday, September 27, 2006 6:08 AM
  •  

    Hi Anthony,

     

    My company is also experiancing the same "No connection" problem even after installing the latest activex control from the technet site.

     

    We also use ISA Proxy server 2000 and would appreciate any advise on how t resolve this.

     

    Mike

    Monday, July 16, 2007 4:39 PM
  • Good luck getting microsoft help on this. I have been trying for many months, including opening a ticket with Microsoft Support. I have even emailed Anthony Tsim (the owner of this app) myself. I also emailed Microsoft managers at a special email I was told to use by support. I've given up because I get no response. And may company has an enterprise support contract with microsoft!

     

    Joe

    Friday, July 20, 2007 8:02 PM
  • Hi,

     

           I am also getting the same message even after filling the information in "No Connection" dialog box. Our system administrator has also tried all options still I am not able to connect to labs. Has anyone got the workaround? Thanks in advance.

    Tuesday, August 07, 2007 7:22 AM
  • Hi,

     

    Can Microsoft improve on the Virtual Labs connection issue since I believe many people are inadvertently blocked from accessing the Virtual Labs due to their firewalls having issue with the connections required by the Virtual Labs?

     

     

    Best regards,

    MP Wong

    Monday, November 12, 2007 12:01 PM
  • Hi Anthony,

     

    still we have same issue, i have dsl connection at my home, no proxies & no firewalls, i disable every thing but still i get no connection error when i try to connect any technet virtual lab.

     

    Sunday, November 18, 2007 2:58 PM
  •  

    I have the issue, too.

     

    My Windows XP based computer is behind the provider's NAT. Personal firewall disabled.

     

    My scenario:

    Code Block
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html; charset=windows-1251"></HEAD>
    <BODY></BODY></HTML>

     

    • And I didn't get the virtual lab.

    Tuesday, December 11, 2007 1:07 PM
  • I have the same issue, looking for some help

     

    Please do something.

     

    Ali

    Tuesday, December 11, 2007 2:54 PM
  •  

    MS technical support didn't solve the problem.

     

    They said "we have good access" and "request technical support from your's ISP".

     

     

     

     

     

    Thursday, December 20, 2007 2:32 PM
  • When I follow the View Online link after registering for a lab I get presented with a blank screen. Source reveals nothing more than a doctype and empty body.

     

    There's no prompt to download a control and no error message of any kind.

     

    I've opened port 443 on my local machine and our network admin has ensured nothing else could be blocking it. I've also manually downloaded and installed VMRCplus.

     

    Any ideas? This is becoming rather frustrating.

     

    Kind regards,

    Paul

    Thursday, April 03, 2008 3:41 AM
  •  Br.Azam wrote:

    Hi Anthony,

     

    still we have same issue, i have dsl connection at my home, no proxies & no firewalls, i disable every thing but still i get no connection error when i try to connect any technet virtual lab.

     

     

    Same for me

    Tuesday, October 07, 2008 4:40 PM
  • We were having the same issue at my work. We have no proxy in place but used an Web Filter applicance.

    Though the settings in the appliance were set to no proxy, any virtual lab we tried (ElementK, MS, Technet)

    returned the "no connection", then the proxy server request. Entering the ip to the appliance for the Proxy Server Address and the affected Proxy Server port number seemed to have taken care of it. Have had no problems since.

     

    Wednesday, November 05, 2008 6:41 PM
  • this issue starting on:

    Wednesday, November 23, 2005 4:02 PM

    till now not solved ???!!!
    Wednesday, December 02, 2009 1:33 PM
  • Hard to believe that something this simple is still an issue for so many.

    One less reason not to renew my TechNet subscription.
    If at first you don't succeed, ask an MVP. Or find someone who really knows. ;)
    Thursday, January 28, 2010 4:19 AM
  • It seems more like an internal issue, and got to do with your org. policies. Try to do it in your personal desktop at home..it should work.

    In short: You cant buy a cake, by showing your dad's piggy bank to the Baker. You also need dad's key for making payment.  :)

    Thursday, May 06, 2010 1:32 PM
  • Some of the Virtual labs work and for some doesnt. If its an internal problem all of them should not work.

     

    Wednesday, July 14, 2010 9:01 PM
  • The fix is currently going through final code review within Microsoft.  We should have it available very soon.  In the mean time, please ensure you have port 80 and 443 enabled  and VMRC allowed.

    Thanks,
    Anthony Tsim
    Owner of Microsoft Virtual Labs


    How do we enable ports 80 and 443 and allow VMRC on WinXP Pro?

    Thanks,

    Sams

    Thursday, July 22, 2010 4:57 PM
  • I am having the same issue as Tanikella

    "Some of the Virtual labs work and for some doesnt. If its an internal problem all of them should not work."

     Windows Workflow Foundation : MSDN Virtual Lab: Workflow Enabled Services and Other New Features in the .NET Framework 3.5 - I couldnt get this virtual lab to work.

    Im also at home with no firelwall, plugged directly in to the internet.

     


    Troy
    Sunday, July 25, 2010 11:40 AM
  • Microsoft youmay have billions but you are wasting my time trying to connect to SQL 2005 Service Broker. I have been at this for a few hours now. Fire the person in charge and put someone on notice. If your going to offer it you need make it right. If not pull it.

    Sincerely very frustrated as so many others are.

    Friday, July 30, 2010 6:32 PM
  • I have attempted this on two computers and would really like to use this service. I am trying to use the WCF vlab.  I am getting the following error "Firewall Connecting to the labs require that you have port 443 open."  Can anyone use this service, I was able to use a SQL 2005 vlab a few years ago?  Some posts state that we should contact our admin, well I am doing this from home and I am the admin.  I am not an IP expert and do not have a good guess what my proxy server address would be.  One of the above posts states that I should have port 80 open, I hope that one is working because I am able to write this post.  I moved my PC out into the DMC on my router and that did not seem to help.  The first post in this thread is from 2005, can someone please narrow down when we should expect a fix for this? 
    Saturday, August 07, 2010 6:23 PM
  • I've been trying to access the virtual labe for www.powerpivot.com but cannot. Is there anybody who is able to use this service and how, I tried to add is as a trusted site, but got styfled on the remote desktop communication manager steps. Is anyone able to advice how to go about accessing this virtual lab?

     

    Friday, August 13, 2010 10:53 AM
  • my firewall and router were both blocking port 443.... so I unblocked but it still didnt work. I discovered charter here in Madison, WI blocks port 443? That sucks, now I have to go to the lab to finish this, its a damn homework assignment due on Sunday.
    Friday, December 03, 2010 11:46 PM
  • Some days they work and some days they don't.

    Yesterday this one worked on my desktop, but today it doesn't.  It didn't work on my laptop.

    ·         MSDN Virtual Lab: BizTalk Server 2009: Building your first BizTalk Solution

     

    Friday, December 17, 2010 6:51 PM
  • It is the end of 2011 and I have the same problem, I can connect to the free labs, but the labs from from my MSDN subscription, I cannot. It rejects my PROXY Server setting. Incidentally SAP also has an online lab which requires PROXY information, I do not have this problem with SAP.
    Tuesday, December 20, 2011 7:15 PM