none
Search Service - 3 Errors in Event Log After Installing,

    Question

  • After installing a std. Search Service Application the following 3 error events are logged in the Application Event Log:

    ERROR 1

    The mount operation for the gatherer application a05b2672-befa-414d-9d62-d5cb8e2039eb has failed because the schema version of the search administration database is less than the minimum backwards compatibility schema version supported for this gatherer application. The database might not have been upgraded.

    ERROR 2

    The administration component for application SearchServiceapp failed with exception System.Runtime.InteropServices.COMException (0xC0041235): The gatherer application could not be mounted because the search administration database schema version does not match the expected backwards compatibility schema version. The database might not have been upgraded. 
       at Microsoft.Office.Server.Search.Administration.SearchApi.RunVoidOnServer(VoidCodeToRun remoteCode, VoidCodeToRun localCode, Boolean useCurrentSecurityContext, Int32 versionIn)
       at Microsoft.Office.Server.Search.Administration.SearchApi.MountApp(String gathererApplicationName)
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.SynchronizeAdminComponent(SearchServiceApplication application)
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()

    ERROR 3

    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (ed161ece-0420-4112-9c03-7d9692396d62).

    Reason: The gatherer application could not be mounted because the search administration database schema version does not match the expected backwards compatibility schema version. The database might not have been upgraded. 

    Technical Support Details:
    System.Runtime.InteropServices.COMException (0xC0041235): The gatherer application could not be mounted because the search administration database schema version does not match the expected backwards compatibility schema version. The database might not have been upgraded. 
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
       at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

     


    I.W Coetzer
    Monday, May 17, 2010 8:33 AM

All replies

  • Hi Ian,

    These errors all seem to indicate that your database may not have been upgraded. Can you let me know if this is an upgraded environment?

    Thanks,

    Linda

    Tuesday, May 18, 2010 2:55 PM
  • I know this is an old post, but it came top in DuckDuckGo's search results, so thought I should post the solution I found.

    Error is SharePoint related, details are here: Technet


    Andrew www.pursuittechnology.co.uk

    Saturday, March 31, 2012 3:37 PM