none
Maximum Request Length Exceeded Help!

    Question

  • I have a report that has 14 user supplied parameters. When I added a 15th parameter and deployed the report, I get an error of Maximum Request Length Exceeded when I try to set up a subscription to the report. All of the subscriptions on the report are failing now and users are getting rather upset.

    Please help! How do I get rid of the Maximum Request Length Exceeded error?

     

    Thanks!

    Wednesday, February 21, 2007 3:44 PM

Answers

  • good news.. found a fix for this.

    it's actually the same fix for file uploads that exceed the default 4mb set by IIS. however, the change needs to made to the report manager web.config file and not the report server web.config file. that's why it didn't work for me the first time.

     

    here is an article that talks about it http://support.softartisans.com/kbview_825.aspx

     

    if you have kept the default installation directory, the file you edit is:

    C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportManager\Web.config

    Just add the maxRequestLength property here and set a size appropriate to you. Not to large to discourage DoS attacks.

    The example below is 10mb

    <httpRuntime executionTimeout="9000"  maxRequestLength="10240"/>

     

    hope it helps.

    Wednesday, February 28, 2007 5:55 PM
  • If you are setting these parameters yourself on a web request, then use the Post method rather then the Get method to set the parameters. This will not be affected by the ~1600 character limit for the Get method.

     

    If you are using the report viewer controls and are setting parameters through the parameter UI using SQL 2005 SP2, you should not hit this limit. The controls will use stored parameter functionality that is not effect by the Get limit.

     

     

     

    Saturday, November 03, 2007 9:37 PM
    Moderator

All replies

  • i'm not entirely sure, but shortening your parameter names may help.

    ie:  CustomerLocation to 'Loc'

    Wednesday, February 21, 2007 4:29 PM
  •  Redmanmc wrote:

    I have a report that has 14 user supplied parameters. When I added a 15th parameter and deployed the report, I get an error of Maximum Request Length Exceeded when I try to set up a subscription to the report. All of the subscriptions on the report are failing now and users are getting rather upset.

    Please help! How do I get rid of the Maximum Request Length Exceeded error?

     

    Thanks!

     

    did you ever find a fix for this problem? i seemed to have stumbled upon it myself. thanks

    Tuesday, February 27, 2007 9:39 PM
  • Unfortunently I have not found a solution to the problem yet. I tried reducing the length of the variable names but it did not fix the problem. 

    If anyone out there has a fix please yell out!

    Tuesday, February 27, 2007 10:34 PM
  • good news.. found a fix for this.

    it's actually the same fix for file uploads that exceed the default 4mb set by IIS. however, the change needs to made to the report manager web.config file and not the report server web.config file. that's why it didn't work for me the first time.

     

    here is an article that talks about it http://support.softartisans.com/kbview_825.aspx

     

    if you have kept the default installation directory, the file you edit is:

    C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportManager\Web.config

    Just add the maxRequestLength property here and set a size appropriate to you. Not to large to discourage DoS attacks.

    The example below is 10mb

    <httpRuntime executionTimeout="9000"  maxRequestLength="10240"/>

     

    hope it helps.

    Wednesday, February 28, 2007 5:55 PM
  • Hello,

    I am receiving this error on one of our reporting web servers that has reporting services installed and adding the maxRequestLength parameter to allow up to 10mb did not solve the Maximum Request Length error. Does anyone have any other solutions to this, some sort of configuration setting fix with the Reporting Services install maybe?

     

    Friday, November 02, 2007 11:14 PM
  • If you are setting these parameters yourself on a web request, then use the Post method rather then the Get method to set the parameters. This will not be affected by the ~1600 character limit for the Get method.

     

    If you are using the report viewer controls and are setting parameters through the parameter UI using SQL 2005 SP2, you should not hit this limit. The controls will use stored parameter functionality that is not effect by the Get limit.

     

     

     

    Saturday, November 03, 2007 9:37 PM
    Moderator
  • Hi Guys,

    I came across the same error when trying to alter one of the Subscriptions which was on a Shared Schedule in Reporting Services.
    Deleted the Subscription & tried to recreate it so it could use a Custom Schedule & write the file to Windows Fileshare
    but it gave me the same error. However, was then able to create the subscription from the Management Studio after connecting to Reporting Services.
    Try Browsing thru to that Report under Home--> Reports Folder--> Report Name--> Subscriptions.
    You should be able to create/modify/delete subscriptions from here i.e even set schedules,parameters etc.

    Wednesday, September 09, 2009 1:42 PM
  • so let's say we have a report with one parameter called "empName" - free text form:

    How many names could this parameter box contain?  are we sayig 1600 characters worth of names?

    Is the limit per character count (a+b+c = 3 chars)? or is there a KB size limit on passing parameters?

     

    Friday, July 23, 2010 1:41 PM
  • I tried to limit the data (reduce number of datarows) on each parameter and it solves our issue.  You might want to try to limit/reduce the data retured on each parameters if possible.

    Friday, December 10, 2010 6:33 AM
  • Hi..

     

    I have faced same problem.

     

    Look at below link :-

     

    http://dotnet-magic.blogspot.com/2011/04/maximum-request-length-exceeded.html

    Enjoy Coding !!!!!!

    Thursday, August 11, 2011 6:52 AM
  • If you change the web config file in ReportManager and not ReportServer your report will work

    C:\Program Files\Microsoft SQL Server\MSSQL.3\Reporting Services\ReportManager\Web.config

    then add the below (in this case 10mb)

    maxRequestLength="10240"

    Thursday, April 10, 2014 7:30 AM