none
SSRS subscription email failure.

    Question

  • I'm running SQL 2008 R2 SP1 (on Server 2008 R2) and getting an error when a subscription runs for a particular report.  If I stop and restart the SSRS & Agent services then the emails will send successfully.

    The error message in the SSRS logs is:

    library!WindowsService_13!778!10/13/2011-10:00:24:: i INFO: Initializing EnableExecutionLogging to 'True'  as specified in Server system properties.
    notification!WindowsService_13!778!10/13/2011-10:00:24:: i INFO: Handling subscription 0b5977df-7a64-4585-a215-b55257d2cc31 to report [Report Name], owner: [DOMAIN]\[USER], delivery extension: Report Server Email.
    library!WindowsService_13!778!10/13/2011-10:00:24:: i INFO: RenderForNewSession('/[Report Name]')
    library!WindowsService_13!778!10/13/2011-10:00:26:: i INFO: Initializing EnableExecutionLogging to 'True'  as specified in Server system properties.
    emailextension!WindowsService_13!778!10/13/2011-10:00:26:: e ERROR: Error sending email. System.Runtime.InteropServices.COMException (0x80040201): Exception 0xc0000005 was generated at address 0x000007FEF2AA57DB
    
       at ReportingServicesCDOInterop.ConfigurationClass.get_Fields()
       at Microsoft.ReportingServices.EmailDeliveryProvider.EmailProvider.get_MessageConfiguration()
       at Microsoft.ReportingServices.EmailDeliveryProvider.EmailProvider.Deliver(Notification notification)
    notification!WindowsService_13!778!10/13/2011-10:00:26:: e ERROR: Error occured processing subscription 0b5977df-7a64-4585-a215-b55257d2cc31: Failure sending mail: Exception 0xc0000005 was generated at address 0x000007FEF2AA57DB
    Mail will not be resent.


    There are 11 reports being sent and each of them have up to 25 recipients.  I've seen the posts about too long of a from address, but it's not applicable here.  It's not a scale-out deployment.  These subscriptions worked prior to moving from SQL 2005.

    There are other subscriptions on the server that do run just fine, but none are scheduled near the same time as this particular report so they might also fail... I just haven't tried that yet.  Any ideas where to look?

    Thursday, October 13, 2011 3:44 PM

Answers

  • Hi Chad Renstrom,

    Thanks for the post. Please check it from below approaches:

    1. Is it one large report?

    2. As we know, the subscription will use the account that in the report’s datasource to call the delivery, so please check if the account in has issue to connect to the SMTP server?

    3. Please check the creator of the subscription, is this account one expired account or invalid account?

    4. Please try to create one new subscription for a test, this will help us to check if this issue caused by the

    If the issue still exists, could you please help me confirm the two questions?

    One, this error happens in every time and you must restart the SSRS and Agent Server later?

    Second, this error happens only once?

    Thanks,
    Sharp Wang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact us.


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.
    Friday, October 14, 2011 5:48 AM

All replies

  • Hi Chad Renstrom,

    Thanks for the post. Please check it from below approaches:

    1. Is it one large report?

    2. As we know, the subscription will use the account that in the report’s datasource to call the delivery, so please check if the account in has issue to connect to the SMTP server?

    3. Please check the creator of the subscription, is this account one expired account or invalid account?

    4. Please try to create one new subscription for a test, this will help us to check if this issue caused by the

    If the issue still exists, could you please help me confirm the two questions?

    One, this error happens in every time and you must restart the SSRS and Agent Server later?

    Second, this error happens only once?

    Thanks,
    Sharp Wang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact us.


    Please remember to mark the replies as answers if they help you and unmark them if they provide no help.
    Friday, October 14, 2011 5:48 AM
  • Thanks for the reply.
    1. It is one single report, but it is not large... a 5 column table inside a list.  The report would end up 1 page long at most.
    2. I double-checked and the account on the datasource and it is the same datasource as other reports that work fine.
    3. The owner/creator of the subscription is an active Domain User account.
    4. When it errors again (probably next thursday) I'll create another subscription and let you know.

     

    To answer your additional question... In the past if I change the subscription time it still fails with the same error.  I've tried both shared schedule and independent schedule for a single subscription or multiple subscriptions at the same time.  The only consistency I've found is  restarting the SSRS and Agent service does seem to fix the problem.

    Friday, October 14, 2011 1:33 PM