none
An error has occurred while establishing a connection to the server AAAARH!!

    Question

  • PLEASE HELP! I dont know why its showing this right now. Earlier in the day, it gave me an error for a disabled login account. Which i come to find out was the old dba's account, which was disabled today.  so i  changed the login. But now im getting this error. How do i fix this?

    An error has occurred during report processing.

    • Cannot create a connection to data source 'Reporting_FSSRC'.

      • An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

      I also want to state, that everything was runing fine this morning and last nite. And I think it could have been  beceause i thought the encryption keys were faulty. So i had to delete them, since i had no backup. Then i finally realized that the login was from our old dba, who set the execution login as his name. Which was disabled today. Wish someone would have told me! So now im getting that error!

    Tuesday, July 29, 2008 10:19 PM

Answers

  • Hi,

     

    Are you connecting to a remote SQL server? If so, have you opened up named pipes using the SQL Server Surface Area Configuration Tool.  Here's a document on troubleshooting datasource connection issues -http://technet.microsoft.com/en-us/library/ms156468.aspx. Hope this helps.

     

    Thx,

    Gowri

     

    Wednesday, July 30, 2008 12:39 AM
  • Just open report manager and check your dataset connection string
    Wednesday, July 30, 2008 12:17 PM

All replies

  • Hi,

     

    Are you connecting to a remote SQL server? If so, have you opened up named pipes using the SQL Server Surface Area Configuration Tool.  Here's a document on troubleshooting datasource connection issues -http://technet.microsoft.com/en-us/library/ms156468.aspx. Hope this helps.

     

    Thx,

    Gowri

     

    Wednesday, July 30, 2008 12:39 AM
  • Just open report manager and check your dataset connection string
    Wednesday, July 30, 2008 12:17 PM
  • You are right. My database setup in the Virtual Report Server was not connecting because of the login. Well i finally got it to connect. But it still shows the same error. It says the connection works in Reporting Services Configuartion Manager, but i still get the same erorr.

    I have made sure it has TCP/IP enabled for remote connections. what else is there to do? Im so confused. I knew i shouldnt have deleted the Encryption key. Some way some how it is not connectiing to the database server (which is on another server). I can get to report manager, and you can see all the folders, and the reports, but once you click the report, i get that error! ARGGGGG!

     

    Wednesday, July 30, 2008 3:20 PM
  • OK I finally figured it out. I was slow. I read this over and over online! and i still didnt notice it. All my data connection strings were erased within the data sources!! got it working again tHANKS GUYS!

     

    Wednesday, July 30, 2008 3:44 PM
  • Please deploy ODC files again.

    Wednesday, August 25, 2010 5:46 AM