none
Reporting Services using Smtp email get transport error 0x80040217.

    Question

  •  

    Anyone know what else I can do to resolve the following error I get when trying to set up a subscription for a report in report manager:

    Failure sending mail: The message could not be sent to the SMTP server. The transport error code was 0x80040217. The server response was not available

     

    I have an Smtp server with an IP address that requires authentication.  I have set up the RS windows service account with a domain acct that has access to the report server and the smtp server.  I have configured the port value in the RSreportserver.config file as 25 and set up smtpautthenticate with a value of 2 and sendusing as 2 (remote smtp server) what else am i missing ....any help appreciated.

     

    Thanks.

    Wednesday, July 16, 2008 2:57 PM

Answers

  • The error means that the SMTP server rejected your e-mail from some reason. There might be several reasons:

     

    1. account information (username/domain/password) is incorrect

    2. SMTP server does not support NTLM authentication (AFAIK, but I am not sure, RS uses NTLM authentication)

    3. SMTP server supports anonymous access. In this case, do not provide account information at all. refer to the below link and intenet search for instructions to change the configuration file in order to disable the authentication.

    4. SMTP server does not allow you to send e-mails externally, there is a rely problem, or other error occured on the server. Check with SMTP administrator if possible what whas the exact error code on the SMTP server.

     

    http://msdn.microsoft.com/en-us/library/ms345234.aspx

     

    As an alternative solution, you can consider setting up an SMTP server on the same box and use SMTPServerPickupDirectory option. You will have to clean the SMTP server settings from the config file. You can configure your local SMTP server to forward an email to the target server or you can use it as is. Live Search would be my friend in this step.

     

    Sunday, July 20, 2008 6:23 PM

All replies

  • The error means that the SMTP server rejected your e-mail from some reason. There might be several reasons:

     

    1. account information (username/domain/password) is incorrect

    2. SMTP server does not support NTLM authentication (AFAIK, but I am not sure, RS uses NTLM authentication)

    3. SMTP server supports anonymous access. In this case, do not provide account information at all. refer to the below link and intenet search for instructions to change the configuration file in order to disable the authentication.

    4. SMTP server does not allow you to send e-mails externally, there is a rely problem, or other error occured on the server. Check with SMTP administrator if possible what whas the exact error code on the SMTP server.

     

    http://msdn.microsoft.com/en-us/library/ms345234.aspx

     

    As an alternative solution, you can consider setting up an SMTP server on the same box and use SMTPServerPickupDirectory option. You will have to clean the SMTP server settings from the config file. You can configure your local SMTP server to forward an email to the target server or you can use it as is. Live Search would be my friend in this step.

     

    Sunday, July 20, 2008 6:23 PM
  • I had a similar problem, trying to send emails using VBA code in Excel.  I eventually solved the problem after changing my Gmail login security NOT to use the 2-step verification, but only a password.
    Monday, September 16, 2013 12:46 PM