none
Service terminated with error 3417

    Question

  • Yesterday I had a working SQL Server Express (SP2) running on my Vista box, but today (and I'm pretty sure I haven't messed with the configuration of SQL Server or Vista itself) the service won't start. The event viewer shows the following error:

    The SQL Server (SQLEXPRESS) service terminated with service-specific error 3417 (0xD59).

    Any ideas?

    Wednesday, March 07, 2007 8:57 AM

Answers

  • in my case , MSSQLSERVICE stopped after I commpress all folders where SQL is installed, I uncommpressed the entire folder of SQL Server.

    It resolved the problem.

     

    • Proposed as answer by DianaGh Wednesday, March 02, 2011 12:36 PM
    • Marked as answer by Naomi NModerator Friday, December 30, 2011 6:43 PM
    Friday, June 22, 2007 12:59 AM
  • The SQL Server folder and the data file folders should not be compressed as thi is not supported.

    Jens K. Suessmeyer.

    ---
    http://www.sqlserver2005.de
    ---
    Friday, June 22, 2007 11:43 AM
    Moderator
  • Hi to all and thanx!

    It worked for me: the NETWORK SERVICE account, that was set to be the one to run SQL Server, had no access to the folder where master db resided

    Though I did not touch permissions at all, it ended up in this situation.

    Thanx again.
    Tuesday, October 23, 2007 1:17 AM
  • Thanks a lot atomy. I did compress files on my laptop, which stopped SQL Service from accessing Master database MDF file. I uncompressed the MDF files in SQL Server folder, which fixed the issue.
    Wednesday, June 03, 2009 4:22 PM
  •  gkakas wrote:
    Hi to all and thanx!

    It worked for me: the NETWORK SERVICE account, that was set to be the one to run SQL Server, had no access to the folder where master db resided

    Though I did not touch permissions at all, it ended up in this situation.

    Thanx again.
    This also worked for me.  I converted a FAT partition to NTFS and I think it was after that that the permissions issue arose.
    Monday, October 06, 2008 1:19 PM

All replies

  • The 3417 message is an error recovering the master database so the instance can not start. 

    There should be some additional details in the errorlog about what the specific problem is with master.  You should look at the errorlog and application event log entries after trying to start the service.

     

     

    • Proposed as answer by DianaGh Wednesday, March 02, 2011 12:35 PM
    Wednesday, March 07, 2007 8:16 PM
  • I am getting the exact error, but find little more detail, I have deleted SQLExpress twice to try different things to fix this issue to no avail... Please provide your findings.
    Thursday, March 15, 2007 4:23 AM
  • With my issues, (see http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1352800&SiteID=1&mode=1) I was getting the 3417.  Mike Wachal posted a link to some solutions and one of them worked for me.
    Thursday, March 15, 2007 7:55 PM
  • I have read your issu because I had the same problem too... Please, go to the service it self, right click on it, click in properties -> Log on -> then select Local system account or try to use administrator's account. i'm not sure if your problem is permission's issue, but try it anyway. goodluck
    • Proposed as answer by k0ren Monday, February 08, 2010 2:41 PM
    Monday, April 02, 2007 8:47 AM
  • I had the same problem with ISA Server 2004 firewall service. Changing logon type to local system helps but to be honest it looks like temporary solution only.

    In my opinion it is a security/permisiion problem related to adding and removing the computers to/from domain.

    Saturday, May 12, 2007 11:46 AM
  • in my case , MSSQLSERVICE stopped after I commpress all folders where SQL is installed, I uncommpressed the entire folder of SQL Server.

    It resolved the problem.

     

    • Proposed as answer by DianaGh Wednesday, March 02, 2011 12:36 PM
    • Marked as answer by Naomi NModerator Friday, December 30, 2011 6:43 PM
    Friday, June 22, 2007 12:59 AM
  • The SQL Server folder and the data file folders should not be compressed as thi is not supported.

    Jens K. Suessmeyer.

    ---
    http://www.sqlserver2005.de
    ---
    Friday, June 22, 2007 11:43 AM
    Moderator
  • Hi to all and thanx!

    It worked for me: the NETWORK SERVICE account, that was set to be the one to run SQL Server, had no access to the folder where master db resided

    Though I did not touch permissions at all, it ended up in this situation.

    Thanx again.
    Tuesday, October 23, 2007 1:17 AM
  • Thank you atomy.  I had never seen this error before and did not know what to make of it.  Turns out I had compressed the DB files to make room on my laptop and SS does not like that.  Thanks again.

    • Edited by joeller Thursday, December 29, 2011 2:47 PM
    Wednesday, March 05, 2008 2:10 PM
  • Adding NETWORK SERVICE to the users who have rights on the sql server directory worked for me.
    Tuesday, April 22, 2008 8:31 AM
  • Thanks of lot ! It solved my issue.

    Add NETWORK SERVICE with full control permission to SQL Server install folder (C:\Program Files\Microsoft SQL Server\) and restart SQL service.
    Friday, June 06, 2008 5:52 PM
  •  gkakas wrote:
    Hi to all and thanx!

    It worked for me: the NETWORK SERVICE account, that was set to be the one to run SQL Server, had no access to the folder where master db resided

    Though I did not touch permissions at all, it ended up in this situation.

    Thanx again.
    This also worked for me.  I converted a FAT partition to NTFS and I think it was after that that the permissions issue arose.
    Monday, October 06, 2008 1:19 PM
  • Thanks a lot atomy. I did compress files on my laptop, which stopped SQL Service from accessing Master database MDF file. I uncompressed the MDF files in SQL Server folder, which fixed the issue.
    Wednesday, June 03, 2009 4:22 PM
  • Hi Jens.. thanks for this tip!!
    Thursday, December 29, 2011 3:20 AM
  •          Thanks Man, It worked for me.

    Tuesday, May 29, 2012 12:32 PM
  • I found that the disk utility (Windows Cleanup) compresses individual files.  In my case the folder with Master.mdf etc. was marked uncompressed.  The individual files in the folder were marked as compressed.  Right-click each file in the folder and uncheck compression on the advanced-tab.  The location of the Master.mdf is provided at the end of the C:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL\Log\ERRORLOG (ascii text file)
    • Edited by sefarkas Friday, November 16, 2012 7:45 PM file not folder
    Friday, November 16, 2012 7:44 PM
  • Great Call worked for us. An infection changed the Log On info for SQL Server (MSSMLBIZ), put it back to local PC and boom it worked.
    Monday, November 26, 2012 6:02 PM
  • Thank You! 

    It worked for me!

    Thursday, December 27, 2012 12:31 PM