none
Not able to run the package in 64 bit server

    Question

  • I created some SSIS packages. I am able to run these packages in BIDS without any issue. When the DBA tries to run the packages in the 64bit server, he is getting an error:

    The connection type "MSORA" specified for connection manager "Att_CPErrBatch" is not recognized as a valid connection manager type. This error is returned when an attempt is made to create a connection manager for an unknown connection type. Check the spelling in the connection type name.

    I have set Project Property Run64BitRuntime to True.

    Any help would be apprieciated.

    Thanks.

    Wednesday, April 13, 2011 1:58 PM

Answers

All replies

  • How is he trying to run them?  MSORA is there so is the oracle client and everything working on the server as well?  can you test it with SQL*PLUS to verify?

    Check the 32bit / 64bit section in this blog http://blogs.lessthandot.com/index.php/DataMgmt/DBAdmin/ssis-runs-in-bids-but-not-with-sql-agent


    Ted Krueger Blog on lessthandot.com @onpnt on twitter
    Please click the Mark as Answer button if a post solves your problem!
    Wednesday, April 13, 2011 2:05 PM
  • He is trying to run the packages using dtexec utility(64 bit version). I am not sure how you can verify with SQL*PLUS. Can you please tell me what to do?

    Thanks!

    Wednesday, April 13, 2011 2:31 PM
  • The DBA should know if Oracle is accessible from the SQL Server.  If you are indeed using an Oracle data source?  When I did this a few years back I was unable to get the 64bit oracle client install to work with SSIS and used the 32bit client.  Installing and getting the client to work is never an easy task but if other things are running there, it may already be done.

    So try executing the package from the 32bit DTEXEC installation folder.  If you provide the SSIS version, what you are doing with Oracle and also the server and oracle details, I may be able to answer this better.

     


    Ted Krueger Blog on lessthandot.com @onpnt on twitter
    Please click the Mark as Answer button if a post solves your problem!
    Wednesday, April 13, 2011 2:55 PM
  • I am using SSIS 2008. I am using Oracle Destination from Attunity to load data into Oracle tables. I have Oracle 10g and Oracle Client 10.2.0.1.0.

    I have set Project Property Run64BitRuntime to True. So I should be able to run SSIS packages (32 bit) in the 64 bit environment, right? Hope this helps.

    Wednesday, April 13, 2011 3:14 PM
  • No.  The Run64BitRuntime settings ONLY APPLIES IN BIDS.

    Please read through my article on 32-/64-bit considerations with SSIS.  The short guidance is that your DBA has to use the 32-bit DTExec in order to run the package.


    Todd McDermid's Blog Talk to me now on
    • Proposed as answer by Nik - Shahriar Nikkhah Wednesday, April 13, 2011 6:46 PM
    • Marked as answer by supjo Wednesday, April 20, 2011 1:36 PM
    Wednesday, April 13, 2011 4:23 PM
  • check http://msdn.microsoft.com/en-us/library/ms141766.aspx

    and check the section <drive>:\Program Files(x86)\Microsoft SQL Server\100\DTS\Binn

     

    '"E:\Program Files\Microsoft SQL Server (x86)\90\DTS\Binn\DTExec.exe" '

    or maybe

    '"C:\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\DTExec.exe" '


    Sincerely SH -- MVP, MCITP 2008, MCTS 2008 & 2005 -- Please kindly mark the post(s) that answered your question and/or vote for the post(s).
    Wednesday, April 13, 2011 5:24 PM
  • @Todd - Thanks for the reply.

    @Nik - In my local machine I do not see <drive>:\Program Files(x86)\Microsoft SQL Server\100\DTS\Binn, but I see <drive>:\Program Files\Microsoft SQL Server\100\DTS\Binn. So does this mean that I am using 64bit SSIS package in my local machine?

    Wednesday, April 13, 2011 5:51 PM
  • @Nik - In my local machine I do not see <drive>:\Program Files(x86)\Microsoft SQL Server\100\DTS\Binn, but I see <drive>:\Program Files\Microsoft SQL Server\100\DTS\Binn. So does this mean that I am using 64bit SSIS package in my local machine?


    you may not have it installed

    stroy short is that you have 2 DTExec one is the 64 bit *which SQL jobs uses) and one is the 32 bit that you have to direct for SQLJob otherwise sql job will use the 64bit


    Sincerely SH -- MVP, MCITP 2008, MCTS 2008 & 2005 -- Please kindly mark the post(s) that answered your question and/or vote for the post(s).
    Wednesday, April 13, 2011 5:56 PM
  • Ok I am gonna try that...running the SSIS packages with dtexec(32 bit version).
    Wednesday, April 13, 2011 6:05 PM