none
Client side printing issue

    Question

  • We have SQL 2008 reporting services report, Users try to click on "Printer" sign at report manager tool bar, however it seems there is way for the user to change the layout of the printing, for example, from Portrait to Landscape, etc. and the preview the report showing report get cut off.

    1. Is there anyway for user to change property of printing?
    2. How to avoid printing page getting cut off.

    Thanks
    Don
    Monday, December 07, 2009 5:26 PM

Answers

  • Hi Don,

    The user should be presented with a pop-up, whcih contains printer properties button. The users can change the settings there (e.g. orienatation).

    However, it is better if you make sure that the orientation is set properly in the report. You can change it by adjusting the report properties (easiest way would be to right-click on the yellow background in report designer and select properties - that is the background behind your report template). Then you can set margins, size, orientation, etc.

    To get the report to print on one page without getting cut off, you should design the report with the particular size in mind. All report elements should fit on a sheet of paper (A4,A3, Letter) and your report size should be adjusted accordingly. Test and make sure it prints out alright. If you have a matrix and the report size varies, you should test with different settings, and possibly adjust your column sizes to be such that even if the report gets cut off, that is done neatly - right on the border between columns.

    Boyan Penev --- http://bp-msbi.blogspot.com
    Tuesday, December 08, 2009 1:20 AM
  • Hi,

    Open Report and Click on "Report" in main menu bar
    Click on Report Properties
    Margins

    Left: .25in Right:.25in
    Top: .25in Bottom: .25in

    Set page width and Height as per your requirement (Your Report page size should be greater than Report Body Size)

    Check the below link for standard sizes
    http://www.dpandi.com/paper/index.html


    If you are using SSRS 2008 you will have options in landscape or portrait in Report Properties

    I hope this is helpful for you


    Rajesh Jonnalagadda http://www.ggktech.com
    Tuesday, December 08, 2009 6:16 AM
    Answerer

All replies

  • Hi Don,

    The user should be presented with a pop-up, whcih contains printer properties button. The users can change the settings there (e.g. orienatation).

    However, it is better if you make sure that the orientation is set properly in the report. You can change it by adjusting the report properties (easiest way would be to right-click on the yellow background in report designer and select properties - that is the background behind your report template). Then you can set margins, size, orientation, etc.

    To get the report to print on one page without getting cut off, you should design the report with the particular size in mind. All report elements should fit on a sheet of paper (A4,A3, Letter) and your report size should be adjusted accordingly. Test and make sure it prints out alright. If you have a matrix and the report size varies, you should test with different settings, and possibly adjust your column sizes to be such that even if the report gets cut off, that is done neatly - right on the border between columns.

    Boyan Penev --- http://bp-msbi.blogspot.com
    Tuesday, December 08, 2009 1:20 AM
  • Hi,

    Open Report and Click on "Report" in main menu bar
    Click on Report Properties
    Margins

    Left: .25in Right:.25in
    Top: .25in Bottom: .25in

    Set page width and Height as per your requirement (Your Report page size should be greater than Report Body Size)

    Check the below link for standard sizes
    http://www.dpandi.com/paper/index.html


    If you are using SSRS 2008 you will have options in landscape or portrait in Report Properties

    I hope this is helpful for you


    Rajesh Jonnalagadda http://www.ggktech.com
    Tuesday, December 08, 2009 6:16 AM
    Answerer
  • Boyan and Rajesh,

    Thanks for the tips, I will follow up with that.

    Don


    Don
    Tuesday, December 08, 2009 3:48 PM