none
Report execution error:The permissions granted to user are insufficient for performing this operation. (rsAccessDenied)

    Question

  • Hi,

     

    I created a report modelusing SSRS (2005) and then published it in the sharepoint which in turns opens report builder. But when i tried to run report for the model i published using report builder i do get the following error.

     

    Report execution error:The permissions granted to user are insufficient for performing this operation. (rsAccessDenied)

    Report might not valid or server couldnt process the data.

     

     

    Please let me know how to fix this.

     

    Skk0109

    Thursday, August 21, 2008 4:53 PM

Answers

  •  

    Hi,

     

    In IIS,

    Right click on Report Server

    Goto  Properties ->Directory Security and Click on Edit in Authentication and Access Controls.

    Uncheck Enable Anonymous access if it is checked.

     

    You are using Sharepoint, then  you need to Change the Default Database Server

    Goto SharePoint Central Administration -> Operations -> Data Configuration->Default Database Server,

    Change that Server Instance to your SQL Instance.

     

    the user must be Admin on the local machine of Report Server and Add Full Control Roles for the user in Report Manager Site Settings.

     

    Friday, August 22, 2008 4:39 AM

All replies

  •  

    Hi,

    Can you try Publishing it in Report Manager and Verify if it throwing the error or not.

    If not, Make the user who uses report on SharePoint as Farm Admin and Check.

    This might be an issue with the user privileges. Grant Database Permissions to the SharePoint users in SharePoint Central Administration

    Thursday, August 21, 2008 5:16 PM
  • Hi,

    I Published it in Report Manager and Verifed still same the error.

    I am the user who uses report on SharePoint as Farm Admin and Checked.

    and i dont know how to do this----Grant Database Permissions to the SharePoint users in SharePoint Central Administration

    Thursday, August 21, 2008 11:46 PM
  •  

    Hi,

     

    In IIS,

    Right click on Report Server

    Goto  Properties ->Directory Security and Click on Edit in Authentication and Access Controls.

    Uncheck Enable Anonymous access if it is checked.

     

    You are using Sharepoint, then  you need to Change the Default Database Server

    Goto SharePoint Central Administration -> Operations -> Data Configuration->Default Database Server,

    Change that Server Instance to your SQL Instance.

     

    the user must be Admin on the local machine of Report Server and Add Full Control Roles for the user in Report Manager Site Settings.

     

    Friday, August 22, 2008 4:39 AM
  • What if you are not using Sharepoint and Enable Anonymous access is unchecked and you are getting that error?  I can run reports from a windows front end utilizing the ReportViewer control, but utilizing the web front end I get the error: "The permissions granted to user 'GOCEIT\ASPNET' are insufficient for performing this operation. (rsAccessDenied)".

     

    Any additional information would be greatly appreciated.

     

    Thank you,

    Keith

     

    Tuesday, September 09, 2008 1:19 PM
  • Hi Keith,

     

    Add Full control Permissions to GOCEIT/ASPNET user on Reporting Services Folder located in your Program files.

    Path -> Program Files/Microsoft SQL Server/MSSQL.x/Reporting Services

    Tuesday, September 09, 2008 1:32 PM
  • No, that didn't do it either.  I have been battling with this for a while know and think I figured something out only to find out that wasn't it.  Thanks for the response.  Any other ideas?

     

    Keith

     

    Tuesday, September 09, 2008 5:11 PM
  • For me this problem was solved by redo the "Grant Database Defaults" in the Sharepoint Central Administration 3.0 application (found under Application/Reporting Services). The Sharepoint Integrated SQL Server Reporting services function just suddenly refused to work, giving me the error on this thread. I was eariler able to successfully run reports and create/edit datasources. But neither of that suddenly worked. We are using the Windows Firewall on the servers, and I couldn't successfully do the action "Grant database defaults" until I temporary disabled it, becauce I didn't have an defined exception for WMI, I assume. I don't have a clue why this function suddenly stoped work, but after doing this action everthing works again.

     

    /Johan

     

    Wednesday, October 22, 2008 11:46 AM
  •  

    I had a similar problem when running Reporting Services in SharePoint integration mode. The solution for me was to swith integration settings in Central Admin from "trusted account" to "Windows Authentication". It most likely because I enabled Kerberos for the main site. nothing else worked for me whatever I tried.

    Friday, November 07, 2008 7:46 PM
  •  
    hi there,

    this is what my current host (www.asphostcentral.com) did to install the Reporting Service 2008 for me.

    1. They asked me to provide a Report Server and Report Manager URL, e.g. www.myDomain.com/RS for Report Server and www.myDomain.com/RM for report Manager
    2. They begin to install the SSRS 2008 by specifying the above URL on the Web Service URL and Report Maanger URL
    3. They did create the Report Server Manager database for me
    4. Under the Service Account, they use my FTP details as the login details
    5. Once this is done, they created a user called "my_FTP_Username" on the Report Manager interface and assign the role: BROWSER and PUBLISHER for me.

    They then came back to me and informed that everything is up and running. I tested it out and yes, it was working perfectly. The MOST common issues that I can see is that usually you guys fails to assign the correct role to the FTP User. If you have an FTP User called: "abc" then, the BROWSER and PUBLISHER roles must be assigned to "abc" user.

    With just $4.99/month, I strongly believe that asphostcentral.com is worth a try. They did charge some fees for SSRS 2008, but it certainly recommended as there is no headache whatsover Smile

    I am a happy camper with them Smile

    P.S: I have not tried SSRS 2005. I jumped straight to use SSRS 2008 because I want new technology on my portal and I strongly believe that the setup of SSRS 2005 will be less about the same with the SSRS 2008.

    P.S2: If you are setting the SSRS on your LOCAL PC, that would be even easier. Why? Just assign your SSRS user an Administrator rights and everything will be working fine. If you do not know how to add your user as an Administrator, please go to your "Computer Management" and add the user under the "Administrator" groups. Fixed all Smile

     

    Monday, December 01, 2008 5:08 AM