none
SQL Full-text Filter Daemon Launcher - is it needed ?

    Question

  • We don't use fulltext searching, I am not sure why this service is enabled in SQL 2008 R2. Can I safely turn it off ?

    Thanks,

     

     


    Ranga
    Friday, November 11, 2011 3:45 PM

Answers

  • Thanks Jonathan for pointing about VAS.So,what do you recommend here ? Moving forward to a 64bit as a long term fix and as a short term patch SQL Server 2008 to SP3.

    Thank you,


    Anup | Forum Support| If you think my suggestion is useful, please rate it as helpful. If it has helped you to resolve the problem, please Mark it as Answer.
    Applying a service pack is not going to fix a 701, FAIL_VIRTUAL_RESERVE error at all so I wouldn't consider that a short term fix at all.  You have to look at the virtual address space on the server to understand the cause of the failed allocation and then maybe you can try a couple of thinks like bumping the size of the base VAS reservation from startup with ;-g384 or ;-g512 but then you are taking memory away from the plan cache on a 32 bit instance since the plan cache can't use AWE allocated memory, only the data cache can. If the problem is that the virtual address space is low overall, this might be a good fix, but if the problem is virtual address space fragmentation, using ;-g will only postpone the failures briefly, they will eventually reoccur and the fix is moving to 64bit where the virtual address space is not as limited.

    Jonathan Kehayias | Principal Consultant, SQLSkills.com
    SQL Server MVP | Microsoft Certified Master: SQL Server 2008
    Author of Troubleshooting SQL Server: A Guide for Accidental DBAs
    Feel free to contact me through My Blog or Twitter. Become a SQLskills Insider!
    Please click the Mark as Answer button if a post solves your problem!

    Friday, November 11, 2011 8:06 PM

All replies

  • You could turn it off, but I wouldn't.  Why do you think you need to disable it? 

    Jonathan Kehayias | Principal Consultant, SQLSkills.com
    SQL Server MVP | Microsoft Certified Master: SQL Server 2008
    Author of Troubleshooting SQL Server: A Guide for Accidental DBAs
    Feel free to contact me through My Blog or Twitter. Become a SQLskills Insider!
    Please click the Mark as Answer button if a post solves your problem!

    Friday, November 11, 2011 4:11 PM
  • It is a general prcactice not to run service which you don't need.

    Saw some memory related erros in the SQL log, prompted me to check the service accounts and noticed this new service.

    Thanks for your input.

     


    Ranga
    Friday, November 11, 2011 6:12 PM
  • It is a general prcactice not to run service which you don't need.

    Saw some memory related erros in the SQL log, prompted me to check the service accounts and noticed this new service.

    Thanks for your input.

     


    Ranga
    I have never had to go through disabling services in Windows to have proper performance with SQL Server.  In this case it is a service that could be required at some point in the future and disabling it makes no sense.  At most you are going to get 2MB of memory back.  A memory error in the SQL ERRORLOG is not going to be caused by this service running.  Post the error you got and lets look at the real cause of the problem.  

    Jonathan Kehayias | Principal Consultant, SQLSkills.com
    SQL Server MVP | Microsoft Certified Master: SQL Server 2008
    Author of Troubleshooting SQL Server: A Guide for Accidental DBAs
    Feel free to contact me through My Blog or Twitter. Become a SQLskills Insider!
    Please click the Mark as Answer button if a post solves your problem!

    Friday, November 11, 2011 6:20 PM
  • There is no harm by running this service.Please post your error to isolate the exact issue.
    Anup | Forum Support| If you think my suggestion is useful, please rate it as helpful. If it has helped you to resolve the problem, please Mark it as Answer.
    Friday, November 11, 2011 6:52 PM
  • Appreciate your response...

    ServerInfo:

    2011-11-08 20:03:50.89 Server      Microsoft SQL Server 2008 (RTM) - 10.0.1600.22 (Intel X86) 
    Enterprise Edition on Windows NT 6.0 <X86> (Build 6002: Service Pack 2)

    24 CPUs, SQL Max Memory: 13 GB, AWE enabled.

     

    I see 2 errors. not sure if they are related:

    1. CLR - CLR is not enabled and we don't use it.

    2011-11-11 06:48:59.63 spid611     Failed to initialize the Common Language Runtime (CLR) v2.0.50727 with HRESULT 0x80004005. You need to restart SQL Server to use CLR integration features.
    2011-11-11 06:48:59.63 spid611     Error: 6512, Severity: 16, State: 27.


    MS Recommendation to reinstall .Net 2.0 - http://support.microsoft.com/kb/2003681

    2. MS Recommendation for memory error is to install SQL 2008 SP2 - http://support.microsoft.com/kb/2003681

    I was not able to put all of them here...its failing to submit if I load all the error messages..

    2011-11-11 07:56:15.47 spid212     Error: 701, Severity: 17, State: 123.
    2011-11-11 07:56:15.47 spid212     There is insufficient system memory in resource pool 'internal' to run this query.

    2011-11-11 07:56:15.26 spid212      Failed Virtual Allocate Bytes: FAIL_VIRTUAL_RESERVE 2097152
    2011-11-11 07:56:15.26 spid212    
    Memory Manager                                   KB
    ---------------------------------------- ----------
    VM Reserved                                 1761220
    VM Committed                                 185212
    AWE Allocated                              13320192
    Reserved Memory                                1024
    Reserved Memory In Use                            0
    2011-11-11 07:56:15.26 spid212    
    Memory node Id = 0                               KB
    ---------------------------------------- ----------
    VM Reserved                                    8704
    VM Committed                                   8512
    AWE Allocated                                     0
    MultiPage Allocator                            6936
    SinglePage Allocator                         221448
    2011-11-11 07:56:15.26 spid212    
    Memory node Id = 1                               KB
    ---------------------------------------- ----------
    VM Reserved                                 1749700
    VM Committed                                 173992
    AWE Allocated                              13320192
    MultiPage Allocator                           18552
    SinglePage Allocator                         221448
    2011-11-11 07:56:15.26 spid212    
    Memory node Id = 32                              KB
    .

    .

    .

    ---------------------------------------- ----------
    Allocations                                    5297
    Rate                                           -233
    Target Allocations                           109850
    Future Allocations                                0
    Overall                                      137484
    Last Notification                                 1
    2011-11-11 07:56:15.47 spid212    
    MEMORYBROKER_FOR_RESERVE (default)            Pages
    ---------------------------------------- ----------
    Allocations                                       0
    Rate                                           -293
    Target Allocations                           135190
    Future Allocations                            30636
    Overall                                      137484
    Last Notification                                 1
    2011-11-11 07:56:15.47 spid212     Error: 701, Severity: 17, State: 123.
    2011-11-11 07:56:15.47 spid212     There is insufficient system memory in resource pool 'internal' to run this query.


    Ranga
    Friday, November 11, 2011 7:19 PM
  • The issue with error 'There is insufficient system memory in resource pool 'internal' to run this query' was fixed in CU9 for SQL Server 2008 SP1.

    You are running on SQL 2008 RTM,I would recommend you to proceed and deploy latest Service Pack for SQL Server 2008 which is SP3

    http://www.microsoft.com/download/en/details.aspx?id=27594

    Thank you,


    Anup | Forum Support| If you think my suggestion is useful, please rate it as helpful. If it has helped you to resolve the problem, please Mark it as Answer.
    Friday, November 11, 2011 7:32 PM
  • The error There is insufficient system memory in resource pool 'internal' to run this query' is related to Full Text Query,I was wondering why you got this as you said,you dont use Full Text Search or Query.Mostly there might be other reasons too.I was able to see a connect on this

    http://connect.microsoft.com/SQLServer/feedback/details/342696/there-is-insufficient-system-memory-in-resource-pool-internal-to-run-this-query

    At this point I would recommend -

    1.Turn on the Service if not already

    2. Patch SQL 20008 to SP3.


    Anup | Forum Support| If you think my suggestion is useful, please rate it as helpful. If it has helped you to resolve the problem, please Mark it as Answer.
    Friday, November 11, 2011 7:35 PM
  • I see 2 errors. not sure if they are related:

    1. CLR - CLR is not enabled and we don't use it.

    2011-11-11 06:48:59.63 spid611     Failed to initialize the Common Language Runtime (CLR) v2.0.50727 with HRESULT 0x80004005. You need to restart SQL Server to use CLR integration features.
    2011-11-11 06:48:59.63 spid611     Error: 6512, Severity: 16, State: 27.


    MS Recommendation to reinstall .Net 2.0 - http://support.microsoft.com/kb/2003681

    You generally have to uninstall .NET and reinstall it to fix this.  You should install .NET 2 and then .NET 3.5, which is required for SQL Server 2008.

    2. MS Recommendation for memory error is to install SQL 2008 SP2 - http://support.microsoft.com/kb/2003681

    I was not able to put all of them here...its failing to submit if I load all the error messages..

    2011-11-11 07:56:15.47 spid212     Error: 701, Severity: 17, State: 123.
    2011-11-11 07:56:15.47 spid212     There is insufficient system memory in resource pool 'internal' to run this query.

    2011-11-11 07:56:15.26 spid212      Failed Virtual Allocate Bytes: FAIL_VIRTUAL_RESERVE 2097152


    Ranga

    This is a VAS issue and it stems from the fact that you are running on a 32-bit SQL Server.  Click the link in my signature for my book, and download a free copy of the PDF eBook.  If you look at Chapter 4 Memory Management, I explain this in much further detail.  

    What I don't understand is why you are running a 32-bit instance of SQL Server on a 24 core system which would definitely support 64-bit computing.  This problem is very specific to 32-bit environments and there are potential work arounds, but all of them have negative trade offs, whereas moving to 64-bit only offers significant benefits across the board.


    Jonathan Kehayias | Principal Consultant, SQLSkills.com
    SQL Server MVP | Microsoft Certified Master: SQL Server 2008
    Author of Troubleshooting SQL Server: A Guide for Accidental DBAs
    Feel free to contact me through My Blog or Twitter. Become a SQLskills Insider!
    Please click the Mark as Answer button if a post solves your problem!

    Friday, November 11, 2011 7:40 PM
  • Thanks Jonathan for pointing about VAS.So,what do you recommend here ? Moving forward to a 64bit as a long term fix and as a short term patch SQL Server 2008 to SP3.

    Thank you,


    Anup | Forum Support| If you think my suggestion is useful, please rate it as helpful. If it has helped you to resolve the problem, please Mark it as Answer.
    Friday, November 11, 2011 7:55 PM
  • Thanks Jonathan for pointing about VAS.So,what do you recommend here ? Moving forward to a 64bit as a long term fix and as a short term patch SQL Server 2008 to SP3.

    Thank you,


    Anup | Forum Support| If you think my suggestion is useful, please rate it as helpful. If it has helped you to resolve the problem, please Mark it as Answer.
    Applying a service pack is not going to fix a 701, FAIL_VIRTUAL_RESERVE error at all so I wouldn't consider that a short term fix at all.  You have to look at the virtual address space on the server to understand the cause of the failed allocation and then maybe you can try a couple of thinks like bumping the size of the base VAS reservation from startup with ;-g384 or ;-g512 but then you are taking memory away from the plan cache on a 32 bit instance since the plan cache can't use AWE allocated memory, only the data cache can. If the problem is that the virtual address space is low overall, this might be a good fix, but if the problem is virtual address space fragmentation, using ;-g will only postpone the failures briefly, they will eventually reoccur and the fix is moving to 64bit where the virtual address space is not as limited.

    Jonathan Kehayias | Principal Consultant, SQLSkills.com
    SQL Server MVP | Microsoft Certified Master: SQL Server 2008
    Author of Troubleshooting SQL Server: A Guide for Accidental DBAs
    Feel free to contact me through My Blog or Twitter. Become a SQLskills Insider!
    Please click the Mark as Answer button if a post solves your problem!

    Friday, November 11, 2011 8:06 PM
  • Jonathan,

    Thank you very much...your insight is very much appreciated. BTW, It was nice seeing you/Paul/Kimberely and others at the SQL PASS. Now I know you all. :)

    Anup,

    Thanks for the responses.

     

     


    Ranga
    Friday, November 11, 2011 8:10 PM
  • Thanks Jonathan.Greatly appreciate that.
    Anup | Forum Support| If you think my suggestion is useful, please rate it as helpful. If it has helped you to resolve the problem, please Mark it as Answer.
    Friday, November 11, 2011 8:26 PM