none
Cannot open company file in Office Accounting - SQL Server problem?

    Question

  •  

    Hi guys,

    I recently installed Office Accounting 2007 Professional on a Windows Server 2003 machine with SQL Server 2005 (installed on an existing instance) and updated Office Accounting with service pack 1. However, after I have created the company file, other users were unable to open it. The error message was "The company could not be opened. Please ensure the SQL Server exists, the service is running and access has been granted."

    Below are some of the stuff I had done, but still cannot solve the problem:

    - Under "Manage users and roles", I granted full control to all users in the AD.
    - Made the company.sbc as well as the multiuser.sbc file available to everyone on the server's shared drive.
    - Granted full control to all users in the AD for the above mentioned shared drive.
    - Copied the company.sbc and multiuser.sbc files onto all client computers.
    - Ensured that SQL Server is running.
    - Checked the security options for the linked database to ensure all users have the necessary rights.
    - Enabled TCP/IP and named pipes as well as the port 5356 and have restarted the services.
    - Added port 5356 as an exception in Windows firewall on all client computers.
    - I even switched off Windows Firewall on the server just to eliminate this possibility!
    - Tried everything listed in http://support.microsoft.com/kb/910012

    I still get that error message on all client computers!!! What else have I left out? God bless me...
    Thursday, January 10, 2008 9:02 AM

Answers

  • Hiya guys!

    After 3 days since I uninstalled Microsoft Office 2007 in one of our accountant's pc, I've been struglling with the same problem, same error message "the company could not be opened. Please ensure that SQL Server exist...".
    I think I have the solution for this. I've found out that by default, when you install office accounting... it makes sample companies on "C:\Documents and Settings\(username)\My Documents\Small Business Accounting\Companies". And when sharing a company data it should go here "C:\Documents and Settings\All Users\Documents\Small Business Accounting\sampleproductcompany_multiuser.sbc". This I've noticed that if you try to make a multi-user company file to a different folder or restore one there and share it, other users that you've given access to that folder/company cannot connect to it using other computers on the network.

    In short, the multi-user company file should be shared in this location "C:\Documents and Settings\All Users\Documents\Small Business Accounting\sampleproductcompany_multiuser.sbc".

    Give it a try and post your reply. Thanks!
    Wednesday, March 11, 2009 10:39 AM
  • Well Ive had this problem with version 2007 and now 2009. The only solution I could get was using the default install on the server, using MS Sql Express and the default instance name.

    When you do that then you can connect from remote clients no matter where the .sbc file is stored!!!!!

    It seems that the instance name is somehow hardcoded somewhere, but this is definitely a bug!!!!!

    I would rather use a full version of SQL Server for the database.
    Wednesday, July 22, 2009 1:49 PM

All replies

  • Did you ever find resolution for this issue? I'm having a similar problem...I'm basically doing a test setup for a company. I have the following installed:

    MS Server 2008 Enterprise
    SQL Server 2008 Feb CTP
    MS Office Accounting 2008 Professional

    Everything installed fine with SQL Server 2005 Express, but I'm trying to move it over to SQL Server 2008. I've changed the instance MOA looks for and I've done all the things you listed above, but I get the following error when I try to create a new company:

    The database that you requested could not be opened, or access is denied.

    So it seems to be finding the database server, but it's like it doesn't have access to create a database. I configured the server to run under the Local Network service account and the Administrator account that I'm currently logged in with. I got the same error regardless of which user was running the server.

    Any ideas?
    Thursday, June 05, 2008 5:22 AM
  • Hiya guys!

    After 3 days since I uninstalled Microsoft Office 2007 in one of our accountant's pc, I've been struglling with the same problem, same error message "the company could not be opened. Please ensure that SQL Server exist...".
    I think I have the solution for this. I've found out that by default, when you install office accounting... it makes sample companies on "C:\Documents and Settings\(username)\My Documents\Small Business Accounting\Companies". And when sharing a company data it should go here "C:\Documents and Settings\All Users\Documents\Small Business Accounting\sampleproductcompany_multiuser.sbc". This I've noticed that if you try to make a multi-user company file to a different folder or restore one there and share it, other users that you've given access to that folder/company cannot connect to it using other computers on the network.

    In short, the multi-user company file should be shared in this location "C:\Documents and Settings\All Users\Documents\Small Business Accounting\sampleproductcompany_multiuser.sbc".

    Give it a try and post your reply. Thanks!
    Wednesday, March 11, 2009 10:39 AM
  • Well Ive had this problem with version 2007 and now 2009. The only solution I could get was using the default install on the server, using MS Sql Express and the default instance name.

    When you do that then you can connect from remote clients no matter where the .sbc file is stored!!!!!

    It seems that the instance name is somehow hardcoded somewhere, but this is definitely a bug!!!!!

    I would rather use a full version of SQL Server for the database.
    Wednesday, July 22, 2009 1:49 PM