none
failed to install sql server express due to Cannot alter the login 'sa'

    Question

  • Hi,

    I am using dell precision m60 laptop with xp professional sp2. I had trouble to install sql server due to "Cannot alter the login 'sa'". I am part of administrators for this machine. Below is the log. Any idea? thanks. -dale

    SQL_SUCCESS_WITH_INFO (1) in OdbcStatement::execute_batch
    sqlstate=01000, level=0, state=1, native_error=15457, msg=[Microsoft][SQL Native Client][SQL Server]Configuration option 'show advanced options' changed from 1 to 0. Run the RECONFIGURE statement to install.
     

    SQL_ERROR (-1) in OdbcStatement::execute_batch
    sqlstate=42000, level=16, state=1, native_error=15151, msg=[Microsoft][SQL Native Client][SQL Server]Cannot alter the login 'sa', because it does not exist or you do not have permission.
     

            Error Code: 0x80073b2f (15151)
    Windows Error Text:   Source File Name: lib\odbc_statement.h
    Compiler Timestamp: Mon Jun 13 14:30:24 2005
         Function Name: OdbcStatement::execute_batch@CnfgSQL@120
    Source Line Number: 91
     

     

    ---- Context -----------------------------------------------

     

    Connecting to SQL Server
    ExecuteSqlCommands
    USE [master      ]
    <Started SQL statement: Tue Feb 28 15:10:40 2006>declare @ServerName nvarchar(255) if not exists (select * from sysservers) begin select @ServerName = Convert(nvarchar(255), SERVERPROPERTY(N'ServerName')) execute sys.sp_addserver @ServerName, local end
    <Finished SQL statement: Tue Feb 28 15:10:41 2006>
    <Started SQL statement: Tue Feb 28 15:10:41 2006>ALTER DATABASE model SET RECOVERY SIMPLE
    <Finished SQL statement: Tue Feb 28 15:10:41 2006>
    <Started SQL statement: Tue Feb 28 15:10:41 2006>EXEC sp_configure N'show advanced options', 1 RECONFIGURE WITH OVERRIDE
    <Finished SQL statement: Tue Feb 28 15:10:41 2006>
    <Started SQL statement: Tue Feb 28 15:10:41 2006>DECLARE @Name AS nvarchar(128), @LangID AS smallint SELECT @Name=name, @LangID=langid FROM syslanguages WHERE lcid=1033 EXEC sp_defaultlanguage N'sa', @Name EXEC sp_configure N'default language', @LangID EXEC sp_configure N'default full-text language', 1033 RECONFIGURE WITH OVERRIDE
    <Finished SQL statement: Tue Feb 28 15:10:41 2006>
    <Started SQL statement: Tue Feb 28 15:10:41 2006>EXEC sp_configure N'show advanced options', 0 RECONFIGURE WITH OVERRIDE
    <Finished SQL statement: Tue Feb 28 15:10:41 2006>

     

    Tuesday, February 28, 2006 8:51 PM

Answers

  • Looks like if SQL Server 2005 RTM is installed in a Domain where a windows Group named 'sa', 'SA', 'Sa' or 'sA' exists, installation fails when Integrated Security is chosen.  However, despite having the Windows group in the Domain, installation with Mixed Security work fine.  After having installed successfully with Mixed Secuirty, the server properties can be changed to accept Integrated Security connections only. This should work.
    Wednesday, March 01, 2006 2:49 AM
  • thanks, Jeff. It is working now.
    Wednesday, March 01, 2006 3:55 AM

All replies

  • Looks like if SQL Server 2005 RTM is installed in a Domain where a windows Group named 'sa', 'SA', 'Sa' or 'sA' exists, installation fails when Integrated Security is chosen.  However, despite having the Windows group in the Domain, installation with Mixed Security work fine.  After having installed successfully with Mixed Secuirty, the server properties can be changed to accept Integrated Security connections only. This should work.
    Wednesday, March 01, 2006 2:49 AM
  • thanks, Jeff. It is working now.
    Wednesday, March 01, 2006 3:55 AM