none
Unable to load Client print control

    Question

  • I know this question has been asked and I have read all of the responses.  But, I seem to have a unique problem. 

    I am using Server 2008 r2 sp2 with ie8. And my problem is getting the error Unable to Load Client Print Control on the client machine for reporting services.

    The standard answer here is that the RSClientPrint.cab needs to be loaded on the client machine and installed with a click of the print icon with admin rights.  I have done that as a administrator and the print icon works fine as an adminstrator.  However, when I log as a non-admin user, that is when I get the error.  The rsclientprint.dll shows up in the registry, but it just does not work for a non-admin user.

    I have a open ticket with a MSDN tech at Microsoft, but he seems to be at a loss and is not trying very many things that lead me to believe that this can be resolved.

    I am wondering if some else out here has had this problem and got it to work.

    Thanks for any help.

    Friday, July 19, 2013 6:02 PM

Answers

  • Hi KeithTexas,

    It seems that the non-Administrator users don't have sufficient permissions on the “Downloaded Program Files” folder where the RSClientPrint control is stored. So, please grant to the user:

    1.Open C:\Windows, right-click on the “Downloaded Program Files” folder and click “Properties”.

    2.Switch to the “Security” tab, click “Edit”.

    3.In the “Security” window, click “Add” and add the specific user to the list.

    4.Check the “Allow” box for “Read & execute” permission and click “OK”.

    Regards, 


    Mike Yin
    TechNet Community Support

    • Proposed as answer by Ravi A Davawala Wednesday, July 24, 2013 1:03 PM
    • Marked as answer by KeithTexas Thursday, July 25, 2013 2:17 PM
    Wednesday, July 24, 2013 9:58 AM
  • we used to have same situation and what we did that for Downloaded Program Files folder we have given full rights to the users.

    Regards

    • Marked as answer by KeithTexas Thursday, July 25, 2013 2:17 PM
    Wednesday, July 24, 2013 1:03 PM
  • Thanks for the answers.  We resolved this issue with this solution.  However, on some machines, we had to go some registry keys and add the user domain in the permissions and that worked also.

    Thanks for the help.

    • Marked as answer by KeithTexas Thursday, July 25, 2013 2:17 PM
    Thursday, July 25, 2013 2:17 PM

All replies

  • Hi KeithTexas,

    It seems that the non-Administrator users don't have sufficient permissions on the “Downloaded Program Files” folder where the RSClientPrint control is stored. So, please grant to the user:

    1.Open C:\Windows, right-click on the “Downloaded Program Files” folder and click “Properties”.

    2.Switch to the “Security” tab, click “Edit”.

    3.In the “Security” window, click “Add” and add the specific user to the list.

    4.Check the “Allow” box for “Read & execute” permission and click “OK”.

    Regards, 


    Mike Yin
    TechNet Community Support

    • Proposed as answer by Ravi A Davawala Wednesday, July 24, 2013 1:03 PM
    • Marked as answer by KeithTexas Thursday, July 25, 2013 2:17 PM
    Wednesday, July 24, 2013 9:58 AM
  • we used to have same situation and what we did that for Downloaded Program Files folder we have given full rights to the users.

    Regards

    • Marked as answer by KeithTexas Thursday, July 25, 2013 2:17 PM
    Wednesday, July 24, 2013 1:03 PM
  • Thanks for the answers.  We resolved this issue with this solution.  However, on some machines, we had to go some registry keys and add the user domain in the permissions and that worked also.

    Thanks for the help.

    • Marked as answer by KeithTexas Thursday, July 25, 2013 2:17 PM
    Thursday, July 25, 2013 2:17 PM
  • hi Keith,

    will you please help to share wt details you did on the registry key to overcome this issue?

    thanks in advance.

    Regards,

    yes.sudhanshu


    yes.sudhanshu

    http://bproud2banindian.blogspot.com
    http://ms-crm-2011-beta.blogspot.com

    Monday, January 06, 2014 7:36 AM