none
SQL services wont start due to incorrect drive letter after windows restore

    Question

  • SQL services wont start due to incorrect drive letter after windows restore


    Had a server crash, was successfully able to reinstall windows and restore the server SQL and all the necessary services were already installed.

    Only problem the windows drives letters are wrong. So the services are pointed to the incorrect drive letter. I cant change the services in regedit or change the drive letter in disk management. Is there a way to do a repair in SQL add remove programs to associate's the necessary services with the correct drive letter?


    Here's a example of the services
    Path to executable
    I:\Program Files\Microsoft SQL Server\MSSQL.1\

    only problem the actual drive letter is E:


    Services that wont start
    SQL SERVER
    SQL SERVER AGENT
    SQL Server Analysis
    SQL Server Analysis Services
    SQL Server Integration Services
    SQL Server Reporting Services
    Thursday, January 17, 2013 8:01 PM

Answers

  • If you have your binaries present in the I:\ drive which is now the E:\ drive, then either you have to rename the drive back to I:\ or you would need to backup all the .mdf, .ndf, .ldf files. Uninstall existing SQL instance and reinstall a new instance with the same name, apply any SP/CU and attach all the databases.
    Sunday, January 20, 2013 4:58 PM

All replies

  • Stop the services and rename the I driveletter. Its done in disk management. Start the services again.

    is this an option?

    Thursday, January 17, 2013 9:13 PM
  • Can you try changing the drive letter in the SQL server configuration manager startup parameters? Please read the following article for detailed steps

    http://msdn.microsoft.com/en-us/library/ms345416(v=sql.90).aspx

    Regards

    Sathish S N

    Friday, January 18, 2013 10:43 AM
  • Hi,

    For changing drive letters you can use following steps.

    1. In SQL Server Configuration Manager, click SQL Server 200x Services.

    2. In the right pane, right-click SQL Server (<instance_name>), and then click Properties.

    3. On the Advanced tab, in the Startup Parameters box, type the parameters separated by semicolons (;).

      For example, to start in single-user mode, insert -m; in front of the existing startup options, and then restart the database.

      ms345416.note(en-US,SQL.90).gifImportant:
      After you are finished using single-user mode, you must remove the -m; from the Startup Parameters box before you can restart the server instance in the normal multi-user mode.
    4. Click OK.

    5. Restart the Database Engine.

    The other way is change the dive letter using disk management tool from E:\ to I: or I: to E:



    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Waqas

    MS(SPM), MS(E&F), MCP, MCT, MCTS, MCITP, MCSE, MCPD, MCSD, MCDBA , Author
    Twitter: @waqas8777
    Linked In: http://www.linkedin.com/in/waqasm1

    • Proposed as answer by Waqas M Wednesday, January 23, 2013 3:41 AM
    Sunday, January 20, 2013 4:33 PM
  • If you have your binaries present in the I:\ drive which is now the E:\ drive, then either you have to rename the drive back to I:\ or you would need to backup all the .mdf, .ndf, .ldf files. Uninstall existing SQL instance and reinstall a new instance with the same name, apply any SP/CU and attach all the databases.
    Sunday, January 20, 2013 4:58 PM