none
Error code 0x84B20001 2008R2 SP 1 failed in cluster :

    Question

  •  I tried to install SP1 in SQL Server 2008R2 .First I got this Error code 0x84B20001." A failure was detected [SQL_Replication_Core_Inst, SQL_Engine_Core_Inst,MPT_AGENT_CORE_CNI,]" and I tried to repair  SQL Server .

    In my case:  Node (B - passive and I  tried to install SP1) and Node (A- active) . I disconnect node B and let node A be a owner . 

     My repair failed for Database Engine and SQL Server Replication and in summery.txt suggest  " The SQL Server feature 'SQL_Engine_Core_Inst' is not a supported state for repair , as it was never successfully configured on remote node A. To continue , remove the specific SQL Server  node A from the cluster ."

    what to do now please suggest me.  


    TP
    Wednesday, December 21, 2011 8:51 PM

Answers

  • Hi whatsUpYo,

    Before you repair for SQL Server failover clusters, review the following important information:

    Repair must be run on individual cluster nodes.
    To repair a failover cluster node after a failed Prepare operation, use Remove node and then perform the Prepare step again.

    For more information, see How to Add or Removed Nodes in a SQL Server Failover Cluster: http://msdn.microsoft.com/en-us/library/ms191545.aspx.

    SQL Server 2008 failover cluster rolling patch and service pack process: http://support.microsoft.com/kb/958734.


    Thanks,
    Maggie


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.
    Thursday, January 05, 2012 3:03 AM

All replies